Failure Audit event entries are unexpectedly logged to the security event log when you search a file in Windows 2000

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Article ID: 840955 - View products that this article applies to.
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SYMPTOMS

When you try to search for files that are located in a folder that is configured to audit access to the files that are in the folder, Failure Audit event entries may be unexpectedly logged in the security event log.

CAUSE

This problem may occur if all the following conditions are true:
  • Windows tries to search a file.
  • The following permissions on the folder and on the files that are in the folder are set to Deny for your user account:
    • Create Files / Write Data
    • Create Folders / Append Data
    • Write Attributes
    • Write Extended Attributes
    • Change Permissions
    • Take Ownership
  • The folder is configured to audit failure access events for the Deny permissions that are configured for your user account.
  • You search the folder for a file by using either of the following criteria:
    • A keyword in the file name.
    • A keyword in the text in the file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows 2000 Service Pack 4 must be installed before you apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   20-May-2004  16:16  5.0.3900.6923  2,358,544  Shell32.dll      
   16-May-2004  19:43  5.0.2195.6928  5,873,664  Sp3res.dll   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 840955 - Last Review: October 26, 2013 - Revision: 2.7
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbwin2000sp5fix kbwin2000presp5fix kbeventlog kbuser kbsecurity kbfix kbbug KB840955

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