Help and Support

Error message after you download a .ZIP file from a document library in Windows SharePoint Services: "Cannot open file"

Article ID:841120
Last Review:May 15, 2007
Revision:3.2

SYMPTOMS

After you download a .ZIP file from a Microsoft Windows SharePoint Services document library, and then you try to open the .ZIP file, you may receive the following error message:
Cannot open file: it does not appear to be a valid archive.  If you downloaded this file, try downloading the file again.

Back to the top

CAUSE

This problem may occur if HTTP compression is turned on in the Web Sites properties of Microsoft Internet Information Services (IIS) on the SharePoint virtual server. When you download a .ZIP file, IIS encodes the file as GZIP. However, the browser client passes the file directly to the unZIP program, without GZIP decoding the file.

To determine if HTTP compression is turned on, follow these steps:
1.Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2.Expand the server (local computer) tree, where server (local computer) is the name of your IIS server.
3.Right-click Web Sites, and then click Properties.
4.Click the Service tab to view the HTTP compression properties.

Back to the top

WORKAROUND

To work around this problem, change the MIME type for the .ZIP file from application/x-zip-compressed to application/octet-stream. To change the MIME type, follow these steps:
1.Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. Right-click the server (local computer) tree, where server (local computer) is the name of your IIS server, and then click Properties.
3.Click MIME Types.
4.Scroll down the registered MIME type list to find the .zip entry.
5.Click the .zip application/x-zip-compressed entry, and then click Edit.
6.Change the MIME type value to application/octet-stream.
7.Stop and then restart the IIS Admin Service to apply the change to the MIME type.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top


APPLIES TO
Microsoft Windows SharePoint Services 3.0
Microsoft Windows SharePoint Services 2.0
Microsoft Office SharePoint Server 2007
Microsoft Office SharePoint Portal Server 2003

Back to the top

Keywords: 
kbopenfile kbtshoot kbprb kbhttp kbwebservices kbwebserver kbclientserver kbclient kberrmsg kbinterop kbnofix KB841120

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.