Error message when you try to connect to a Windows SharePoint document library: "System error 5 has occurred"

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Article ID: 841215 - View products that this article applies to.
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Symptoms

Consider the following scenarios.

Scenario 1
  • Your computer is running one of the following operating systems:
    • Windows Vista
    • Windows XP Service Pack 2 (SP2) or a later version of Windows XP
    • The 64-bit version of Windows XP or a later version of Windows XP
    • Windows Server 2003 Service Pack 1 (SP1) or a later version of Windows Server
  • You use the net use Windows command to map a drive to a Windows SharePoint Services 3.0 or Windows SharePoint Services 2.0 website.
  • You type your user name and password.
In this scenario, you may receive an error message that resembles the following:

System error 5 has occurred.

Access is denied.

Scenario 2
  • Your computer is running one of the following operating systems:
    • Windows Vista
    • Windows XP Service Pack 2 (SP2) or a later version of Windows XP
    • The 64-bit version of Windows XP or a later version of Windows XP
    • Windows Server 2003 Service Pack 1 (SP1) or a later version of Windows Server
  • You try to view a Windows SharePoint Services 3.0 or Windows SharePoint Services 2.0 document library by using Explorer View.
  • You type your user name and password several times, and then click Cancel.
In this scenario, the web folders are displayed unexpectedly.


Cause

This issue can occur if the server that is running Windows SharePoint Services 3.0 or Windows SharePoint Services 2.0 is configured to use Basic Authentication.

Note For security purposes, Windows Vista and Windows XP SP2 disable Basic authentication in the Web Distributed Authoring and Versioning (WebDAV) Redirector. Both Explorer View in Windows SharePoint Services and the Windows shell commands that are associated with Windows SharePoint Services use WebDAV redirector technology.

Workaround

To work around this issue, enable Basic Authentication on the client computer. To have us enable Basic authentication on the client computer for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. In the File Download dialog box, click Run, and then follow the steps in the Fix it Wizard.


Fix this problem
Microsoft Fix it 50623


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

Windows XP and Windows Server 2003

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To enable Basic authentication on the client computer, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type UseBasicAuth, and then press Enter.
  6. On the Edit menu, click Modify.
  7. In the Value data box, type 1, and then click OK.

    Note Basic authentication is enabled if the UseBasicAuth registry entry is set to a non-zero value. Basic authentication is disabled if the UseBasicAuth registry entry is not present or if the UseBasicAuth registry entry is set to 0 (zero).
  8. Exit Registry Editor, and then restart the computer.

Windows Vista

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To enable Basic authentication on the client computer, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
     Start button
    , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type BasicAuthLevel, and then press Enter.
  5. On the Edit menu, click Modify.
  6. In the Value data box, type 2, and then click OK.

    Note The mapping is as follows:
    • 0 - Basic authentication disabled
    • 1 - Basic authentication enabled for Secure Sockets Layer (SSL) shares only
    • 2 or greater - Basic authentication enabled for SSL shares and for non-SSL shares
  7. Exit Registry Editor, and then restart the computer.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.

More information

WebDAV is an extension of the HTTP protocol. WebDAV includes Basic Authentication.

Note Authentication is how a user is identified to a server.

When Basic Authentication is used, the user's user name and password are not encrypted and can be intercepted by someone else. This can pose a security risk.

The DAV redirector in Windows XP Service Pack 1 and earlier versions of Windows does not support encrypted HTTP protocols if the server is configured to use Basic Authentication. To help keep computers and networks secure, Windows Vista and Windows XP SP2 include functionality that lets you control the use of Basic Authentication by the DAV redirector.

In Windows Vista and later versions of Windows, the DAV redirector supports encrypted HTTP protocols. This includes the SSL protocol. By default, Basic Authentication is disabled unless SSL is enabled.


References

For more information about Windows SharePoint Services 3.0, visit the Microsoft Windows SharePoint Services 3.0 website.

For more information about Windows SharePoint Services 2.0, visit the Windows SharePoint Services 2.0 in Windows Server 2003 website.

Properties

Article ID: 841215 - Last Review: July 12, 2013 - Revision: 8.2
Applies to
  • Microsoft Windows SharePoint Services 3.0
  • Microsoft Windows SharePoint Services 2.0
  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft Office SharePoint Server 2007
Keywords: 
kberrmsg kbprb kbfixme kbmsifixme KB841215

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