You cannot establish a VPN connection by using a dial-up connection on a Windows XP-based computer

Article translations Article translations
Article ID: 841566 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You try to establish a virtual private network (VPN) connection by using a dial-up connection on a Microsoft Windows XP-based computer.
  • The Windows XP-based computer uses a Cisco VPN client.
  • The Windows XP-based computer uses a security solution that implements an intermediate driver by using a custom filter class. For example, the computer may use a security solution such as Senforce Enterprise Mobile Security Manager.
In this scenario, the VPN client cannot establish the connection and stops responding.

CAUSE

This problem occurs because the binding that connects the TCP/IP protocol, the Cisco VPN driver, and the dial-up networking stack (NDISWAN) is not handled correctly in this scenario.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ndis.sys5.1.2600.1577168,19220-Jul-200401:53x86SP1SP1QFE
Nwlnkipx.sys5.1.2600.157584,86411-Jul-200419:01x86SP1SP1QFE
Windows XP, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ndis.sys5.1.2600.1577579,32816-Jul-200412:16IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 841566 - Last Review: October 9, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp1fix kbbug kbfix KB841566

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com