Sie empfangen "Hardware kann nicht installiert werden" oder "während der Installations ist ein Fehler aufgetreten" Fehlermeldung, wenn Sie versuchen, ein PCI-Gerät installieren

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Problembeschreibung

Wenn Sie versuchen, ein neues Gerät (PCI = Peripheral Component Interconnect) oder eine PCI-Gerätetreiber zu installieren, erhalten Sie eine der folgenden Fehlermeldungen angezeigt:
Diese Hardware kann nicht installiert werden. Beim Installieren der folgenden Hardwarekomponente ein Problem aufgetreten.
Während der Installation des Geräts ist ein Fehler aufgetreten. Die Daten sind ungültig.
Angenommen, Sie erhalten möglicherweise eine dieser Fehlermeldungen angezeigt Wenn Sie versuchen, ein PCI-Modem oder eine PCI-Modem-Treiber zu installieren.

Ursache

Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
  • Ein Registrierungsunterschlüssel hat nicht die Standardberechtigungen ordnungsgemäß festgelegt. Die Standardberechtigungen ist möglicherweise geändert wurden.
  • Das Installationsprogramm für das Gerät erfordert andere Berechtigungen, die weniger streng als die Standardberechtigungen sind.
Hinweis Die folgende Liste enthält die relevanten Standardberechtigungen für Unterschlüssel in der Registrierung:
  • Jeder: Read
  • System: Vollzugriff

Lösung

Wichtig Dieser Abschnitt, die Methode oder die Aufgabe enthält Schritte, die erklären, wie Sie die Windows-Registry ändern. Es können schwerwiegende Probleme auftreten, wenn Sie die Windows-Registry falsch ändern. Stellen Sie daher sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie Änderungen vornehmen. Dann können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Für Weitere Informationen zum Sichern und Wiederherstellen der Registrierung, klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:
322756 Sichern und Wiederherstellen der Registrierung in Windows

Methode 1: Wiederherstellen der Standardeinstellungen auf den Registrierungsunterschlüssel für Ihr Gerät

Wenn Sie feststellen können, welche Unterschlüssel mit diesem Problem verknüpft ist, bearbeiten Sie die Registrierung, um die richtigen Einstellungen auf diesen Unterschlüssel zu konfigurieren. Informationen über die Behebung des Problems und bestimmen, welche Unterschlüssel von diesem Problem betroffen ist finden Sie im Abschnitt "Weitere Informationen". So konfigurieren die richtigen Einstellungen auf einen bestimmten Unterschlüssel:
  1. Melden Sie sich am Computer mit einem Konto an, das über administrative Anmeldeinformationen verfügt.
  2. Klicken Sie auf Start, klicken Sie auf Ausführen, Typ Regedit Klicken Sie im Dialogfeld Öffnen Feld, und klicken Sie dann auf OK.
  3. Suchen Sie den folgenden Registrierungsschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\PCI
  4. Mit der rechten Maustaste des Unterschlüssels, der die das Gerät verbunden ist, bei denen das Symptom auftritt, und klicken Sie dann auf Berechtigungen.
  5. Klicken Sie auf Erweiterte, und klicken Sie dann auf die Berechtigungen Registerkarte.
  6. Stellen Sie sicher, dass die folgenden Standardberechtigungen konfiguriert sind:
    • "Jeder": Lesen
    • System: Vollzugriff
  7. Aktivieren Sie die Ersetzen Sie Berechtigungseinträge für alle untergeordneten Objekte durch angezeigten Einträge, die auf untergeordnete Objekte anwenden Aktivieren Kontrollkästchen Sie, und klicken Sie dann auf Anwenden.
  8. Klicken Sie auf "Ja", und klicken Sie dann auf OK zwei Mal.
  9. Beenden Sie den Registrierungseditor.
  10. Wenn das Problem nicht behoben wird, wiederholen Sie diesen Vorgang, und gewähren Sie Vollzugriff Berechtigungen jeder Gruppe auf diesen Unterschlüssel.

Methode 2: Wiederherstellen der Standardberechtigungen für den PCI-Schlüssel und Unterschlüssel

  1. Melden Sie sich am Computer mit einem Konto an, das über administrative Anmeldeinformationen verfügt.
  2. Klicken Sie auf Start, klicken Sie auf Ausführen, Typ Regedit Klicken Sie im Dialogfeld Öffnen Feld, und klicken Sie dann auf OK.
  3. Suchen Sie den folgenden Registrierungsschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\
  4. Mit der rechten Maustaste PCI, und klicken Sie dann auf Berechtigungen.
  5. Stellen Sie sicher, dass die folgenden Standardberechtigungen konfiguriert sind:
    • "Jeder": Lesen
    • System: Vollzugriff
  6. Klicken Sie auf Erweiterte, aktivieren Sie die Ersetzen Sie Berechtigungseinträge für alle untergeordneten Objekte durch angezeigten Einträge, die auf untergeordnete Objekte anwenden Aktivieren Kontrollkästchen Sie, und klicken Sie dann auf Anwenden.
  7. Klicken Sie auf "Ja", und klicken Sie dann auf OK zwei Mal.
  8. Beenden Sie den Registrierungseditor.

Weitere Informationen

Konfigurieren Sie für die erweiterte Problembehandlung die Datei "Setupapi.log", um die ausführliche Protokollierung verwenden, und klicken Sie dann versuchen Sie, den Gerätetreiber zu installieren.

Hinweis Ausführlicher Protokollierung erhöht die Größe der Datei "Setupapi.log". Es wird empfohlen, dass Sie nur verwenden, ausführliche Protokollierung, während Sie Probleme behandeln. Wenn Sie fertig sind, löschen die LogLevel Wert, der ausführliche Protokollierung zu deaktivieren.

Das Protokoll kann genau welche Registrierungsunterschlüssel auf das Symptom beziehen, die dieser Artikel beschreibt, aufzeichnen. Ausführlichen Protokollierung zu konfigurieren:
  1. Melden Sie sich am Computer mit einem Konto an, das über administrative Anmeldeinformationen verfügt.
  2. Klicken Sie auf Start, klicken Sie auf Ausführen, Typ Regedit Klicken Sie im Dialogfeld Öffnen Feld, und klicken Sie dann auf OK.
  3. Suchen Sie den folgenden Registrierungsschlüssel:
    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup
  4. Mit der rechten Maustaste Setup, zeigen Sie auf Neue, und klicken Sie dann auf DWORD-Wert.
  5. Typ LogLevelBenennen Sie den Wert, und drücken dann die EINGABETASTE.
  6. Mit der rechten Maustaste die LogLevel Wert, den Sie soeben erstellt haben, klicken Sie auf Ändern, Typ 0xFFFF Klicken Sie im Dialogfeld Wert Feld ein, und klicken Sie dann auf OK.
  7. Benennen Sie die vorhandene Datei "Setupapi.log" in Setupapi.old.

Eigenschaften

Artikel-ID: 841567 - Geändert am: Sonntag, 30. Dezember 2012 - Version: 3.0
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  • Microsoft Windows XP Professional
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 841567
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