U ontvangt een 'kan deze hardware niet installeren' of 'is een fout opgetreden tijdens de installatie' foutbericht wanneer u een PCI-apparaat

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 841567 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u een nieuwe PCI-apparaat of een PCI-stuurprogramma installeert, wordt een van de volgende foutberichten weergegeven:
Deze hardware installeren niet. Er is een probleem met de installatie van deze hardware.
Er is een fout opgetreden tijdens de installatie van het apparaat. De gegevens zijn ongeldig.
Bijvoorbeeld, wordt een van deze foutberichten als een PCI-modem of een PCI-modem-stuurprogramma installeren.

Oorzaak

Dit probleem kan optreden als een van de volgende voorwaarden voldaan is:
  • Een registersubsleutel geen standaardmachtigingen correct ingesteld. De standaardmachtigingen zijn mogelijk gewijzigd.
  • Het installatieprogramma voor uw apparaat aanvullende machtigingen soepeler dan de standaardmachtigingen zijn vereist.
OpmerkingDe volgende lijst bevat de relevante standaardmachtigingen voor subsleutels in het register:
  • Iedereen: Lezen
  • Systeem: Volledige controle

Oplossing

BelangrijkDeze sectie, methode of taak bevat stappen voor het wijzigen van het register. Echter, kunnen ernstige problemen optreden als u het register onjuist bewerkt. Zorg ervoor dat u deze zorgvuldig stappen. Reservekopie van het register voordat u het wijzigen voor extra bescherming. Vervolgens kunt u het register herstellen als er een probleem optreedt. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over back-up en terugzetten van het register:
322756Back-up en terugzetten van het register in Windows

Methode 1: De standaardinstellingen herstellen voor de subsleutel voor uw apparaat

Als u welke subsleutel voor dit probleem vaststellen kunt, het register configureren van de juiste instellingen op die subsleutel te bewerken. Zie de sectie 'Meer informatie' voor informatie over het oplossen van dit probleem en bepalen welke subsleutel is dit probleem optreedt. De juiste instellingen configureren op een bepaalde subsleutel:
  1. Meld u bij de computer met een account die beheerdersreferenties heeft.
  2. Klik opStart, klik opUitvoeren, typRegeditin deOpenvak en klik vervolgens opOK.
  3. Zoek de volgende registersleutel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\PCI
  4. Klik met de rechtermuisknop op de subsleutel die is gerelateerd aan het apparaat dat het probleem zich voordoet en klik vervolgens opMachtigingen.
  5. Klik opGeavanceerde, en klik vervolgens op deMachtigingentabblad.
  6. Controleer of de volgende standaardmachtigingen zijn geconfigureerd:
    • Iedereen: Lezen
    • Systeem: Volledige controle
  7. Selecteer deMachtigingen voor alle onderliggende objecten vervangen door de weergegeven vermeldingen die op onderliggende objecten van toepassingen klik vervolgens opToepassen.
  8. Klik opJa, en klik vervolgens opOKtwee keer.
  9. Sluit Register-Editor.
  10. Als het probleem niet is opgelost, herhaalt u deze procedure en volledig beheer verlenen machtigingen aan iedereen groeperen op deze subsleutel.

Methode 2: De standaardmachtigingen voor de PCI-sleutel en subsleutels herstellen

  1. Meld u bij de computer met een account die beheerdersreferenties heeft.
  2. Klik opStart, klik opUitvoeren, typRegeditin deOpenvak en klik vervolgens opOK.
  3. Zoek de volgende registersleutel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\
  4. Klik met de rechtermuisknopPCI, en klik vervolgens opMachtigingen.
  5. Controleer of de volgende standaardmachtigingen zijn geconfigureerd:
    • Iedereen: Lezen
    • Systeem: Volledige controle
  6. Klik opGeavanceerde, selecteer deMachtigingen voor alle onderliggende objecten vervangen door de weergegeven vermeldingen die op onderliggende objecten van toepassingen klik vervolgens opToepassen.
  7. Klik opJa, en klik vervolgens opOKtwee keer.
  8. Sluit Register-Editor.

Meer informatie

Het bestand Setupapi.log logboekregistratie configureren voor geavanceerde probleemoplossing en probeer vervolgens het stuurprogramma te installeren.

OpmerkingUitgebreide logboekregistratie verhoogt de grootte van het bestand Setupapi.log. Het is raadzaam dat alleen u uitgebreide logboekregistratie tijdens het oplossen van problemen. Wanneer u klaar bent, verwijdert deLogLevelwaarde logboekregistratie uitschakelen.

Het logboek kan vastleggen precies welke registersubsleutel is gerelateerd aan het symptoom dat in dit artikel wordt beschreven. Logboekregistratie configureren:
  1. Meld u bij de computer met een account die beheerdersreferenties heeft.
  2. Klik opStart, klik opUitvoeren, typRegeditin deOpenvak en klik vervolgens opOK.
  3. Zoek de volgende registersleutel:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup
  4. Klik met de rechtermuisknopSetup, wijsNieuwe, en klik vervolgens opDWORD-waarde.
  5. TypeLogLevelnaam van de nieuwe waarde en druk op ENTER.
  6. Met de rechtermuisknop op deLogLevelde waarde die u zojuist hebt gemaakt, klikt u opWijzigen, typ0xffffin deWaardegegevens in en klik vervolgens opOK.
  7. Wijzig de naam van het bestaande bestand Setupapi.log Setupapi.old.

Eigenschappen

Artikel ID: 841567 - Laatste beoordeling: vrijdag 25 maart 2011 - Wijziging: 4.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows XP Professional
Trefwoorden: 
kbprb kbmt KB841567 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:841567

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com