BOGUE : programme d'installation SQL Server cesse de répondre lors de la mise à niveau une instance de SQL Server Desktop Engine (Windows) vers SQL Server 2000

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Numéro d'article: 841773 - Voir les produits auxquels s'applique cet article
Bogue #: 470856 (SQL Server 8.0)
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Symptômes

Mise à niveau une instance par défaut de SQL Server 2000 vers SQL Server 2000 Service Pack 3 (SP3) sur un ordinateur qui exécute Microsoft Windows Small Business Server 2003. Si vous essayez de mettre à l'instance de Microsoft SQL Server 2000 Desktop Engine (Windows) qui correspond à Windows SharePoint Services vers SQL Server 2000 niveau, le programme d'installation de SQL Server cesse de répondre. Vous recevez le message d'erreur suivantes :
Programme d'installation se prépare à copier des fichiers

Cause

Le Gestionnaire de contrôle des services (scm.exe) rencontre un délai d'expiration lorsqu'il tente d'arrêter le service MSSQL $ SharePoint.

note Le service MSSQL $ SharePoint est le service Microsoft Windows pour l'instance de SQL Server 2000 Desktop Engine (Windows qui correspond à Windows SharePoint Services).

Contournement

Pour contourner ce problème, vous devez arrêter manuellement le service MSSQL $ SharePoint avant de démarrer le programme d'installation pour mettre à niveau de l'instance de SQL Server 2000 Desktop Engine (Windows).

note Si le programme d'installation cesse de répondre avec le message qui est mentionné dans la section « Symptômes », vous pouvez arrêter manuellement le service MSSQL $ SharePoint pour poursuivre le processus de mise à niveau.

Pour arrêter manuellement le service MSSQL $ SharePoint service, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez services.msc et cliquez sur OK .
  2. Dans le volet droit de la fenêtre Services, recherchez le service MSSQL $ SharePoint .
  3. Cliquez avec le bouton droit sur service MSSQL $ SharePoint , puis cliquez sur Arrêter .
  4. Fermez la fenêtre Services.

Statut

Microsoft a confirmé qu'il s'agit un bogue dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Lorsque ce problème se produit, le fichier image complète du Gestionnaire de contrôle des services peut ressembler à celui-ci :
# ChildEBP RetAddr 
00 0012f184 77f4262b SharedUserData!SystemCallStub+0x4
01 0012f188 77e418ea ntdll!NtDelayExecution+0xc [d:\srv03rtm\base\ntdll\daytona\obj\i386\usrstubs.asm @ 611]
02 0012f1f0 77e416ee kernel32!SleepEx(unsigned long dwMilliseconds = 0x1388, int bAlertable = 0)+0x68 [d:\srv03rtm\base\win32\client\synch.c @ 1646]
03 0012f1fc 00405bec kernel32!Sleep(unsigned long dwMilliseconds = <Memory access error>)+0xb [d:\srv03rtm\base\win32\client\synch.c @ 1570]
04 0012f218 0040181c scm!CServiceNT::Stop(int bStopDependents = <Memory access error>)+0x11c [..\shared\csvcnt.cpp @ 327]
05 0012ff14 00401321 scm!CApp::RunThread(void * lpv = 0x00000000)+0x41c [app.cpp @ 445]
06 0012ff34 00408a03 scm!CApp::Run(int nCmdShow = <Memory access error>)+0x11 [app.cpp @ 246]
07 0012ffc0 77e4f38c scm!WinMainCRTStartup(void)+0xce [crt0.c @ 198]
08 0012fff0 00000000 kernel32!BaseProcessStart(<function> * lpStartAddress = 0x00408935)+0x23 [d:\srv03rtm\base\win32\client\support.c @ 580]

Propriétés

Numéro d'article: 841773 - Dernière mise à jour: lundi 3 décembre 2007 - Version: 1.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft SQL Server 2000 Desktop Engine (Windows) sur le système suivant
    • Microsoft Windows Small Business Server 2003 Premium Edition
Mots-clés : 
kbmt kbtshoot kbservice kbscm kbpreinstall kbupgrade kbsetup kbbug KB841773 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 841773
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