Не удается создать запланированное задание в Windows XP

Переводы статьи Переводы статьи
Код статьи: 841846 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При попытке создания назначенного задания с помощью мастера планирования заданий в Windows XP, мастер перестает отвечать на запросы. Если открыть диспетчер задач, а затем нажмите кнопку Приложения Вкладка, мастера планирования заданий имеет отметку Не отвечает. Если нажать кнопку Процессы Вкладка в диспетчере задач Windows, вы увидите, что Процесс Explorer.exe процесс занимает наибольшую долю циклы ЦП. Этот процесс обычно занимает от 96 и 99 процентов циклов ЦП.

Примечание Чтобы открыть диспетчер задач, нажмите сочетание клавиш CTRL + ALT + DEL.

Причина

Это может происходить, если выполняются следующие условия:
  • Вы вошли в систему как член локальной группы «пользователи». Например при входе в систему под Имя_компьютера\Пользователи, где Имя_компьютера Это имя вашего компьютера.
  • Разрешения для пользователей и все группы были удалены из системы безопасности файлов списка управления доступом (ACL) для папки меню «Пуск» в профиле All Users. Данные разрешения также были удалены для всех вложенных папок папки меню «Пуск» в профиле All Users.
Например, эта проблема обычно возникает, если разрешения для пользователей и все группы были удалены из системы безопасности NTFS ACL для папки «Администрирование» в профиле All Users.

Проблема возникает, когда мастер планирования заданий строит список доступных задач, мастер проверяет несколько мест, включая папку «Администрирование» в профиле All Users. Если в этих местах не имеют необходимых разрешений, мастера планирования заданий может перестать отвечать.

Решение

Сведения о пакете обновления

Чтобы устранить эту проблему, получите последний пакет обновления для Windows XP. Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
322389 Как получить последний пакет обновления для Windows XP

Сведения об исправлении

Корпорация Майкрософт выпустила исправление. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Данное исправление только в тех системах, в которых обнаружена эта специфическая неполадка. Это исправление может проходить дополнительное тестирование. Таким образом Если вы не представляет особой эта проблема, рекомендуется отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, обратитесь в службу и службу поддержки для получения исправления.

Примечание Если возникают другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Затраты на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов службы поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, значит исправления недоступна для данного языка.

Сведения о файлах

Английская версия данного исправления содержит версии файлов (или более поздней версии), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать Часовой пояс вкладку Дата и время на панели управления.
Windows XP 64-разрядная версия
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-May-2004  21:11  5.1.2600.1536     635,392  Mstask.dll       IA-64
   11-Apr-2004  01:55  5.1.2600.1515      25,600  Mstinit.exe      IA-64
   28-May-2004  21:11  5.1.2600.1515     576,000  Schedsvc.dll     IA-64
   11-Apr-2004  03:33  5.1.2600.1515     592,896  Xpsp2res.dll     IA-64
   11-Apr-2004  04:04  5.1.2600.1515     593,408  Wxpsp2res.dll
Windows XP
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-May-2004  21:07  5.1.2600.1536     259,584  Mstask.dll       
   11-Apr-2004  02:46  5.1.2600.1515      10,752  Mstinit.exe      
   28-May-2004  21:07  5.1.2600.1515     172,544  Schedsvc.dll     
   11-Apr-2004  04:04  5.1.2600.1515     593,408  Xpsp2res.dll

Временное решение

Чтобы обойти эту проблему, восстановите разрешения по умолчанию для папки меню «Пуск» или вложенную папку, была удалена разрешения. Например, чтобы восстановить разрешения для папки «Администрирование» в профиле всех пользователей:
  1. Войдите в систему с учетной записью администратора.
  2. Запустите проводник Windows, а затем откройте следующую папку:
    \Documents and Settings\All Users\Start Menu\Programs\
  3. Щелкните правой кнопкой мыши Администрирование папка, а затем нажмите кнопку Свойства.
  4. Нажмите кнопку Безопасность вкладки, а затем нажмите кнопку Дополнительно.
  5. Выберите Наследовать от родительского объекта применимые к дочерним объектам. Добавляя их к явно заданным в этом Установите флажок и нажмите кнопку Применение.
  6. Выберите Заменить разрешения для всех дочерних объектов заданными здесь, применимые к дочерним объектам Установите флажок и нажмите кнопку Применение.

    Внимание! Если выбран параметр Заменить разрешения для всех дочерних объектов заданными здесь, применимые к дочерним объектам флажок, все подпапки и файлы будут иметь их сброс же разрешения родительского объекта разрешения. После нажатия кнопки Применение -или- ОК, эту операцию нельзя отменить, сняв флажок.
  7. Нажмите кнопку ОКи войдите в систему как член группы «Пользователи», убедитесь в том, что можно создавать назначенное задание.
Примечание Если проблема сохраняется, может потребоваться повторите эти шаги для других вложенных папок папки меню «Пуск» в профиле All Users. Чтобы убедиться, что пользователей и все группы имеют разрешения для папки, щелкните правой кнопкой мыши папку и нажмите кнопку Свойства. Нажмите кнопку Безопасность вкладки, а затем убедитесь, что Пользователи и «Все» группы отображаются в Имена групп или пользователей список. По умолчанию указаны следующие объекты:
  • Администраторы)Имя_компьютера\Администраторы)
  • «Все»
  • (Пользователи) питанияИмя_компьютера\Power пользователей)
  • СИСТЕМА
  • Пользователи)Имя_компьютера\Пользователи)

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Microsoft, перечисленных в разделе «Относится к». Сначала исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows XP.

Дополнительная информация

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Свойства

Код статьи: 841846 - Последний отзыв: 16 июня 2011 г. - Revision: 4.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional
Ключевые слова: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbtshoot kbwinxppresp2fix kbfix kbbug kbmt KB841846 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:841846

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com