A broadband connection that requires a user name and a password is not available in Windows XP

Article translations Article translations
Article ID: 841991 - View products that this article applies to.
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
Expand all | Collapse all

SYMPTOMS

When you select the Connect to the Internet and Setup my connection manually option buttons in the Microsoft Windows XP New Connection Wizard to create a new Internet connection that requires a username and a password, the option to supply a username and a password may not be available.

CAUSE

This issue may occur if one of the following registry subkeys is damaged:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\26

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem:
  1. Verify that the Remote Access Connection Manager service is started:
    1. Click Start, click Control Panel, click Performance and Maintenance, click Administrative Tools, and then double-click Services.
    2. Right-click Remote Access Connection Manager, and then click Properties.
    3. In the Startup Type list box, click Automatic.
    4. If the Service Status is Stopped, click the Start button.
  2. You may receive the following error message:
    Could not start the Remove Access Connection manager service on Local Computer. Error 5: Access is denied.
    If you receive this error message, follow these steps.

    Note This procedure includes steps to back up the registry subkeys before you modify them.
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following subkey in the registry:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan
    3. On the File menu, click Export.
    4. In the File name box, type exported rasman key, and then click Save.
    5. In the RasMan subkey, click the ObjectName string value.

      If this value is not set to LocalSystem, follow these steps:
      1. Click Modify on the Edit menu.
      2. Type LocalSystem in the Value data box, and then click OK.
    6. In Registry Editor, locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP
    7. Right-click the 25 registry subkey, click Delete, and then click Yes to confirm that you want to delete the registry key.
    8. Right-click the 26 registry subkey, click Delete, and then click Yes to confirm that you want to delete the registry key.
    9. Quit Registry Editor.
  3. Restart your computer.
  4. Start the Remote Access Connection Manager service if the service is not already running.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 841991 - Last Review: November 17, 2004 - Revision: 2.2
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Home Edition
Keywords: 
kbregistry kbnetwork kbprb KB841991

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com