Je-li v protokolu událostí aplikace v počítači Exchange Server 2003 zaprotokolována událost s ID 9646 a klient se otevře mnoho relace MAPI

Překlady článku Překlady článku
ID článku: 842022 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Na serveru se systémem Microsoft Exchange Server 2003, v aplikaci je zaznamenána událost podobná následující událost protokol:

Typ události: Chyba
Zdroj události: MSExchangeIS
Kategorie události: Obecné
Událost ID: 9646
Popis:
Ukončení relace Mapi "/ o =Organizace/ OU =Pro správu Skupiny/CN = recipients/cn =Příjemce" protože přesáhl maximální 32 objektů typu "relace".

Když k tomuto problému dochází, také můžete obdržet následující chybovou zprávu Aplikace Microsoft Office Outlook 2003:
Nelze otevřít výchozí e-mailové složky. Microsoft Exchange Server počítač není k dispozici. Buď Existují problémy se sítí nebo Microsoft Exchange Server dolů pro Údržba.

Příčina

Tento problém může nastat, pokud jsou splněny následující podmínky:
  • Jste nainstalovali službu 2003 v Microsoft Exchange Server V počítači Exchange Server aktualizací Service Pack 1 (SP1).
  • Otevře program, který je spuštěn v klientském počítači, mnoho Relace MAPI v počítači Exchange Server. Je počet relací rozhraní MAPI větší než nejvyšší přípustné hodnoty.
  • Používáte-li aplikace Microsoft Office Outlook 2007 a přidat velké další poštovní profilu. K tomuto problému může například dojít, pokud Další poštovní schránka obsahuje více než tisíc složky.
Exchange Server 2003 SP1 ukládá omezení počtu nejvyšší přípustná MAPI relací na uživatele. Výchozí maximální počet povolených MAPI relací na uživatele nastavena na šestnáctkovou hodnotu 0x20 po použití Exchange Server 2003 SP1.

Poznámka: Šestnáctková hodnota 0x20 převede na desítkovou hodnotu 32.

Řešení

Chcete-li tento problém vyřešit, doporučujeme, aby jste nejdříve určit zda MAPI je dosažen limit relace z důvodu možného zneužití, protože velké další poštovní byl přidán, protože je v důsledku chyby v klientský program, nebo v důsledku návrh programu klienta.

Pokud problém Příčinou velkých poštovních byl přidán do profilu v režimu serveru Exchange s mezipamětí Aplikace Outlook 2007, můžete zakázat nové funkce výchozí aplikace Outlook 2007, který způsobuje, že Tento problém. Chcete-li to provést, postupujte takto.

Poznámka: Po provedení těchto kroků nelze přístup ke sdílené poštovní schránky složky při práci v režimu offline pomocí režimu serveru Exchange s mezipamětí profil.
  1. V Nástroje nabídky, klepněte na tlačítko Účet Nastavení.
  2. Klepněte na účet Exchange Server a potom klepněte na tlačítkoZměna.
  3. Klepněte na tlačítko Další nastavení.
  4. V Upřesnit karta, zrušte zaškrtnutí políčkaStáhnout sdílené složky (vyloučí poštovní složky) Zaškrtávací políčko.
  5. Klepněte na tlačítko OK, klepněte na tlačítko Další, a potom klepněte na tlačítko Dokončit.
Pokud tomuto problému dochází z důvodu chyby v klientském programu nebo z důvodu návrh programu klienta doporučujeme obrátit se na dodavatele Zjistěte, zda můžete použít jeden z následujících postupů:
  • Získat opravu
  • Oprávnění udělit zobrazit informace o úložišti stav účet, pod kterým je spuštěn program

    Poznámka: Programy, které je spuštěna pod účtem, který má oprávnění limit relací na uživatele rozhraní MAPI nejsou ovlivněny.
Chcete-li udělit oprávnění zobrazit informace o úložišti stav, postupujte Tyto kroky:
  1. Exchange System Manager klepněte pravým tlačítkem Exchange Server objekt nebo úložiště poštovních schránek, ke kterému chcete udělit oprávnění, a Klepněte na tlačítko Vlastnosti.
  2. Klepněte Zabezpečení na kartě.
  3. Klepněte na účet, ke kterému chcete udělit oprávnění.

    Pokud účet není uveden, klepněte na tlačítkoPřidat, klepněte na název účtu, Přidat, a Klepněte na tlačítko OK.
  4. Ve skupinovém rámečku Povolit Klepnutím vyberte sloupec na Zobrazit informace o úložišti stav políčko, je-li toto zaškrtávací políčko není zaškrtnuté.
  5. Zrušte zaškrtnutí políčka u oprávnění, která jsou není požadováno a klepněte na tlačítko OK.

    Poznámka: Je možné, že budete muset tento krok vynecháte, pokud jste klepli naPřidat Přidejte účet v kroku 3. Důvodem je, že každá kontrola pole v Povolit Při přidávání byl vybrán sloupec účet v kroku 3.
Pokud nelze získat opravu a nelze nakonfigurovat spuštění spolu s oprávněním zobrazit informace o úložišti stav účtu, můžete Upravte počet MAPI relací na uživatele, které jsou povoleny konfigurací nastavení registru. Pokud to uděláte, zkuste zjistit minimální hodnotu můžete použít tak, aby se klientský program lze spustit bez problémů. Při zvýšení limit příliš vysoké, program Klient může ovlivnit výkon Exchange Server počítač.

Pokud k tomuto problému dochází po instalaci Scalable Networking pack nebo aktualizace Windows 2003 Service Pack 2 naleznete v následujících článek znalostní báze Microsoft Knowledge Base:

936594 Po instalaci systému Windows Server 2003 SP2 nebo sady Scalable Networking Pack do počítače se systémem Windows Server 2003 může docházet k problémům se sítí

Další informace

Změna hodnoty maximální přípustné relace MAPI uživatele z výchozího lze nakonfigurovat maximální povolené relací za Položka registru uživatele. Chcete-li to provést, postupujte takto.

Důležité Tento oddíl, metoda nebo úkol obsahuje kroky, které můžete zjistit, jak na úpravou registru. Však mohou nastat závažné problémy při úpravě registr nesprávně. Proto se ujistěte, postupujte podle těchto kroků: opatrně. Pro zvýšení ochrany před úpravami je nutné zálohujte registr. Můžete pak obnovení registru v případě, že dojde k potížím. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup při zálohování a obnovení registru v systému Windows
  1. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, Typ regedit v Otevřít pole a pak Klepněte na tlačítko OK.
  2. Vyhledejte a klepněte na následující podklíč registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
  3. Pokud Povolený počet relací na uživatelepoložka neexistuje, proveďte následující:
    1. V Upravit příkaz Novýa klepněte na tlačítko Hodnota DWORD.
    2. Typ Povolený počet relací na Uživatel jako název položky a stiskněte klávesu ENTER.
  4. Klepněte pravým tlačítkem myši Povolený počet relací na Uživatel položka a klepněte na tlačítko Upravit.
  5. Klepněte na tlačítko Desítkové, zadejte hodnoty, které Chcete nastavit Hodnota dat pole a pak klepněte na tlačítkoOK.
  6. Ukončete Editor registru.
  7. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, Typ Services.msc v Otevřít pole, a Klepněte na tlačítko OK.
  8. Klepněte Úložiště informací MSExchange Službaa klepněte na tlačítko Restartovat službu.

Vlastnosti

ID článku: 842022 - Poslední aktualizace: 22. května 2011 - Revize: 7.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Klíčová slova: 
kbtshoot kbprb kbmt KB842022 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:842022

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com