Incoming ARP packets can overwrite static entries in the ARP cache in Windows 2000

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Article ID: 842168 - View products that this article applies to.
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Symptoms

In Microsoft Windows 2000, incoming Address Resolution Protocol (ARP) packets can overwrite static entries in the ARP cache if the sender's protocol address matches an existing static entry that is in the ARP cache. Because an ARP reply that is received without an ARP request can update the ARP cache, a static ARP entry can be spoofed by using a false media access control (MAC) address. Because ARP is unlikely to be routed, this situation may occur only on a local network.

Cause

This problem occurs because the ARP client does not distinguish between transient and static cache entries when the ARP client processes incoming ARP packets.

Resolution

Service pack information

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows 2000 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size    File name
-------------------------------------------------------- 
19-Jun-2003  20:05  5.0.2195.6602  108,816  Msafd.dll        
02-Jun-2004  22:44  5.0.2195.6938  318,832  Tcpip.sys
19-Jun-2003  20:05  5.0.2195.6601   17,680  Wshtcpip.dll     
19-Jun-2003  20:05  5.0.2195.6687  120,240  Afd.sys
19-Jun-2003  20:05  5.0.2195.6655   16,240  Tdi.sys

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 842168 - Last Review: October 26, 2013 - Revision: 6.0
Applies to
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbAutoHotfix kbqfe kbHotfixServer kbbug kbfix kbwin2000presp5fix KB842168

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