Windows Server 2003에서 저장소 영역 네트워크 테이프 장치에 백업 작업을 수행할 수 없습니다.

기술 자료 번역 기술 자료 번역
기술 자료: 842411 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Windows Server 2003을 실행 하는 컴퓨터 파이버 또는 iSCSI 저장 영역 네트워크를 (SAN) 테이프 장치에 백업 작업이 수행 되지 않을 또는 백업 성능에 심각 하 게 영향을 받을 수 있습니다.

이 문제에는 하나 이상의 DPM 서버는 테이프 라이브러리 스위치 파이버 채널 또는 iSCSI 연결을 사용 하 여 공유 하 고 DPM 환경에서 발생할 수도 있습니다.

원인

플러그 사이 충돌이 있을 때이 문제가 발생할 수 있습니다 및 플레이 컴퓨터의 다른 프로세스입니다. 백업 상태를 확인 하려면 장치 플러그 앤 플레이 전송 단위 테스트 준비 요청 장치에 모든 두 번째입니다. 이 요청에서 다른 작업과 충돌을 일으키는 컴퓨터입니다.

해결 과정

이 문제를 해결 하는 방법은 세 가지가 있습니다.

방법 1: 테이프 서비스에 대 한 모든 테스트 단위 준비 (TUR) 요청을 사용 하지 않도록 설정

중요 한 이 섹션, 메서드 또는 작업 방법을 설명 하는 단계를 포함 합니다 레지스트리를 수정 합니다. 그러나 수정할 경우 심각한 문제가 발생할 수 있습니다는 레지스트리 잘못. 따라서 다음이 단계를 수행 했는지 확인 신중 하 게 합니다. 수정 하기 전에 추가 보호를 위해 레지스트리를 백업 합니다. 그런 다음 문제가 발생할 경우 레지스트리를 복원할 수 있습니다. 자세한 내용은 백업 및 레지스트리를 복원 하 고, 다음 문서를 참조 하는 방법에 대 한 Microsoft 기술 자료의 다음 문서를 참조 번호:
322756 백업 하 고 Windows에서 레지스트리를 복원 하는 방법
  1. 클릭 시작를 클릭 실행, 형식 regedit를 클릭 하 고 다음을 누릅니다.확인.
  2. 검색에
    \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum
    그 같은 값 클래스의 모든 인스턴스에 대 한 레지스트리 하위 키 테이프 드라이브입니다.
  3. 이 하위 키에는 서비스 값 서비스를 알려줍니다. 장치를 처리합니다. 이
    Service_Name
    키 지가
    \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
    레지스트리 하위 키입니다. 에
    Service_Name
    사용할 수 있는 키를
    열거형
    키를 확인 하는 이 서비스에서 처리 하는 장치입니다.
  4. 저장 장치에 해당 하는 하위 키를 찾습니다 및 다음 하위 키를 마우스 오른쪽 단추로 클릭 합니다.
  5. 가리킵니다. 를 클릭 하 고 다음을 누릅니다. DWORD 값. 형식 자동 실행 항목 이름으로 다음 ENTER 키를 누릅니다.
  6. 마우스 오른쪽 단추로 클릭 자동 실행를 클릭 하 고 다음을 누릅니다.수정. 에 값 데이터 상자에 값을 입력 합니다. 의 0 자동 실행 기능을 해제.

    키: \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Service_Name
    값: 자동 실행
    종류: REG_DWORD
    데이터: 0을 사용할 수 없습니다, 그리고 1 가능 (기본값)입니다.

방법 2: 테이프 서비스에 대 한 특정 장치에 대 한 TUR 요청 해제

  1. 메서드는 테이프를 찾으려면 1의 1-4 단계를 수행 하십시오. 서비스입니다.
  2. REG_SZ AutoRunAlwaysDisable 항목을 다음과 같이 설정 합니다. (실행 하 고 있습니다. REG_DWORD 자동 실행 항목 설정지 않습니다.)
    • 처음 8 자는 공급 업체 ID입니다. 경우 공급 업체 ID가 8 자 미만이, 공백으로 채워집니다.
    • 두 번째 16 자는 제품 ID입니다. 경우는 제품 ID가 16 자 미만이, 공백으로 채워집니다.
    • 두 개 이상의 장치를 추가 하는 경우 다음 장치가입니다. 이전 장치를 추가 합니다.

      키:
      \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<service_name></service_name>

      항목: AutoRunAlwaysDisable
      형식: REG_SZ
      데이터: 사용 하지 않도록 설정 하는 문자열입니다. 이것입니다. 16 문자 제품의 뒤에 8 문자 공급 업체 ID 문자열 ID입니다.
다음 예제에서는 장치와 상관 관계 참조 아래는 열거형 키:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\4MMdat\Enum] 
"0"="SCSI\Sequential&Ven_HP&Prod_C1537A&Rev_L907\5&347b98f7&0&060" 
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\4mmdat] 
REG_SZ:AutoRunAlwaysDisable:"HP      C1537A          "
참고 이 예제에서는 따옴표로 표시 하는 데 사용 됩니다 있는 공백 채우기 올바르게 사용 합니다. 인용 실제에서 사용 되지 않습니다. 저장 된 값입니다. TUR 올바른 간격을 사용 하지 않는 경우 사용할 수 없습니다. 사용자 이 변경 내용을 적용 하려면 컴퓨터를 다시 시작 해야 합니다.

방법 3:을 프로그래밍 방식으로 특정 장치에 대 한 TUR 요청 해제

프로그래밍 방식으로 특정 장치에 대 한 TUR 요청을 사용 하지 않으려면 호출 하는 DeviceIoControl 기능을 IOCTL_STORAGE_MCN_CONTROL I/O 코드를 제어할 수 있습니다. 자세한 내용은 다음 Microsoft 웹 사이트:
http://msdn2.microsoft.com/en-us/library/aa363415.aspx
HP 시작 하면 필요한 해결 방법을 문서화 된 및 다음 중지 이동식 저장소 서비스 서버인 때마다 다시 시작 합니다. 이동식 저장소 서비스를 사용할 수 있으므로이 솔루션은 작동에 DeviceIoControl 서비스가 중지 되 면 모든 테이프 장치 함수 호출입니다.

Dell 테이프 백업 단위 (TBU) 장치에 적용 하는 단위 테스트 준비 요청 문제를 해결 하는 방법

테스트 장치 준비 (TUR) Windows Server 2003에서 충돌 발생 SCSI 연결, 파이버 연결 또는 iSCSI 연결 장치에 문제를 요청 합니다. 때이 문제 발생 하는 오버플로 TUR 요청의 응답 저장소 단위를 발생 합니다. 또는 SCSI 명령에 느리게 응답. 파이버 또는 iSCSI SAN 환경에서 모든 Windows 서버 TUR TBU 하드웨어 검색 하도록 zoned 2003 기반 컴퓨터를 보낼 수 있습니다. 요청 합니다. 서버에서 장치 관리자에서 장치를 볼 수 있는 경우는 TUR 요청에 대 한 드라이버가 설치 되지 않았습니다 경우에 장치를 보내고 있는 장치입니다. 이 문제를 해결 하려면 두 개의 메서드를 사용할 수 있습니다. 방법 1이 되는 임시 수정 프로그램입니다. 방법 2 레지스트리를 적용 됩니다. 방법 2만 효과적입니다. 드라이버 파일을 변경 해야 합니다. 변경 또는 드라이버를 업그레이드 하는 경우 사용 이 수정 프로그램을 다시 적용 해야 합니다.

방법 1: 이동식 저장소 서비스를 사용 합니다.

이동식 저장소 서비스를 사용 하 여 일시적으로 해제 하려면 TUR 요청에 오버플로가 발생 합니다. 이렇게 하려면 서비스를 사용 합니다. 다음으로 시작 하 고 서비스를 중지 합니다. 컴퓨터를 때까지이 메서드 TUR 요청 중지 다시 시작 또는 드라이버 변경 됩니다.

참고 기본적으로 이동식 저장소 서비스가입니다. 사용 하지 않도록 설정 합니다.

TUR 요청을 일시 중지 하려면 다음과 같이 하십시오.
  1. 클릭 시작종류services.msc를 클릭 하 고 다음을 누릅니다.확인.
  2. 오른쪽 창에서 이동식 저장소.
  3. 시작 유형 목록에서 클릭수동를 클릭 하 고 다음을 누릅니다. 적용.
  4. 클릭 시작를 클릭 하 고 다음을 누릅니다.중지.
  5. 시작 유형 목록에서 클릭사용 안 함를 클릭 하 고 다음을 누릅니다. 확인.

방법 2: TBU 장치에 대 한 TUR 요청 해제 하려면 레지스트리를 수정 합니다.

이 메서드를 사용 하려면 TBU 장치용 드라이버 파일을 찾습니다. 그런 다음 각 드라이버 파일에 대 한 설정을 레지스트리를 구성 합니다. 사용자 장치 관리자를 사용 하 여 각 TBU 장치의 드라이버 파일을 찾을 수 있습니다. 장치 관리자도 알 수 없는 매체 체인저 드라이버를 나열합니다.

찾을 수 있는 TBU 장치용 드라이버 파일 정보를 다음 단계를 수행 하십시오.
  1. 클릭 시작종류sysdm.cpl를 클릭 하 고 다음을 누릅니다.확인.
  2. 시스템 속성 대화 상자 클릭 하 여 하드웨어 탭입니다.
  3. 클릭 장치 관리자.
  4. 장치 관리자 창을 마우스 오른쪽 단추로 클릭 TBU 장치 클릭 속성를 누른 다음 해당드라이버 탭입니다.
  5. 드라이버 탭에서 클릭 드라이버 세부 정보.
  6. 드라이버 파일 정보 대화 상자 드라이버 파일 이름을 note입니다.
  7. TBU 모든 장치에 [NULL]에 대해 d-f 단계를 반복 하 여에 컴퓨터입니다.
TBU 장치 드라이버 정보를 확인 한 후 구성 각 이러한 드라이버 파일에서 레지스트리를 설정 합니다. 이 작업을 수행합니다 다음 단계:
  1. 클릭 시작종류regedit를 클릭 하 고 다음을 누릅니다. 확인.
  2. 왼쪽 창에서 찾아 다음을 클릭 합니다. 레지스트리 하위 키:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
  3. 확장의
    서비스
    하위 키, 및 다음 마우스 오른쪽 단추를 클릭 하 고 있습니다. 확인 한 드라이버 파일의 이름을 가진 레지스트리 하위 키 장치 관리자입니다.
  4. 가리킵니다. 를 클릭 하 고 다음을 누릅니다.DWORD 값.
  5. 형식 자동 실행를 클릭 하 고 다음 키를 누릅니다. 다음 중 하나를 입력 합니다.
  6. 마우스 오른쪽 단추로 클릭 자동 실행를 클릭 하 고 다음을 누릅니다.수정.
  7. 값 데이터 상자, 형식0 자동 실행 기능을 해제.
  8. 반복 단계 3-7 각 드라이버 파일 장치 관리자에서 표시 합니다.
  9. 레지스트리 편집기를 종료 한 다음 다시 시작을 컴퓨터입니다.

Overland 장치에 대 한 솔루션

Overland TUR 요청 문제에 대 한 대안 솔루션을 제공 Windows Server 2003에서 발생할 것입니다. 이 대 한 자세한 내용은 한 가지 해결 방법은 다음 Overland 웹 사이트를 방문 하십시오.
http://support.overlandstorage.com/jive/entry.jspa?externalID=6561&categoryID=442
이 문서에 나와 있는 다른 공급 업체 제품 들은 Microsoft와 무관 한 회사에서 제조한 것입니다. Microsoft 어떠한 보증도, 묵시적 또는 성능 또는 안정성 이러한 제품에 대 한 보증도 하지 않습니다.

속성

기술 자료: 842411 - 마지막 검토: 2011년 5월 13일 금요일 - 수정: 1.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
키워드:?
kbtshoot kbprb kbmt KB842411 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
이 문서의 영문 버전 보기:842411

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com