Windows Server 2003 ベースのドメイン コントローラー上の IIS 6.0 Web ページを参照するとエラー メッセージ "サービスは利用できません" が表示される

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文書番号: 842493
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現象

Microsoft Windows Server 2003 ベースのドメイン コントローラーでホストされている Web ページを参照すると、次の ASP (Active Server Pages) エラー 5 のエラー メッセージが表示されることがあります。
サービスを使用できません
また、次の警告イベントがシステム イベント ログに出力されることがあります。

イベントの種類:警告
イベント ソース:W3SVC
イベント カテゴリ:なし
イベント ID: 1009
日付: 日付
時刻:時刻
ユーザー: 該当なし
コンピューター:Computer_Name
説明:
アプリケーション プール 'Application_Pool_Name' を提供している手順が突然終了しました。手順 id は '5288' でした。手順終了コードは '0xffffffff' でした。

詳細な情報は、http://support.microsoft.com の [ヘルプとサポート センター] を参照してください。

また、次のエラー イベントがアプリケーション イベント ログに出力されることがあります。

イベントの種類:メッセージ
イベント ソース:Active Server Pages
イベント カテゴリ:なし
イベント ID: 5
日付: 日付
時刻:時刻
ユーザー: 該当なし
コンピューター:Computer_Name
説明:
エラー: 次のエラーが原因でアプリケーション プール 'Application_Pool_Name' のテンプレート固定キャッシュの初期化に失敗しました: アプリケーション プールのディスク キャッシュ サブディレクトリを作成できませんでした。データに追加のエラー コードがある可能性があります。

詳細な情報は、http://support.microsoft.com の [ヘルプとサポート センター] を参照してください。

Filemon を使用してファイルの動作を監視すると、次のようなエラー メッセージが表示されます。
3521 Time w3wp.exe:3168 CREATE C:\WINDOWS\system32\inetsrv\ASP Compiled Templates\PID3168.TMP ACCESS DENIED NT AUTHORITY\NETWORK SERVICE

原因

この問題は、インターネット インフォメーション サービス (IIS) 6.0 を実行しているサーバーが、ドメイン コントローラーを兼用している場合に発生する可能性があります。この問題は、アプリケーション プールで NT Authority\Network Service アカウントが使用され、要求されたフォルダーにアクセスするためのアクセス許可が NT Authority\Network Service アカウントに付与されていないために発生します。

解決方法


この問題を解決するには、手動で IIS_WPG グループのアクセス許可をフォルダーに設定した後、NT Authority\Network Service アカウントのアクセス許可をフォルダーに設定します。



この問題を自動的に解決するには、「Fix it で解決する」セクションに進んでください。自分でこの問題を解決するには、「自分で解決する」セクションに進んでください。

Fix it で解決する



この問題を自動的に解決するには、[この問題を解決する] ボタンまたはリンクをクリックします。[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、このウィザードの手順に従います。


この問題を解決する
Microsoft Fix it 50520

注:
  • このウィザードは英語版のみとなります。自動的な解決は英語版以外の Windows でも機能します。
  • 別のコンピューターを使用している場合は、Fix it ソリューションをフラッシュ ドライブまたは CD に保存して、問題のあるコンピューターで実行することができます。

次に、「問題が解決されたかどうかの確認」セクションに進んでください。



自分で解決する


フォルダーに対するアクセス許可を IIS_WPG グループに設定するには、以下の手順を実行します。
  1. エクスプローラーを起動して、次のフォルダーを開きます。
    %systemroot%\Help\iisHelp
  2. 右側のウィンドウで、[Common] フォルダーを右クリックし、次に [共有とセキュリティ] をクリックします。
  3. [セキュリティ] タブをクリックし、[追加] をクリックします。次に、IIS_WPG と入力して [OK] をクリックします。
  4. [IIS_WPG] が選択された状態で、[許可] 列の下にある以下のチェック ボックスをオンにし、[OK] をクリックします。
    • 読み取りと実行
    • フォルダーの内容の一覧表示
    • 読み取り
  5. 次のフォルダーを開きます。
    %systemroot%\system32\inetsrv
  6. 右側のウィンドウで、[ASP Compiled Templates] フォルダーを右クリックし、次に [共有とセキュリティ] をクリックします。
  7. [セキュリティ] タブをクリックし、[IIS_WPG] グループをクリックして、[許可] 列の下にある [フル コントロール] チェック ボックスをオンにします。[OK] をクリックします。
  8. %systemroot%
    フォルダーを開きます。
  9. 右側のウィンドウで、[IIS Temporary Compressed Files] フォルダーを右クリックし、次に [共有とセキュリティ] をクリックします。
  10. [セキュリティ] タブをクリックし、[IIS_WPG] グループをクリックして、[許可] 列の下にある [フル コントロール] チェック ボックスをオンにします。[OK] をクリックします。
フォルダーに対するアクセス許可を NT Authority\Network Service アカウントに設定するには、以下の手順を実行します。
  1. エクスプローラーを起動して、次のフォルダーを開きます。
    %systemroot%\Help\iisHelp
  2. 右側のウィンドウで、[Common] フォルダーを右クリックし、次に [共有とセキュリティ] をクリックします。
  3. [セキュリティ] タブをクリックし、[追加] をクリックします。次に、NETWORK SERVICE と入力して [OK] をクリックします。
  4. [NETWORK SERVICE] が選択された状態で、[許可] 列の下にある以下のチェック ボックスをオンにし、[OK] をクリックします。
    • 読み取りと実行
    • フォルダーの内容の一覧表示
    • 読み取り
  5. 次のフォルダーを開きます。
    %systemroot%\system32\inetsrv
  6. 右側のウィンドウで、[ASP Compiled Templates] フォルダーを右クリックし、次に [共有とセキュリティ] をクリックします。
  7. [セキュリティ] タブをクリックし、[追加] をクリックします。次に、NETWORK SERVICE と入力して [OK] をクリックします。
  8. [NETWORK SERVICE] グループが選択された状態で、[許可] 列の下にある [フル コントロール] チェック ボックスをオンにし、[OK] をクリックします。
  9. 次のフォルダーを開きます。
    %systemroot%
  10. 右側のウィンドウで、[IIS Temporary Compressed Files] フォルダーを右クリックし、次に [共有とセキュリティ] をクリックします。
  11. [セキュリティ] タブをクリックし、[追加] をクリックします。次に、NETWORK SERVICE と入力して [OK] をクリックします。
  12. [NETWORK SERVICE] グループが選択された状態で、[許可] 列の下にある [フル コントロール] チェック ボックスをオンにし、[OK] をクリックします。
以上の手順を完了したら、サービス スナップインまたはコンピューターの管理スナップインから、IIS Admin サービスを再起動します。

回避策

サービス スナップインまたはコンピューターの管理スナップインから IIS Admin サービスを再起動することにより、この問題を一時的に回避できることがあります。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

原因の異なる同様の問題の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
332097 DCPROMO 実行時に一部の IIS フォルダーのアクセス許可が保持されない

問題が解決されたかどうかの確認

  • 問題が解決されたかどうかを確認します。問題が解決された場合、このセクションの作業は完了していることになります。問題が解決されていない場合は、サポートに問い合わせることができます。
  • マイクロソフトはフィードバックをお待ちしています。この解決方法に関するフィードバックを提供する、または問題を報告するには、"Fix it for me" ブログ にコメントを記入するか、電子メール メッセージ (日本語可) を送信してください。

プロパティ

文書番号: 842493 - 最終更新日: 2011年4月12日 - リビジョン: 5.0
キーワード:?
kberrmsg kbprb kbfixme kbmsifixme KB842493
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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