Você recebe um erro "A dll de sistema 'kernel32.dll' foi realocado na memória" mensagens depois que você instalar uma atualização de segurança para o Windows NT Workstation 4.0

Traduções deste artigo Traduções deste artigo
ID do artigo: 842674 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Depois de instalar a atualização de segurança descrita no artigo 835732 do Microsoft Knowledge Base (KB), todos os seguintes sintomas ocorrer:
  • Não é possível iniciar o Microsoft Windows Explorer.
  • Não é possível executar o programa hotfix.exe.
  • Se você tentar executar qualquer programa ou processo que mapeia o arquivo Kernel32.dll para seu espaço de endereço, você receber a seguinte mensagem de erro:
    A dll de sistema "kernel32.dll" foi realocada na memória. O aplicativo não pode ser executado corretamente.
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
835732MS04-011: Actualização de segurança para Microsoft Windows

Causa

Esse problema ocorre se as duas condições a seguir forem verdadeiras:
  • Você está executando a versão chinês do Microsoft Windows NT Workstation 4.0 com o Windows NT 4.0 Service Pack 6a (SP6a) instalado.
  • Você instala a versão chinês da atualização de segurança para o Windows NT Workstation 4.0 descrita no artigo 835732.
Esse problema ocorre porque a versão chinês da atualização de segurança contém uma compilação incorreta do arquivo Gdi32.dll.

Resolução

Informações sobre o hotfix

Uma correção suportada está agora disponível da Microsoft, mas destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos computadores que apresentarem esse problema específico.

Para resolver esse problema, contate o Atendimento Microsoft para obter a correção. Para obter uma lista completa dos números de telefone do Atendimento Microsoft do e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Observação : em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Devido às dependências do arquivo, esse hotfix requer o Microsoft Windows NT 4.0 SP6a.

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
152734Como obter o service pack mais recente do Windows NT 4.0

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version           Size      File name
   ---------------------------------------------------------
   14-May-2004  7:25   4.0.1381.7263     209,168   Gdi32.dll      

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Propriedades

ID do artigo: 842674 - Última revisão: sábado, 26 de outubro de 2013 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbfix kbbug KB842674 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 842674

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com