Přehled potíží, které mohou nastat, když chybí sdílené položky správy

ID článku: 842715 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastanou potíže. Informace o zálohování, obnovení a úpravě registru najdete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Souhrn

Tento článek popisuje příznaky, ke kterým může dojít, když v počítači chybí jedna nebo více skrytých sdílených položek správy. Článek obsahuje také informace o způsobu řešení tohoto problému.

Pokud jste již zjistili, že ve vašem počítači chybí jedna nebo více skrytých sdílených položek správy, přečtěte si informace v částech Příčina a Řešení. Je třeba si uvědomit, že chybějící sdílené položky pro správu obvykle naznačují, že počítač, o který se jedná, byl napaden nebezpečným softwarem. Doporučujeme, aby uživatelé zformátovali a přeinstalovali v napadených počítačích systém Windows.

Příznaky

Když jsou sdílené položky pro správu odstraněny z počítače nebo v počítači nějakým způsobem chybí, může docházet k řadě potíží.

Používáte-li příkaz net share nebo nástroje MPSReports, může výstup naznačovat, že v počítači chybí sdílená složka IPC$, ADMIN$ nebo C$. Pokud tuto chybějící sdílenou složku znovu vytvoříte, může znovu chybět po dalším spuštění počítače nebo přihlášení. K této záležitosti může dojít i tehdy, pokud nastavíte hodnoty DWORD registru AutoShareServer a AutoShareWks na hodnotu 1.

Můžete zjistit neznámé procesy, které začínají ve spouštěcí složce nebo v klíči
pro spuštění
v registru. Antivirový software může zjistit viry, červy, trójské koně nebo viry backdoor. Nebo je možné, že kořen protokolu FTP na serveru bude obsahovat neznámé soubory.

Následující seznam představuje podrobný seznam problematického chování, které je možné spojovat s touto záležitostí.
  • Pokud je dotčený počítač řadič domény, můžete do klientských počítačů dostat během přihlašování do sítě nebo když se pokouší připojit do domény, chybovou zprávu. Někdy je možné se připojit s klientskými počítači se systémem Microsoft Windows 2000 nebo Microsoft Windows XP, ale není možné se připojit s klientskými počítači se systémem Microsoft Windows 95, Microsoft Windows 98 nebo Microsoft Windows Millennium Edition. U počítačů se systémem Windows 9x se může zobrazit chybová zpráva o tom, že
    • vámi zadané heslo domény není správné nebo že vám byl odepřen přístup na přihlašovací server,
    • přihlašovací server nerozpoznal vaše heslo domény nebo přístup na server vám byl odepřen.
    Když se pokusíte přihlásit k síti s počítačem se systémem Windows 2000 nebo Windows XP, může se vám zobrazit chybová zpráva o tom, že
    žádný přihlašovací server není k dispozici pro službu požadovanou v přihlášení
    nebo podobná. Když se pokoušíte připojit k doméně, může se vám zobrazit chybová zpráva o tom, že
    při pokusu o připojení k doméně Název_domény došlo k chybě a nelze najít název sítě.
  • Když se pokoušíte získat vzdálený přístup do dotčeného počítače nebo se ho pokoušíte vzdáleně zobrazit pomocí cesty UNC, mapované jednotky, příkazu net use, příkazu net view nebo procházením sítě ve složce Okolní počítače nebo Místa v síti, může se vám zobrazit chybová zpráva o tom, že
    • tento server není konfigurován pro transakce,
    • došlo k systémové chybě 53, síťová cesta nebyla nalezena, doména
    • Název_domény není přístupná.
  • Když se pokoušíte provádět úlohy správy na řadiči domény, mohou se zobrazit chybové zprávy. Je například možné, že se nespustí moduly snap-in konzoly MMC, jako například Uživatelé a počítače služby Active Directory nebo Sítě a služby Active Directory a může se vám zobrazit chybová zpráva s informacemi o tom, že
    informace o názvu nelze vyhledat, protože selhal pokus o přihlášení.
  • Když se pokoušíte přidat uživatele ke skupině zabezpečení, může se vám zobrazit chybová zpráva s informacemi o tom, že
    nebylo možné otevřít výběr objektů, protože nelze najít žádná místa pro výběr objektu.
  • Když se pokoušíte spustit program Netdom.exe z nástrojů pro podporu systému Windows 2000 k vyhledání rolí FSMO, může se vám zobrazit chybová zpráva s informacemi o tom, že
    nelze aktualizovat heslo, hodnota aktuálně zadaná jako heslo není správná.
  • Pokoušíte-li se spustit program Dcdiag.exe z nástrojů pro podporu systému Windows 2000, může se vám zobrazit chybová zpráva s informacemi o tom, že
    došlo k chybě 67, nebylo možné najít název sítě.
    Výsledky z programu Dcdiag.exe mohou uvádět také chyby vazby LDAP s informacemi o tom, že
    vazba LDAP se nezdařila s chybou 1323.
  • Když se pokoušíte spustit program Netdiag.exe z nástrojů pro podporu systému Windows 2000, může se vám zobrazit chybová zpráva s informacemi o tom, že
    selhal test seznamu řadičů domény a
    pomocí prohlížeče se nezdařilo zobrazit výčet řadičů domény. [NERR_BadTransactConfig]
  • Pokud spustíte trasování v síti, když se pokoušíte připojit k dotčenému počítači, mohou se vám zobrazit výsledky podobného typu, jako jsou následující:
    C session setup & X, Username = username, and C tree connect & X, Share = \\<Název_serveru>\IPC$ R session setup & X - DOS Error, (67) BAD_NET_NAME
  • Je možné, že se na serveru nespustí služba WINS nebo se u konzoly WINS může zobrazit červená značka X nebo obojí.
  • V Prohlížeči událostí mohou být protokolovány události NetBT 4311 podobného typu, jako jsou následující:

    ID události: 4311
    Zdroj události: NetBT
    Typ události: Chyba
    Popis: Inicializace se nezdařila, protože nebylo možné vytvořit zařízení ovladače.

  • Je možné, že se konzola Správa licencí Terminálové služby nespustí a že se vám zobrazí chybová zpráva s informacemi o tom, že
    • v aktuální doméně nebo pracovní skupině není k dispozici žádný licenční server Terminálové služby. Chcete-li se připojit k jinému licenčnímu serveru, klepněte na licenci, klepněte na možnost připojení a klepněte na název serveru.
    • Síťová adresa není platná.
  • Je možné, že se služby pro systém Macintosh nespustí. Když se pokoušíte spustit tuto službu, mohou být v Prohlížeči událostí protokolovány události podobné následujícím:

    Typ události: Chyba
    Zdroj události: MacFile
    Kategorie události: Není k dispozici
    ID události: 10021
    Uživatel: neuvedeno
    Popis: Služba Souborový server pro systém Macintosh nekontaktovala řadič domény k získání informací o doméně.

    Typ události: Chyba
    Zdroj události: MacFile
    Kategorie události: Není k dispozici
    ID události: 10027
    Uživatel: neuvedeno
    Popis: Objevila se chyba při inicializaci Souborového serveru pro systém Macintosh. Podproces pomocného modulu serveru nemohl být inicializován Specifický kód chyby je v datech.

    Typ události: Chyba
    Zdroj události: MacFile
    Kategorie události: Není k dispozici
    ID události: 10001
    Uživatel: neuvedeno
    Popis: Nebylo možné spustit službu Souborový server pro systém Macintosh. Objevila se chyba specifická pro daný systém. Kód chyby je v datech.

    Typ události: Chyba
    Zdroj události: Správce služeb
    Kategorie události: Není k dispozici
    ID události: 7024
    Uživatel: neuvedeno
    Popis: Souborový server pro systém Macintosh byl ukončen s chybou služby 1722.

Příčina

K těmto problémům může dojít poté, co nebezpečný program odebere sdílené položky pro správu z počítače se systémem Windows Server 2003, Windows XP, Windows 2000 nebo Windows NT 4.0.

Uživatelé se zlými úmysly se často připojují k těmto sdíleným položkám pro správu a využívají k tomu slabých hesel, chybějících aktualizací zabezpečení, přímého vystavení počítače síti Internet nebo kombinace těchto faktorů. Uživatel se zlými úmysly potom instaluje nebezpečné programy, jejichž vliv na počítač a na zbytek počítačové sítě se zvyšuje. V mnoha případech tyto nebezpečné programy odstraňují sdílené položky pro správu v rámci obranného kroku, který má zabránit tomu, aby jiní konkurenční uživatelé se zlými úmysly převzali kontrolu nad napadenými systémy.

Napadení některým z těchto nebezpečných programů může přijít přímo z Internetu nebo z jiného počítače v místní síti, který je také napadený. To obvykle ukazuje na to, že zabezpečení sítě není dobré. Pokud tedy zjistíte tyto příznaky, doporučujeme zkontrolovat všechny ostatní počítače v síti, zda se v nich nenacházejí nebezpečné programy. K tomu použijte antivirový software a nástroje pro zjišťování špionážních programů. Doporučujeme také provést analýzu zabezpečení za účelem identifikace chyb zabezpečení v síti. Informace o zjišťování nebezpečných programů a o tom, jak analyzovat zabezpečení sítě, naleznete v části Řešení.

Příkladem nebezpečného programu, který se zaměřuje na sdílené položky pro správu je program Win32.Agobot. Technické detaily o tom, jak tento program pracuje, naleznete na webu společnosti Computer Associates – Virus Information Center:
http://www3.ca.com/securityadvisor/virusinfo/virus.aspx?id=37776
Společnost Microsoft se vám snaží usnadnit získání technické podpory poskytnutím informací o kontaktech na jiné výrobce. Tyto kontaktní informace se mohou bez upozornění změnit. Společnost Microsoft neručí za přesnost kontaktních informací jiných dodavatelů.Poznámka: Program Win32.Agobot je pouze příklad. Nebezpečné programy zastarávají s tím, jak je dodavatelé antivirových programů zjišťují a přidávají k definicím virů. Uživatelé se zlými úmysly však často vyvíjejí nové programy a jejich varianty, aby je nebylo možné zjistit pomocí antivirového softwaru.

Řešení

Varování: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalování operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí.

Chcete-li ověřit, že byl počítač zasažen tímto problémem, postupujte podle následujících pokynů:
  1. Zkontrolujte, zda u hodnot registru AutoShareServer a AutoShareWks není nastavena 0:
    1. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz regedit a stiskněte klávesu ENTER.
    2. Vyhledejte v registru následující podklíč a klepněte na něj: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    3. Pokud jsou hodnoty AutoShareServer a AutoShareWks DWORD v podklíči
      LanmanServer\Parameters
      konfigurovány s hodnotou data 0, změňte tuto hodnotu na 1.

      Poznámka: Pokud tyto hodnoty neexistují, nemusíte je vytvářet, protože výchozí chování je nastaveno tak, aby se sdílené položky pro správu vytvářely automaticky.
    4. Ukončete Editor registru.
  2. Restartujte počítač. Počítače se systémy Windows Server 2003, Windows XP, Windows 2000 nebo Windows NT 4.0 obvykle automaticky vytvářejí sdílené položky pro správu během spuštění.
  3. Po restartování počítače zkontrolujte, zda jsou sdílené položky pro správu aktivní. Chcete-li zkontrolovat sdílené položky, použijte příkaz net share. Postupujte následujícím způsobem:
    1. Klepněte na tlačítko Start, na příkaz Spustit, zadejte cmd a stiskněte klávesu ENTER.
    2. Do příkazového řádku zadejte net share a stiskněte klávesu ENTER.
    3. V seznamu sdílených položek hledejte sdílené položky pro správu Admin$, C$ a IPC$.
Pokud sdílené položky pro správu nejsou v seznamu uvedeny, je možné, že je v počítači spuštěn nebezpečný program, který odstraňuje tyto sdílené položky během spuštění. Chcete-li hledat nebezpečné programy, postupujte takto:
  1. K provedení úplné antivirové kontroly v počítači použijte nejnovější definice virů. Můžete použít antivirový software nebo použít jednu z několika bezplatných služeb zjišťování virů, které jsou k dispozici na Internetu. Odkazy na aktualizace definic virů a na bezplatné kontroly online poskytované dodavateli antivirových softwarů naleznete v části Další informace.

    Důležité: Pokud máte podezření, že váš počítač byl napaden nebezpečným kódem, doporučujeme ho co nejdříve odebrat ze sítě. Toto doporučení se zakládá na skutečnosti, že uživatel se zlými úmysly může používat infikovaný počítač k zahájení útoků odmítnutím služby (denial of service) k odeslání nevyžádaných komerčních e-mailů nebo za účelem sdílení nelegálních kopií softwaru, hudby a filmů.
  2. Pokud antivirová kontrola zjistí nebezpečný program v systému, postupujte při jeho odstranění podle pokynů dodavatele antivirového programu. Dále si projděte informace o hodnocení rizika a technické detaily o programu na webu dodavatele antivirového programu. Zejména zkontrolujte, zda program obsahuje funkci backdoor. Funkce backdoor znamená, že program dává uživateli se zlými úmysly k dispozici způsob, jak znovu získat kontrolu nad systémem v případě, že je program zjištěn a odstraněn.

    Pokud technické detaily o programu uvádějí, že obsahuje funkci backdoor, doporučujeme formátovat pevný disk počítače a znovu bezpečně přeinstalovat systém Windows. Informace o zlepšení zabezpečení počítačů a serverů se systémem Windows naleznete na následujícím webu společnosti Microsoft:
    http://www.microsoft.com/security/guidance/default.mspx
  3. Pokud antivirová kontrola nezjistí v systému nebezpečný program, neznamená to, že počítač není infikován nebezpečným programem. Mnohem pravděpodobněji to může znamenat, že nebezpečný program je nový program nebo jeho varianta a že nejnovější definice virů ho nezjistí. V takovém případě kontaktujte dodavatele antivirového programu, aby problém oznámil nebo se obrátil na oddělení služeb odborné pomoci společnosti Microsoft se žádostí o podporu.
  4. Po dokončení antivirové kontroly zkontrolujte, zda se v počítači nevyskytují jiné nebezpečné programy, například špionážní programy nebo nástroje uživatelů se zlými úmysly. Odkazy na nástroje pro zjišťování špionážních programů a nástrojů uživatelů se zlými úmysly naleznete v části Další informace.
  5. Zkontrolujte všechny ostatní počítače v síti, zda se v nich nenacházejí nebezpečné programy a proveďte bezpečnostní analýzu za účelem identifikace chyb zabezpečení v síti. Chcete-li provést analýzu zabezpečení sítě, doporučujeme použít nástroj Microsoft Baseline Security Analyzer (MBSA) verze 1.2.1. Další informace o tomto nástroji naleznete na následujícím webu nástroje Microsoft Baseline Security Analyzer (MBSA) společnosti Microsoft:
    http://www.microsoft.com/technet/security/tools/mbsahome.mspx

Další informace

Technické informace o tom, jak pomoci při zabezpečení sítě naleznete na následujícím webu TechNet společnosti Microsoft s informacemi o zabezpečení:
http://www.microsoft.com/cze/security/technet/default.mspx
Chcete-li získat aktualizace definic virů od dodavatelů antivirového softwaru, navštivte některý z následujících webů jiných výrobců: Chcete-li získat bezplatnou kontrolu online od dodavatele antivirového softwaru, navštivte některý z následujících webů jiných výrobců:Chcete-li získat nástroje na zjišťování špionážních programů a nástrojů uživatelů se zlými úmysly, navštivte některý z webů jiných výrobců:Společnost Microsoft se vám snaží usnadnit získání odborné pomoci poskytnutím informací o kontaktech na jiné výrobce. Tyto kontaktní informace se mohou bez upozornění změnit. Společnost Microsoft neručí za správnost těchto informací o kontaktech na jiné výrobce.

Vlastnosti

ID článku: 842715 - Poslední aktualizace: 15. července 2005 - Revize: 2.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Klíčová slova: 
kbtshoot kbprb kb3rdparty KB842715

Dejte nám zpětnou vazbu