Visão geral dos problemas que podem ocorrer quando compartilhamentos administrativos estão faltando

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Sumário

Este artigo descreve os sintomas que podem ocorrer quando um ou mais compartilhamentos administrativos ocultos estão faltando no seu computador. O artigo também fornece informações sobre como resolver esse problema.

Se você já tiver determinado que o computador está faltando um ou mais compartilhamentos administrativos ocultos, consulte as seções "Causa" e "Resolução". Perceba que compartilhamentos administrativos ausentes normalmente indicam que o computador em questão foi comprometido por um software mal-intencionado. Recomendamos que os usuários formatar e reinstalar o Windows em servidores comprometidos.

Sintomas

Você pode enfrentar uma variedade de problemas quando compartilhamentos administrativos são removidos ou não estão presentes no seu computador.

Se você usar o comando net share ou MPSReports, a saída pode mostrar que seu computador está faltando o IPC$, ADMIN$ ou compartilhamento C$. Se você recriar um compartilhamento perdido, ele pode estar faltando novamente após a próxima inicialização ou logon. Esse problema pode ocorrer mesmo se você definir valores DWORD do Registro AutoShareServer e AutoShareWks como 1.

Você pode encontrar processos desconhecidos que iniciam a partir da pasta de inicialização ou o
Executar
chave do registro. Software antivírus pode detectar vírus, worms, cavalos de Tróia ou backdoors. Ou a raiz FTP em um servidor Web pode ser preenchida com arquivos desconhecidos.

A lista a seguir é uma lista abrangente de comportamento problemático que pode ser associado esse problema.
  • Se o computador afetado for um controlador de domínio, você pode receber mensagens de erro nos computadores clientes durante o logon de rede ou durante os períodos que eles tentarem ingressar no domínio. Às vezes, você pode fazer logon com computadores clientes que executam o Microsoft Windows 2000 ou Microsoft Windows XP, mas não pode fazer logon com computadores clientes que estejam executando o Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows Millennium Edition. Em computadores com Windows 9x, você pode receber uma mensagem de erro semelhante à seguinte:
    • A senha de domínio que você forneceu não está correta ou o acesso ao servidor de logon foi negado.
    • O servidor de logon não reconheceu sua senha de domínio ou acessar o servidor foi negado.
    Quando você tenta efetuar logon na rede em um computador baseado no Windows XP ou Windows 2000, você pode receber uma mensagem de erro semelhante à seguinte:
    Nenhum servidor de logon está disponível para atender à solicitação de logon.
    Quando você tenta ingressar no domínio, você pode receber uma mensagem de erro semelhante à seguinte:
    Erro ao tentar ingressar no domínio 'Nome_do_domínio': O nome da rede não foi encontrado.
  • Ao tentar acessar ou exibir o computador remotamente usando um caminho UNC, uma unidade mapeada, o comando net use , o comando net view , ou navegar na rede no ambiente de rede ou Meus locais de rede, você pode receber uma mensagem de erro semelhante à seguinte:
    • O servidor não está configurado para transações.
    • Ocorreu um erro de sistema 53. O caminho de rede não foi encontrado.
    • Nome_do_domínio não está acessível.
  • Você pode receber erros ao tentar executar tarefas administrativas em um controlador de domínio. Por exemplo, snap-ins do MMC, como o Active Directory Users e computadores ou serviços e Sites do Active Directory pode não iniciar e você pode receber uma mensagem de erro semelhante à seguinte:
    Informações de nomeação não podem ser localizadas porque: Falha na tentativa de logon.
  • Quando você tenta adicionar um usuário a um grupo de segurança, você pode receber uma mensagem de erro semelhante à seguinte:
    Seletor de objetos não pode abrir porque nenhum local do qual escolher objetos pode ser encontrados.
  • Quando você tentar executar Netdom. exe do Windows 2000 Support Tools para encontrar as funções FSMO, você pode receber uma mensagem de erro semelhante à seguinte:
    Não é possível atualizar a senha. O valor fornecido como senha atual está incorreto.
  • Quando você tentar executar Dcdiag. exe do Windows 2000 Support Tools, você pode receber uma mensagem de erro semelhante à seguinte:
    Falhou com 67: O nome da rede não foi encontrado
    Os resultados de Dcdiag. exe também podem listar os erros de ligação LDAP semelhantes à seguinte:
    Ligação LDAP falhou com erro 1323.
  • Quando você tentar executar Netdiag. exe do Windows 2000 Support Tools, você pode receber uma mensagem de erro semelhante à seguinte:
    Teste de lista DC. : Falha de
    Falha ao enumerar DCs usando o navegador. [NERR_BadTransactConfig]
  • Se você executar um rastreamento de rede ao tentar se conectar ao computador afetado, você pode ver resultados semelhantes à seguinte:
    C session setup & X, Username = username, and C tree connect & X, Share = \\<Server_Name>\IPC$
    R session setup & X - DOS Error, (67) BAD_NET_NAME
    
  • No servidor, o serviço WINS pode não iniciar ou o console do WINS pode exibir um x vermelho, ou ambos.
  • Eventos 4311 do NetBT semelhantes ao seguinte podem ser registrados no Visualizador de eventos:

    Identificação de evento: 4311
    Origem do evento: NetBT
    Tipo de evento: erro
    Descrição: A inicialização falhou porque o dispositivo de driver não pôde ser criado

  • O console de licenciamento de serviços de Terminal pode não iniciar e você pode receber uma mensagem de erro semelhante à seguinte:
    • Nenhum servidor de licenças do Terminal Services está disponível no domínio atual ou grupo de trabalho. Para se conectar a outro servidor de licenças, clique em licença, clique em conectar e clique no nome do servidor.
    • O endereço de rede é inválido
  • Serviços para Macintosh podem não iniciar. Quando você tenta iniciar o serviço, eventos semelhantes ao seguinte podem ser registrados em Visualizar eventos:

    Tipo de evento: erro
    Origem do evento: MacFile
    Categoria do evento: nenhuma
    Identificação de evento: 10021
    Usuário: n / a
    Descrição: O servidor de arquivos para Macintosh não pôde contatar um controlador de domínio para obter informações de domínio.

    Tipo de evento: erro
    Origem do evento: MacFile
    Categoria do evento: nenhuma
    Identificação de evento: 10027
    Usuário: n / a
    Descrição: Ocorreu um erro ao inicializar o servidor de arquivos para Macintosh. Não foi possível inicializar um segmento auxiliar do servidor. Código de erro específico está nos dados.

    Tipo de evento: erro
    Origem do evento: MacFile
    Categoria do evento: nenhuma
    Identificação de evento: 10001
    Usuário: n / a
    Descrição: Não é possível iniciar o servidor de arquivos para Macintosh. Ocorreu um erro específico do sistema. O código de erro está nos dados

    Tipo de evento: erro
    Origem do evento: Service Control Manager
    Categoria do evento: nenhuma
    Identificação de evento: 7024
    Usuário: n / a
    Descrição: O servidor de arquivos para Macintosh foi encerrado com erro específico do serviço 1722.

Causa

Esses problemas podem ocorrer após um programa mal-intencionado remover os compartilhamentos administrativos em um computador que esteja executando o Windows Server 2003, Windows XP, Windows 2000 ou Windows NT 4.0.

Freqüentemente, usuários mal-intencionados se conectam a esses compartilhamentos administrativos aproveitando de senhas fraca, atualizações de segurança, exposição direta do computador à Internet ou uma combinação desses fatores. Os usuários mal-intencionados instalar programas mal-intencionados para expandir sua influência sobre o computador e sobre o restante da rede de computadores. Em muitos casos, esses programas mal-intencionados removem os compartilhamentos administrativos como um movimento de defesa para impedir outros usuários mal-intencionados adversários de assumir o controle dos sistemas infectados.

A infecção por um desses programas mal-intencionados pode vir diretamente da Internet ou de outro computador na rede local que está infectada. Isso geralmente indica que a segurança da rede é fraca. Portanto, se você perceber esses sintomas, recomendamos que você examine todos os outros computadores na rede por programas mal-intencionados usando ferramentas de detecção de spyware e software antivírus. Também recomendamos que você execute uma análise de segurança para identificar vulnerabilidades na rede. Consulte a seção "Resolução" para obter informações sobre como detectar programas mal-intencionados e como analisar a segurança de rede.

Um exemplo de um programa mal-intencionado que visa compartilhamentos administrativos é o programa Agobot. Para obter detalhes técnicos sobre como funciona este programa, visite o seguinte site da Computer Associates vírus informações Central:
http://www3.CA.com/securityadvisor/virusInfo/Virus.aspx?ID=37776
A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações de contato de terceiros.Observação O programa Agobot é apenas um exemplo. Programas mal-intencionados se tornam obsoletos como fornecedores de antivírus os descobrem e adicioná-los para suas definições de vírus. No entanto, usuários mal-intencionados desenvolvem com freqüência novos programas e variantes para evitar a detecção pelos softwares antivírus.

Resolução

Importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756 Como fazer backup e restaurar o registro no Windows


Para verificar se um computador está afetado por esse problema, execute essas etapas:
  1. Examine os valores do Registro AutoShareServer e AutoShareWks para certificar-se de que não estão definidos como 0:
    1. Clique em Início, clique em Executar, tipo Regedit, e pressione ENTER.
    2. Localize e clique a seguinte subchave do registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    3. Se o DWORD AutoShareServer e AutoShareWks valores na
      LanmanServer\Parameters
      subchaves são configurados com um valor 0, altere o valor para 1.

      Observação Se esses valores não existirem, é necessário criá-los porque o comportamento padrão é criar automaticamente os compartilhamentos administrativos.
    4. Feche o Editor do registro.
  2. Reinicie o computador. Normalmente, os computadores que estejam executando o Windows Server 2003, Windows XP, Windows 2000 ou Windows NT 4.0 automaticamente criam compartilhamentos administrativos durante a inicialização.
  3. Após o computador for reiniciado, verifique se os compartilhamentos administrativos estão ativos. Para examinar os compartilhamentos, use o NET share comando. Para fazer isso, siga estas etapas:
    1. Clique em Início, clique em Executar, tipo cmd, e pressione ENTER.
    2. No prompt de comando, digite NET share, e pressione ENTER.
    3. Procure o Admin$, C$ e compartilhamentos administrativos do IPC$ na lista de compartilhamentos.
Se os compartilhamentos administrativos não estiverem listados, o computador pode estar executando um programa mal-intencionado que remove os compartilhamentos durante a inicialização. Para procurar por programas mal-intencionados, execute estas etapas:
  1. Use as definições de vírus mais recentes para executar um exame antivírus completo no computador. Você pode usar seu software antivírus ou usar um dos vários antivírus serviços gratuitos disponíveis na Internet. Consulte a seção "Mais informações" para obter links para atualizações de definição de vírus e exames online gratuitos de fornecedores de software antivírus.

    Importante Se você suspeitar que um computador está infectado com um código mal-intencionado, recomendamos que você o remova da rede assim que possível. Recomendamos isso porque um usuário mal-intencionado pode estar usando o computador infectado para iniciar ataques de negação de serviço distribuído (DDoS), enviar email comercial não solicitado ou para compartilhar cópias ilegais de software, músicas e filmes.
  2. Se o exame antivírus identificar um programa mal-intencionado no sistema, use as instruções de remoção do fornecedor do antivírus. Além disso, revise a avaliação da ameaça e os detalhes técnicos sobre o programa no site do fornecedor de antivírus. Em particular, verifique se o programa inclui capacidade backdoor. Capacidade backdoor significa que o programa fornece uma maneira para que o usuário mal-intencionado recuperar o controle do sistema se o programa for descoberto e removido.

    Se os detalhes técnicos sobre o programa indicarem que ele tem capacidade backdoor, recomendamos que formate o disco rígido do computador e reinstalar o Windows com segurança. Para obter informações sobre como melhorar a segurança de servidores e computadores baseados no Windows, visite o seguinte site da Microsoft Security Guidance Center na Web:
    http://technet.microsoft.com/en-us/library/cc184906.aspx
  3. Se o exame antivírus identificar um programa mal-intencionado no sistema, não significa que o computador não está infectado por um programa mal-intencionado. Mais provavelmente, pode significar que o programa mal-intencionado é um novo programa ou variante e que as definições de vírus mais recentes não o detectam. Nesse caso, contate o fornecedor do antivírus para relatar o problema ou abrir um incidente de suporte com o Microsoft Product Support Services (PSS) para investigar.
  4. Após concluir a varredura antivírus, examine o computador para outros programas mal-intencionados, como spyware ou ferramentas de usuário mal-intencionado. Consulte a seção "Mais informações" para obter links para spyware e ferramentas de detecção do usuário mal-intencionado.
  5. Verifique todos os outros computadores na rede por programas mal-intencionados e realize uma análise de segurança para identificar vulnerabilidades na rede. Analisar a segurança de rede, recomendamos que você use a ferramenta de Microsoft Baseline Security Analyzer versão 1.2.1. Para obter mais informações sobre essa ferramenta, visite o seguinte site da Web do Microsoft Baseline Security Analyzer:
    http://technet.microsoft.com/en-US/Security/cc184924.aspx

Mais Informação

Para obter informações técnicas sobre como ajudar a proteger sua rede, visite o seguinte Web site Microsoft TechNet security:
http://www.microsoft.com/technet/security/default.mspx
Para obter atualizações de definição de vírus de fornecedores de software antivírus, visite qualquer um dos seguintes sites de terceiros:Para obter um exame online gratuito de um fornecedor de software antivírus, visite qualquer um dos seguintes sites de terceiros:Para obter ferramentas de detecção do usuário mal-intencionado e spyware, visite qualquer um dos seguintes sites de terceiros:A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações de contato de terceiros.

Propriedades

Artigo: 842715 - Última revisão: 29 de março de 2012 - Revisão: 0.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kb3rdparty kbtshoot kbprb kbmt KB842715 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 842715

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