Visão geral dos problemas que podem ocorrer quando as ações administrativas estão ausentes

Este artigo fornece uma resolução para os problemas que podem ocorrer quando os compartilhamentos administrativos estão ausentes.

Aplica-se a: Windows Server 2012 R2, Windows 10 - todas as edições
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Resumo

Este artigo descreve os sintomas que podem ocorrer quando um ou mais compartilhamentos administrativos ocultos estão ausentes em seu computador. O artigo também fornece informações sobre como resolve esse problema.

Se você já tiver determinado que seu computador está ausente de um ou mais compartilhamentos administrativos ocultos, consulte as seções "Causa" e "Resolução". Observe que compartilhamentos administrativos ausentes normalmente indicam que o computador em questão foi comprometido por software mal-intencionado. Recomendamos que os usuários formatem e reinstalem o Windows em servidores comprometidos.

Sintomas

Você pode ter uma variedade de problemas quando os compartilhamentos administrativos são removidos ou estão ausentes do computador.

Se você usar o comando de compartilhamento líquido ou MPSReports, a saída poderá mostrar que seu computador está perdendo a ação IPC$, ADMIN$ou C$. Se você recriar um compartilhamento ausente, ele poderá estar ausente novamente após a próxima inicialização ou logon. Esse problema pode ocorrer mesmo se você definir os valores DWORD do Registro AutoShareServer e AutoShareWks como 1.

Você pode encontrar processos desconhecidos que começam na pasta Inicialização ou na chave Executar no registro. O software antivírus pode detectar vírus, worms, trojans ou backdoors. Ou a raiz FTP em um servidor Web pode ser preenchida com arquivos desconhecidos.

A lista a seguir é uma lista abrangente do comportamento problemático que pode estar associado a esse problema.

  • Se o computador afetado for um controlador de domínio, você poderá receber mensagens de erro em computadores cliente durante o logon de rede ou durante os momentos em que eles tentam ingressar no domínio. Às vezes, você pode fazer logon com computadores cliente, mas pode receber uma mensagem de erro semelhante a qualquer uma das seguintes:

    • A senha de domínio fornecida não está correta ou o acesso ao servidor de logon foi negado.

    • O servidor de logon não reconheceu sua senha de domínio ou o acesso ao servidor foi negado.

    • Nenhum servidor de logon está disponível para atender à solicitação de logon.

      Ao tentar ingressar no domínio, você pode receber uma mensagem de erro semelhante a:

      O seguinte erro ocorreu ao tentar ingressar no domínio 'Domain_Name': O nome da rede não pode ser encontrado.

  • Quando você tenta acessar ou exibir o computador afetado remotamente usando um caminho UNC, uma unidade mapeada, o comando de uso da rede, o comando net view ou navegando pela rede no Network Neighborhood ou no My Network Places, você pode receber uma mensagem de erro semelhante a uma das seguintes:

    • O servidor não está configurado para transações.

    • O erro do sistema 53 ocorreu. O caminho de rede não foi encontrado.

    • Domain_Name não está acessível.

  • Você pode receber erros ao tentar executar tarefas administrativas em um controlador de domínio. Por exemplo, os snap-ins do MMC, como Usuários e Computadores do Active Directory ou Sites e Serviços do Active Directory, podem não ser iniciados e você pode receber uma mensagem de erro semelhante à seguinte:

    As informações de nomenclatura não podem ser localizadas porque: falha na tentativa de logon.

  • Ao tentar adicionar um usuário a um grupo de segurança, você pode receber uma mensagem de erro semelhante a:

    O Seletor de Objetos não pode abrir porque nenhum local do qual escolher objetos pode ser encontrado.

  • Ao tentar executar Netdom.exe para encontrar as funções FSMO, você pode receber uma mensagem de erro semelhante à seguinte:

    Não é possível atualizar a senha. O valor fornecido como a senha atual está incorreto.

  • Ao tentar executar Dcdiag.exe, você pode receber uma mensagem de erro semelhante à seguinte:

    Falha com 67: o nome da rede não pode ser encontrado

    Os resultados de Dcdiag.exe também podem listar erros de associação LDAP semelhantes aos seguintes:

    Falha na associação LDAP com o erro 1323.

  • Ao tentar executar Netdiag.exe, você pode receber uma mensagem de erro semelhante a:

    Teste de lista DC. . . . . . . . . . . : Falha
    Falha ao enumerar DCs usando o navegador. [NERR_BadTransactConfig]

  • Se você executar um rastreamento de rede ao tentar se conectar ao computador afetado, poderá ver resultados semelhantes aos seguintes:

    C session setup & X, Username = username, and C tree connect & X, Share = \\<Server_Name>\IPC$  
    R session setup & X - DOS Error, (67) BAD_NET_NAME
    
  • No servidor, o serviço WINS pode não iniciar ou o console WINS pode exibir um X vermelho ou ambos.

  • Eventos netBT 4311 semelhantes aos seguintes podem ser registrados em Visualizador de Eventos:

    ID do evento: 4311
    Fonte do evento: NetBT
    Tipo de Evento: Erro
    Descrição: falha na inicialização porque o dispositivo de driver não pôde ser criado

  • O console de Licenciamento dos Serviços de Terminal pode não ser iniciado e você pode receber uma mensagem de erro semelhante a:

    • Nenhum servidor de licença dos Serviços de Terminal está disponível no domínio ou grupo de trabalho atual. Para se conectar a outro servidor de licença, clique em licença, clique em conectar e clique no nome do servidor.

    • O endereço de rede é inválido

Motivo

Esses problemas podem ocorrer depois que um programa mal-intencionado remove os compartilhamentos administrativos em um computador que está executando o Windows Server.

Com frequência, usuários mal-intencionados se conectam a esses compartilhamentos administrativos aproveitando senhas fracas, atualizações de segurança ausentes, exposição direta do computador à Internet ou uma combinação desses fatores. Em seguida, os usuários mal-intencionados instalam programas mal-intencionados para expandir sua influência sobre o computador e sobre o resto da rede de computadores. Em muitos casos, esses programas mal-intencionados removem os compartilhamentos administrativos como um movimento defensivo para impedir que outros usuários mal-intencionados concorrentes assumissem o controle dos sistemas infectados.

A infecção por um desses programas mal-intencionados pode vir diretamente da Internet ou de outro computador na rede local que está infectado. Geralmente, indica que a segurança na rede é fraca. Portanto, se você vir esses sintomas, recomendamos examinar todos os outros computadores na rede para programas mal-intencionados usando software antivírus e ferramentas de detecção de spyware. Também recomendamos que você execute uma análise de segurança para identificar vulnerabilidades na rede. Consulte a seção "Resolução" para obter informações sobre como detectar programas mal-intencionados e como analisar a segurança de rede.

Um exemplo de um programa mal-intencionado que visa compartilhamentos administrativos é o Win32.Agobot programa.

A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Essas informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações para contato com outras empresas.

Observação

O Win32.Agobot programa é apenas um exemplo. Programas mal-intencionados tornam-se obsoletos à medida que os fornecedores de antivírus os descobrem e os adicionam às definições de vírus. No entanto, usuários mal-intencionados frequentemente desenvolvem novos programas e variantes para evitar a detecção por software antivírus.

Resolução

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como fazer o backup e a restauração do Registro no Windows

Para verificar se um computador é afetado por esse problema, siga estas etapas:

  1. Examine os valores do registro AutoShareServer e AutoShareWks para garantir que eles não estejam definidos como 0:

    1. Clique em Iniciar, clique em Executar, digite regedit e pressione ENTER.
    2. Localize e clique na seguinte subchave do Registro: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    3. Se os valores DWORD AutoShareServer e AutoShareWks na subchave LanmanServer\Parameters forem configurados com um valor de dados de 0, altere esse valor para 1.

      Observação

      Se esses valores não existirem, você não precisará criá-los porque o comportamento padrão é criar automaticamente os compartilhamentos administrativos.

    4. Saia do Editor do Registro.
  2. Reinicie o computador. Normalmente, computadores que estão executando o Windows Server criam automaticamente os compartilhamentos administrativos durante a inicialização.

  3. Após a reinicialização do computador, verifique se os compartilhamentos administrativos estão ativos. Para examinar os compartilhamentos, use o comando net share. Para fazer isso, siga estas etapas:

    1. Clique em Iniciar, clique em Executar, digite cmd e pressione ENTER.

    2. No prompt de comando, digite compartilhamento líquido e pressione ENTER.

    3. Procure as ações administrativas Administração$, C$e IPC$ na lista de ações.

Se os compartilhamentos administrativos não estiverem listados, o computador poderá estar executando um programa mal-intencionado que remove os compartilhamentos durante a inicialização. Para procurar programas mal-intencionados, siga estas etapas:

  1. Use as definições de vírus mais recentes para executar uma verificação completa de antivírus no computador. Você pode usar seu software antivírus ou usar um dos vários serviços gratuitos de verificação de vírus que estão disponíveis na Internet. Consulte a seção "Mais Informações" para obter links para atualizações de definição de vírus e para obter verificações online gratuitas de fornecedores de software antivírus.

    Importante

    Se você suspeitar que um computador está infectado com código mal-intencionado, recomendamos removê-lo da rede o mais rápido possível. Recomendamos isso porque um usuário mal-intencionado pode estar usando o computador infectado para iniciar ataques DDoS (Negação Distribuída de Serviço), para enviar emails comerciais não solicitados ou para compartilhar cópias ilegais de software, música e filmes.

  2. Se a verificação antivírus identificar um programa mal-intencionado no sistema, use as instruções de remoção do fornecedor antivírus. Além disso, examine a avaliação de ameaças e os detalhes técnicos sobre o programa no site do fornecedor de antivírus. Em particular, marcar para ver se o programa inclui recursos de backdoor. A funcionalidade de backdoor significa que o programa fornece uma maneira de o usuário mal-intencionado recuperar o controle do sistema se o programa for descoberto e removido.

    Se os detalhes técnicos sobre o programa indicarem que ele tem funcionalidade de backdoor, recomendamos formatar o disco rígido do computador e reinstalar o Windows com segurança. Para obter informações sobre como melhorar a segurança de computadores e servidores baseados no Windows, visite a seguinte Central de Diretrizes de Segurança da Microsoft

  3. Se a verificação antivírus não identificar um programa mal-intencionado no sistema, isso não significa que o computador não esteja infectado por um programa mal-intencionado. Mais provável, isso pode significar que o programa mal-intencionado é um novo programa ou variante, e que as definições mais recentes de vírus não o detectam. Nesse caso, entre em contato com o fornecedor antivírus para relatar o problema ou abra um incidente de suporte com o PSS (Serviços de Suporte ao Produto) da Microsoft para investigar.

  4. Depois de concluir a verificação de antivírus, examine o computador para outros programas mal-intencionados, como spyware ou ferramentas de usuário mal-intencionadas. Consulte a seção "Mais Informações" para obter links para spyware e ferramentas de detecção de usuário mal-intencionadas.

  5. A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Essas informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações para contato com outras empresas.