Article ID: 842739 - Last Review: October 25, 2006 - Revision: 1.6

Other advertisements unexpectedly run after you use the Software Update Scanning Tools to install software updates in Systems Management Server 2003

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SYMPTOMS

Assume a scenario where the following conditions are true:
  • You (the system administrator) use the Microsoft Systems Management Server (SMS) 2003 Software Update Scanning Tools to install software updates on an SMS 2003 Legacy Client.
  • These software updates require a system restart of the SMS client computer.
In this scenario, other advertisements that are assigned to the SMS 2003 Legacy Client may automatically start to run after the countdown timer that appears in the System Shutdown Timeout dialog box is presented to the user who is logged on to the SMS client computer. Additionally, pending advertisements may not run as expected when the SMS 2003 client computer is restarted.

If any one of the assigned advertisements depends on the successful installation of the software update, the assigned advertisements may not be installed correctly until the SMS 2003 Legacy Client is restarted.

CAUSE

This problem occurs when the Software Updates Installation Agent (Patchinstall.exe) calls the InitiateSystemShutdown function to restart the SMS 2003 client computer. After the InitiateSystemShutdown function triggers a system restart, it hands control back to the SMS Advanced Client Execution Manager. Then, the SMS Advanced Client Execution Manager may try to run any other outstanding assigned advertisements while the countdown timer that appears in the System Shutdown Timeout dialog box is running.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Feb-2004  18:03  2.0.6.7           355,242  Smsupdate.exe    
   06-Aug-2000  09:51  2000.80.194.0     274,489  Ntwdblib.dll     
   25-Dec-2003  11:55  2.50.2726.136     348,160  Patchinstall.exe  
   23-Feb-2003  10:05  2.0.1493.5011     855,312  Preinst.exe      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbbug KB842739
 

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