Počítač so systémom Windows Server 2003 môže po prechode z úsporného režimu prestať reagovať, pričom sa do denníka aplikácie radiča domény zapíšu udalosti 1030 a 1058

Preklady článku Preklady článku
ID článku: 842804
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Po prechode z úsporného režimu môže počítač so systémom Windows Server 2003 prestať reagovať. Až jednu hodinu pred zobrazením pracovnej plochy sa tiež môže zobrazovať okno s hlásením Načítavajú sa osobné nastavenia.

Štandardne je počítač so systémom Windows Server 2003 po prepnutí z úsporného režimu zamknutý. Pred získaním prístupu k pracovnej ploche je nutné prihlásiť sa do počítača. Keď sa však vyskytne tento problém, počítač nie je zamknutý a prihlasovacia obrazovka systému Windows Server 2003 sa nezobrazí.

Po reštartovaní počítača so systémom Windows Server 2003 sa okrem toho do denníka aplikácie v radiči domény môžu zapísať nasledujúce hlásenia udalostí:
Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1058
Description: Windows cannot access the file gpt.ini for GPO CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=domain,DC=com. The file must be present at the location <\\domain\sysvol\domain\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (Access is denied. ). Group Policy processing aborted. For more information, see Help and Support Center at http://support.microsoft.com.
alebo
Description: Windows cannot access the file gpt.ini for GPO CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=domain,DC=com. The file must be present at the location <\\domain\sysvol\domain\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (The network path was not found. ).

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1030
Description: Windows cannot query for the list of Group Policy objects. A message that describes the reason for this was previously logged by the policy engine. For more information, see Help and Support Center at http://support.microsoft.com.
Keď zapnete zapisovanie do denníka udalostí používateľského prostredia (Userenv), doménové služby Distributed File System (DFS) nemusia po prechode počítača z úsporného režimu fungovať. Okrem toho sa v súbore %SystemRoot%\Debug\UserMode\Userenv.log môžu zobraziť ďalšie hlásenia podobné nasledujúcim.

Poznámka Informácie o zapnutí zapisovania do denníka Userenv sa nachádzajú v článku databázy Microsoft Knowledge Base, na ktorý sa odkazuje v časti Referencie.
USERENV(1d8.a84) 21:52:58:718 EvaluateDeferredGPOs: Searching for GPOs in cn=policies,cn=system,DC=domain,DC=local
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Searching <CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=domain,DC=local>
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Machine has access to this GPO.
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: GPO passes the filter check.
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Found functionality version of: 2
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Found file system path of: <\\doména.local\sysvol\doména.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}>
USERENV(1d8.a84) 21:52:58:734 ProcessGPO: Couldn't find the group policy template file <\\domain.local\sysvol\domain.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>, error = 0x5.

PRICINA

Tento problém sa môže vyskytnúť, ak sa prihlasovací proces Winlogon pred spustením ďalších súčastí pokúša spracovať skupinové politiky. Pomocou balíka Service Pack popísaného v tomto článku sa do procesu pridáva logika, ktorá upravuje správanie procesu Winlogon a služieb pracovnej stanice.

Existuje však niekoľko ďalších potenciálnych príčin, ktoré môžu spôsobovať tento problém. Pred použitím tohto balíka Service Pack skontrolujte, či sú spustené a správne nakonfigurované nasledujúce súčasti:
  • Sú spustené služby Netlogon a DFS.
  • Doménové radiče majú priradené práva na čítanie a použitie vzťahujúce sa na politiku doménových radičov.
  • Povolenia súborového systému NTFS a povolenia zdieľaného ukladacieho priestoru sú správne nastavené na zdieľanom priestore Sysvol.
  • Položky DNS sú pre jednotlivé doménové radiče správne priradené.

RIESENIE

Ak chcete vyriešiť tento problém, prečítajte si časť Informácie o balíku Service Pack, ktorá nasleduje po tejto časti. Ak chcete dočasne vyriešiť tento problém, prečítajte si časť Dočasné riešenie v aktuálnej časti Riešenie.

Informácie o balíku Service Pack

Ak chcete odstrániť tento problém, prevezmite si najnovší balík Service Pack pre systém Windows Server 2003. Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
889100 Informácie o možnostiach získania najnovšieho balíka Service Pack pre systém Windows Server 2003
Poznámka Po nainštalovaní tohto balíka Service Pack sa vráťte k tomuto článku a použite postup popísaný v časti Informácie o databáze Registry, ktorá nasleduje po tejto časti.

Informácie o databáze Registry

Poznámka Tento postup použite v systéme Windows Server 2003.

Dôležité upozornenie Táto časť, postup alebo úloha obsahuje kroky, ktoré informujú o úpravách databázy Registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Postupujte preto presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je vhodné pred úpravou databázu Registry zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o zálohovaní a obnovení databázy Registry sa nachádzajú v nasledujúcom článku databázy Microsoft Knowledge Base:
322756 Zálohovanie a obnovovanie databázy Registry v systéme Windows
Ak chcete, aby sme tento postup vykonali za vás, prejdite do časti Opravte to za mňa. Ak chcete tento problém vyriešiť sami, prejdite do časti Ja to vyriešim.

Opravte to za mňa



Ak chcete tento problém vyriešiť automaticky, kliknite na prepojenie alebo tlačidlo Fix it. Kliknite na položku Spustiť v dialógovom okne Prevzatie súboru a postupujte podľa pokynov Sprievodcu nástroja Fix it.


Odstrániť tento problém
Microsoft Fix it 50615

Poznámky
  • Pred spustením balíka nainštalujte balík Service Pack uvedený v časti Informácie o balíku Service Pack.
  • Tento sprievodca môže byť dostupný iba v angličtine. Automatická oprava však funguje aj pre ostatné jazykové verzie systému Windows.
  • Ak práve nepracujete s počítačom, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na jednotku flash alebo na disk CD a potom ho spustiť v počítači s problémom.

Potom prejdite do časti Vyriešil sa problém?



Ja to vyriešim

Po použití balíka Service Pack postupujte nasledovne:
  1. Kliknite na tlačidlo Štart a na položku Spustiť. Do poľa Otvoriť zadajte príkaz regedit a potom kliknite na tlačidlo OK.
  2. V Editore databázy Registry vyhľadajte nasledujúci podkľúč:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Ak položka WaitForNetwork chýba, je nutné ju pridať. Postupujte nasledovne:
    1. Kliknite pravým tlačidlom na podkľúč Winlogon, kliknite na položku Nový a potom na položku Hodnota DWORD.
    2. Do poľa Názov hodnoty zadajte hodnotu WaitForNetwork.
  4. Kliknite pravým tlačidlom na položku WaitForNetwork a potom kliknite na príkaz Upraviť.
  5. V dialógovom okne Úprava hodnoty DWORD zadajte do poľa Údaje hodnôt hodnotu 1 a potom kliknite na tlačidlo OK.
  6. Zatvorte Editor databázy Registry.

Vyriešil sa problém?

  • Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, úspešne ste dokončili postupy v tejto časti. Ak sa problém nepodarilo vyriešiť, môžete sa obrátiť na oddelenie technickej podpory.
  • Oceníme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť ľubovoľný problém súvisiaci s týmto riešením, použite blog Fix it for me alebo nám odošlite e-mail.

Dočasné riešenie

Ak chcete dočasne vyriešiť tento problém, môžete spustiť súbor Dfsutil.exe, ktorý je zahrnutý do balíka nástrojov technickej podpory Windows Server 2003 Support Tools. Balík Windows Server 2003 Support Tools možno nainštalovať dvoma spôsobmi. Môžete spustiť súbor \\Support\Tolls\Suptools.msi z disku CD-ROM so systémom Windows Server 2003. Alebo môžete nástroje technickej podpory nástroje extrahovať zo súboru \\Support\Tools\Support.cab. Pri spustení súboru Dfsutil.exe postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz cmd a potom kliknite na tlačidlo OK.
  2. Do príkazového riadka zadajte príkaz dfsutil /PurgeMupCache a stlačte kláves ENTER.

STAV

Spoločnosť Microsoft potvrdila, že ide o problém, ktorý sa týka produktov spoločnosti Microsoft uvedených v časti „Vzťahuje sa na“.
Tento problém bol prvýkrát vyriešený v balíku Windows Server 2003 Service Pack 1.

ODKAZY

Ďalšie informácie o povolení zapisovania do denníka udalostí používateľského prostredia získate po kliknutí na nasledujúce číslo článku databázy Microsoft Knowledge Base:
221833 Postup pri povolení zapisovania ladenia používateľského prostredia do denníka v maloobchodných zostavách systému Windows
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Vlastnosti

ID článku: 842804 - Posledná kontrola: 8. apríla 2011 - Revízia: 1.0
Kľúčové slová: 
kbresolve kbqfe kbwinserv2003presp1fix kbprb kbbug kbfixme kbmsifixme KB842804

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com