Windows XP ベースのコンピューターからログオフするとシステム ユーザー プロフィール正しくアンロードされません。

文書翻訳 文書翻訳
文書番号: 842827 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Windows XP ベースのコンピューターからログオフすると、システム ユーザー プロフィール正しくアンロードがあります。さらに、次のエラーがアプリケーション ログに記録されます。

イベントの種類: エラー
イベント ソース: Userenv
イベント カテゴリ: なし
イベント ID: 1524
説明:
Windows クラス レジストリ ファイルをアンロードすることはできません - それは他のアプリケーションやサービスで使用します。使用中のときファイル読み込まれますされません。

もう一度、コンピューターにログオンすると、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーが読み込まれていません。さらに、COM の特定の操作に失敗します。たとえばは COM 操作を Outlook フォームに失敗します。

原因

コンピューターにログオンすると、WebDav クライアント サービス ハンドル、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーをユーザーごとの初期化中にキャッシュされるため、この問題が発生します。

HKEY_CURRENT_USER\Software\Classes レジストリ サブキー、Usrclass.dat ファイルでユーザー プロファイルです。ユーザーごとの COM 登録は、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーが使用されます。そのため、キャッシュされているハンドルがあるため、コンピューターからログオフすると、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーはアンロードできません。

解決方法

修正プログラムの情報

サポートされている修正プログラムをマイクロソフトから入手することができます。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用して下さい。この修正プログラムには、さらに追加テストが行われる可能性があります。したがって、この問題により深刻な影響を受けていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

修正プログラムがダウンロード可能な場合は、この記事の上部に「修正プログラムのダウンロード」セクションが表示されます。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポートへお問い合わせいただき、修正プログラムを入手してください。

その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。通常のサポート料金は、この特定の修正プログラムの対象とならない追加のサポートに関する質問および問題に適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
「修正プログラムのダウンロード」フォームには、修正プログラムを利用可能な言語が表示されます。お使いの言語が見つからない場合は、修正プログラムがその言語で利用可能ではありません。

前提条件

Windows XP SP2 がこの修正プログラムを適用するインストールが必要です。

再起動の必要性

この修正プログラムを適用した後、コンピューターを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムが、他のいかなる修正プログラムも置き換えることはありません。

ファイル情報

この修正プログラムの英語版のファイル属性 (またはそれ以降のファイル属性) を、次の表に一覧表示します。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイルの情報を表示するはローカル時刻に変換されます。UTC とローカル時刻との時差を確認するのを使用して、 タイム ゾーン タブには 日付と時刻 コントロール パネルの項目。
元に戻す全体を表示する
ファイル名ファイル バージョンファイル サイズ日付時間プラットフォームSP 要件区分
Advapi32.dll5.1.2600.3039617,4722006 年 11 月 22 日13:07x86SP2SP2QFE
Webclnt.dll5.1.2600.303968,0962006 年 11 月 22 日13:07x86SP2SP2QFE

回避策

この問題を回避するには、Microsoft ユーザー プロファイル ハイブのクリーンアップ サービス (UPHClean) を使用します。UPHClean Windows ユーザープロファイルのアンロード中に、コンピューターを監視します。UPHClean を閉じます開いているリソースを強制的します。したがって、コンピューターでユーザー プロファイルをアンロードできます。

ダウンロードして、UPHClean をインストールするのには、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582

状況

マイクロソフトでは、この問題をこの資料の「対象製品」として記載されているマイクロソフト製品の問題として認識しています。

詳細

HKEY_CLASSES_ROOT レジストリ サブツリー マージされたビュー、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーの HKEY_LOCAL_MACHINE\Software\Classes レジストリ サブキーです。HKEY_CLASSES_ROOT レジストリ サブツリーから、システムを読み込むときに、HKEY_CURRENT_USER レジストリ サブツリーの下にある、ユーザーごとのデータ HKEY_LOCAL_MACHINE サブツリーの下にあるコンピューターのデータを上書きします。システム、HKEY_CLASSES_ROOT レジストリ サブツリーに書き込む場合、データは、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーにリダイレクトされます。HKEY_CURRENT_USER\Software\Classes レジストリ サブキー、Usrclass.dat ファイルで、ユーザーのプロファイルです。そのため、通常のユーザは、通常、HKEY_LOCAL_MACHINE\Software\Classes のレジストリ サブキーに読み取り専用のアクセスが COM クラス登録ユーザーを作成できます。

この資料に記載されている問題が発生すると、HKEY_CURRENT_USER\Software\Classes のレジストリ サブキーがレジストリに、次回コンピューターにログオンはありません。そのため、ユーザーごとの COM の登録がありません。

プロパティ

文書番号: 842827 - 最終更新日: 2013年3月10日 - リビジョン: 7.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbautohotfix kbqfe kbHotfixServer kbtshoot kbexpertiseinter kbprb kbmt KB842827 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:842827
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com