Article ID: 843023 - Last Review: July 24, 2007 - Revision: 2.6

The Re-run command is unavailable when a user tries to rerun an advertisement in Systems Management Server 2003

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SYMPTOMS

When a user logs on and then tries to use the Microsoft Systems Management Server (SMS) 2003 Administrator Console to rerun an advertisement, the Re-run command on the All Tasks shortcut menu is unavailable, and the user cannot click it. Additionally, this symptom may have occurred when you originally created the advertisement.

CAUSE

This problem occurs if the logged-on user does not have all the following rights:
  • Read rights for the Collection class
  • Advertise rights for the Collection class
  • Distribute rights for the Package class
  • Modify rights for the Advertisement class
An SMS 2003 administrator may not have these specific rights if they have full rights only on a single collection, on a single package, or on a single advertisement.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885643  (http://support.microsoft.com/kb/885643/ ) How to obtain the latest Systems Management Server 2003 service pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   25-Dec-2003  12:35  2.50.2726.143  118,784  Sms_matk.dll

Hotfix installation instructions

To apply this hotfix, follow these steps:
  1. Create a new folder in a location that your SMS site servers can use, and then copy the Sms2003-rtm-kb843023-x86-enu.exe hotfix file to the new folder.
  2. From each computer that has the SMS Administrator Console installed, use an account that has administrative credentials to log on to your site server.

    Note Each computer that has the SMS Administrator Console installed includes all the primary SMS site servers in your environment.
  3. Quit the SMS Administrator Console if it is running.
  4. Run the Sms2003-rtm-kb843023-x86-enu.exe file, and then follow the instructions in the wizard.
After you apply this hotfix, the Re-run command is available on the All Tasks shortcut menu if the logged-on user has all the following instance-level rights:
  • Read rights for the Collection instance
  • Advertise rights for the Collection instance
  • Distribute rights for the Package instance
  • Modify rights for the Advertisement instance

WORKAROUND

To work around this issue, grant the logged-on user class-level rights to the following items in SMS 2003:
  • Collection class
  • Package class
  • Advertisement class
To do this, follow these steps:
  1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. Expand Site Database (SiteCode-SiteName), expand Collections, right-click the collection that you want to modify, and then click Properties.
  3. Click the Security tab, and then click Create (*).
  4. Type the user account that you see in the User name field. Use the domain name\user name syntax. Under Permissions, click to select the Read and Advertise check boxes, click OK, and then click OK.
  5. In the SMS Administrator Console, right-click Packages, and then click Properties.
  6. Click the Security tab, and then click Create (*).
  7. Type the user account that you see in the User name field. Use the domain name\user name syntax. Under Permissions, click to select the Distribute check box, click OK, and then click OK.
  8. In the SMS Administrator Console, right-click Advertisements, and then click Properties.
  9. Click the Security tab, and then click Create (*).
  10. Type the user account that you see in the User name field. Use the domain name\user name syntax. Under Permissions, click to select the Modify check box, click OK, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsmstopazfix kbfix kbbug KB843023
 

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