FIX: You may receive a "COMException" error message when you run the Production Manager report or the Approval Assistant report in Content Management Server 2002

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Article ID: 843027 - View products that this article applies to.
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SYMPTOMS

When you run the Production Manager report or the Approval Assistant report in Microsoft Content Management Server (MCMS) 2002, you may receive the following error message:
Exception Details: System.Runtime.InteropServices.COMException: Server error. Contact the site administrator.
Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Stack Trace: [COMException (0x80041b58): Server error. Contact the site administrator.] Microsoft.ContentManagement.Interop.Publishing.IRcwSearches.UserApprovalsPending() +0 Microsoft.ContentManagement.Publishing.Searches.UserApprovalsPending() +38 [CmsServerException: Server error. Contact the site administrator.] Microsoft.ContentManagement.Publishing.Searches.UserApprovalsPending() +70 Microsoft.ContentManagement.WebAuthor.ApprovalAssistant.BindDataGrid() +62 Microsoft.ContentManagement.WebAuthor.ApprovalAssistant.Page_Load(Object sender, EventArgs e) +518 System.Web.UI.Control.OnLoad(EventArgs e) +67 System.Web.UI.Control.LoadRecursive() +29 System.Web.UI.Page.ProcessRequestMain() +724

CAUSE

Under certain circumstances, MCMS 2002 site deployment may introduce a database inconsistency.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Content Management Server 2002. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
906142 How to obtain the latest Microsoft Content Management Server 2002 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size   File name
   ----------------------------------------------------
   02-Jun-2004  18:54  8,263  Preparenodesfordelete.sql

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Content Management Server 2002 Service Pack 2.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 843027 - Last Review: November 15, 2007 - Revision: 2.2
APPLIES TO
  • Microsoft Content Management Server 2002
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbcontentmgtserv2002sp2fix kbfix kbbug kbcontentmgtserv2002presp2fix KB843027

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