Error message when you try to use the OpenEncryptedFileRaw() function to open a file on a Windows 2000-based computer: “The network path was not found”

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Article ID: 843198 - View products that this article applies to.
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SYMPTOMS

When you try to use the OpenEncryptedFileRaw() function to open a file on a Microsoft Windows 2000-based computer, you receive an error message that resembles the following:
System error 53. The network path was not found.
This problem only occurs when you try to open the file by using the following file name format:
\\?\Volume{GUID}\file_name
Note In this example, GUID is a placeholder for the GUID of the volume and file_name is a placeholder for the file name. The actual GUID may resemble the following example:
\\?\Volume{064c97b2-825b-11d7-801c-806d6172696f}\file_name

CAUSE

This problem occurs because the OpenEncryptedFileRaw() function does not support the file name format that is described in the "Symptoms" section. Therefore, the OpenEncryptedFileRaw() function treats a file name with that format as a network file, instead of as a local file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 2000 Service Pack 3 (SP3) installed on the computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.0.2195.6876388,36824-Mar-200402:17x86
Browser.dll5.0.2195.686669,90424-Mar-200402:17x86
Dnsapi.dll5.0.2195.6824134,92824-Mar-200402:17x86
Dnsrslvr.dll5.0.2195.687692,43224-Mar-200402:17x86
Eventlog.dll5.0.2195.688347,88824-Mar-200402:17x86
Kdcsvc.dll5.0.2195.6890143,63224-Mar-200402:17x86
Kerberos.dll5.0.2195.6903210,19211-Mar-200402:37x86
Ksecdd.sys5.0.2195.682471,88821-Sep-200300:32x86
Lsasrv.dll5.0.2195.6940512,78411-Jun-200422:18x86
Lsass.exe5.0.2195.690233,55225-Feb-200423:59x86
Msv1_0.dll5.0.2195.6680117,52019-Jun-200320:05x86
Netapi32.dll5.0.2195.6897312,59224-Mar-200402:17x86
Netlogon.dll5.0.2195.6695371,98419-Jun-200320:05x86
Ntdsa.dll5.0.2195.68961,028,88024-Mar-200402:17x86
Samsrv.dll5.0.2195.6897388,36824-Mar-200402:17x86
Scecli.dll5.0.2195.6893111,37624-Mar-200402:17x86
Scesrv.dll5.0.2195.6903253,20024-Mar-200402:17x86
Sp3res.dll5.0.2195.69355,887,48804-Jun-200423:13x86
W32time.dll5.0.2195.682450,96024-Mar-200402:17x86
W32tm.exe5.0.2195.682457,10421-Sep-200300:32x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 843198 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB843198

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