Z počítače se systémem Windows XP nelze pomocí příkazu AT naplánovat vzdálenou úlohu (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 843250 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu o naplánování úlohy v počítači se systémem Microsoft Windows NT 4.0 pomocí příkazu at z počítače se systémem Microsoft Windows XP může zobrazit následující chybová zpráva:
Ověřovací služba neznámý.
Při pokusu o naplánování úlohy v počítači se systémem Windows 2000 nebo v počítači se systémem Microsoft Windows Server 2003 pomocí příkazu at z počítače se systémem Windows XP, který je v nedůvěryhodné doméně obdržet následující chybovou zprávu:
Přístup byl odepřen.

Příčina

Tento problém může nastat, pokud platí jedna z následujících podmínek:
  • V systému Windows nainstalujete aktualizaci zabezpečení MS04-011 počítač se systémem XP.

    Další informace o MS04-011 zabezpečení aktualizaci získáte v článku databáze Microsoft Knowledge Base:
    835732MS04-011: Aktualizace zabezpečení pro systém Microsoft Windows
    Aktualizace zabezpečení MS04-011 obsahuje následující změny:
    • Aktualizace zabezpečení změní vzdálené volání procedury (RPC) vazbu na klienta Netapi32.dll při volání funkce NetScheduleJobAdd.
    • Aktualizace zabezpečení zahrnuje volání funkce RpcBindingSetAuthInfoEx, který má RPC_C_AUTHN_LEVEL_PKT_PRIVACY konstanta úroveň ověřování. Toto volání odpovídá straně serveru volání funkce RpcServerRegisterAuthInfo, který má úroveň ověřování konstanta RPC_C_AUTHN_WINNT.
    Protože služba Schedule Windows NT 4.0 (atsvc.exe) nezaregistruje poskytovatele zabezpečení, nemůže přijmout Atsvc ověřené volání. Počítače se systémem Windows 2000 a počítačů se systémem Windows Server 2003, které jsou v nedůvěryhodných doménách nelze přijmout volání ověřené při ověřování pověření nelze ověřit.
  • Zkuste naplánovat úlohu na nedůvěryhodné počítače se systémem Windows 2000 nebo na nedůvěryhodné počítači s operačním systémem Windows Server 2003 z počítače se systémem Windows XP po instalaci KB831003 opravy hotfix.

    Další informace o opravě hotfix KB831003 klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
    831003Naplánované úlohy používající účet NTAUTHORITY\SYSTEM nejsou správně spouštěny (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Řešení

Informace o aktualizaci Service Pack

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Tato oprava hotfix vyžaduje aktualizaci Service Pack 1.

Požadavek na restartování

Po instalaci této opravy hotfix je třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
Windows XP, 32bitové verze
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   07-Jun-2004  17:45  5.1.2600.1539  376,832  Netapi32.dll
Windows XP, 64bitové verze
   Date         Time   Version        Size     File name      Platform
   -------------------------------------------------------------------
   07-Jun-2004  18:00  5.1.2600.1539  905,728  Netapi32.dll   IA-64
   07-Jun-2004  17:45  5.1.2600.1539  376,832  Wnetapi32.dll  x86

Jak potíže obejít

Chcete-li vyřešit problém, kde nelze naplánovat úlohu na nedůvěryhodné počítači se systémem Windows 2000 nebo na nedůvěryhodné počítači s operačním systémem Windows Server 2003 z počítače systémem Windows XP po instalaci opravy hotfix KB831003 použít jednu z následujících metod.

Metoda 1

  1. Na příkazovém řádku zadejte následující příkaz a stiskněte klávesu ENTER:
    net use \\ untrusted_server_name \ipc$ /savecred
  2. Po zobrazení výzvy, zadejte uživatelské jméno pro nedůvěryhodné domény a potom stiskněte klávesu ENTER.
  3. Po zobrazení výzvy, zadejte heslo pro nedůvěryhodné domény a stiskněte klávesu ENTER.
  4. Spuštění naplánované úlohy pomocí příkazu at.

Metoda 2

  1. Klepněte na tlačítko Start a potom klepněte na příkaz Ovládací panely.
  2. Poklepejte na panel uživatelské účty.
  3. Na kartě Upřesnit klepněte na tlačítko Spravovat hesla a potom klepněte na tlačítko Přidat.
  4. Do pole Server zadejte název serveru, který chcete spustit naplánovanou úlohu.
  5. Zadejte uživatelské jméno v poli uživatelské jméno do pole heslo zadejte heslo a klepněte na tlačítko OK.
  6. Klepněte na tlačítko Zavřít a potom klepněte na tlačítko OK.
  7. Spuštění naplánované úlohy pomocí příkazu at.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Další informace o funkci NetScheduleJobAdd naleznete na následujícím webu:
http://msdn2.microsoft.com/en-us/library/aa370614.aspx
Další informace o funkci RpcServerRegisterAuthInfo naleznete na následujícím webu:
http://msdn2.microsoft.com/en-us/library/aa378438.aspx
Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 843250 - Poslední aktualizace: 5. června 2007 - Revize: 2.8
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Klíčová slova: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kberrmsg kbwinxppresp2fix kbfix kbbug KB843250 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:843250

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com