Você não pode agendar um trabalho remoto usando o comando AT a partir de um computador baseado no Windows XP

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Sintomas

Quando você tenta agendar um trabalho em um computador com Microsoft Windows NT 4.0 usando o comando em um computador baseado no Microsoft Windows XP, você receberá a seguinte mensagem de erro:
O serviço de autenticação é desconhecido.
Quando você tenta agendar um trabalho em um computador baseado no Microsoft Windows 2000 ou em um computador com Microsoft Windows Server 2003 usando o comando at de um computador baseado no Windows XP que estiver em um domínio não confiável, você receberá a seguinte mensagem de erro:
O acesso foi negado.

Causa

Esse problema pode ocorrer se uma das seguintes condições for verdadeira:
  • Você instalar a atualização de segurança MS04-011 no seu Windows XP.

    Para obter informações adicionais sobre o MS04-011 segurança atualizar, clique no seguinte número de artigo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    835732MS04-011: Actualização de segurança para Microsoft Windows
    A atualização de segurança MS04-011 inclui as seguintes alterações:
    • A atualização de segurança altera a chamada de procedimento remoto (RPC) vincular no cliente em Netapi32.dll quando é feita uma chamada para a função NetScheduleJobAdd .
    • A atualização de segurança inclui uma chamada para a função RpcBindingSetAuthInfoEx que tenha a RPC_C_AUTHN_LEVEL_PKT_PRIVACY constante de nível de autenticação. Essa chamada coincide com a chamada do lado do servidor para a função RpcServerRegisterAuthInfo que tem a constante de nível de autenticação RPC_C_AUTHN_WINNT.
    Porque o serviço de agendamento do Windows NT 4.0 (atsvc.exe) não registra um provedor de segurança, Atsvc não pode aceitar a chamada autenticada. Computadores baseados no Windows 2000 e computadores baseados no Windows Server 2003 que estão em domínios não confiáveis não podem aceitar a chamada autenticada quando suas credenciais de autenticação não podem ser validadas.
  • Tentar agendar um trabalho em um computador baseado no Windows 2000 não confiável ou em um computador com Windows Server 2003 não confiável de um computador baseado no Windows XP depois de instalar o KB831003 hotfix.

    Para obter informações adicionais sobre o hotfix KB831003, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    831003Tarefas que usam NTAUTHORITY\SYSTEM não são executadas corretamente agendadas

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Esse hotfix requer o Windows XP Service Pack 1.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Windows XP, versões de 32 bits
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   07-Jun-2004  17:45  5.1.2600.1539  376,832  Netapi32.dll
Windows XP, versões de 64 bits
   Date         Time   Version        Size     File name      Platform
   -------------------------------------------------------------------
   07-Jun-2004  18:00  5.1.2600.1539  905,728  Netapi32.dll   IA-64
   07-Jun-2004  17:45  5.1.2600.1539  376,832  Wnetapi32.dll  x86

Como Contornar

Para contornar o problema onde você não pode agendar um trabalho em um computador baseado no Windows 2000 não confiável ou em um computador com Windows Server 2003 não confiável de um computador baseado no Windows XP após a instalação do hotfix KB831003, use um dos seguintes métodos.

Método 1

  1. Digite o seguinte comando em um prompt de comando e pressione ENTER:
    net use \\ untrusted_server_name \ipc$ /savecred
  2. Quando você for solicitado, digite seu nome de usuário para o domínio não confiável e, em seguida, pressione ENTER.
  3. Quando você for solicitado, digite sua senha para o domínio não confiável e, em seguida, pressione ENTER.
  4. Execute a tarefa agendada usando o comando at .

Método 2

  1. Clique em Iniciar e em seguida, clique em Painel de controle .
  2. Clique duas vezes em contas de usuário .
  3. Na guia Avançado , clique em Gerenciar senhas e em seguida, clique em Adicionar .
  4. Na caixa servidor , digite o nome do servidor onde você deseja executar a tarefa agendada.
  5. Digite seu nome de usuário na caixa nome de usuário , digite sua senha na caixa senha e, em seguida, clique em OK .
  6. Clique em Fechar e, em seguida, clique em OK .
  7. Execute a tarefa agendada usando o comando at .

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".Esse problema foi corrigido primeiro no Microsoft Windows XP Service Pack 2.

Mais Informações

Para obter mais informações sobre a função NetScheduleJobAdd , visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/aa370614.aspx
Para obter mais informações sobre a função RpcServerRegisterAuthInfo , visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/aa378438.aspx
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 843250 - Última revisão: terça-feira, 5 de junho de 2007 - Revisão: 2.8
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kberrmsg kbwinxppresp2fix kbfix kbbug KB843250 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 843250

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