Artigo: 843280 - Última revisão: terça-feira, 24 de Julho de 2007 - Revisão: 1.10

Não-interativo AT.exe tarefas não são executados no Windows Server 2003

Está disponível transferência de hotfixDisponível transferência de hotfix
Ver e solicitar transferências de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Depois de utilizar a ferramenta AT (AT.exe) para agendar uma tarefa, a tarefa pode não funcionar como previsto. Se visualizar a tarefa com a ferramenta tarefas agendadas, poderá ver o estado de erro seguinte na coluna estado da pasta Tarefas agendadas:
0 x 80
Nota Para iniciar a ferramenta tarefas agendadas, clique em Iniciar , aponte para Todos os programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Tarefas agendadas

Além disso, o ficheiro de registo SchedLgU.txt pode conter uma entrada semelhante à seguinte:
"At2.job" (test.cmd)
Terminar a date and time
Resultado: A tarefa foi concluída com um código de saída de (80).
Nota Para visualizar o ficheiro de registo SchedLgU.txt, siga estes passos:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Tarefas agendadas .
  2. No menu Tarefas agendadas , clique em Avançadas e, em seguida, clique em Ver registo .
Este sintoma poderá ocorrer quando se verificam as seguintes condições:
  • A tarefa está configurada para não interagir com o ambiente de trabalho. Quando utilizar a ferramenta de AT para agendar uma tarefa não interactiva, a tarefa não interactiva não utiliza o parâmetro interactivo.
  • A conta de serviço AT está configurada para iniciar sessão com uma conta de utilizador em vez de com a conta do sistema.

    Nota Para ver a conta de serviço AT, siga estes passos:
    1. Clique em Iniciar , aponte para Todos os programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Tarefas agendadas .
    2. No menu Tarefas agendadas , clique em Avançadas e, em seguida, clique em AT Service Account .
  • Ligar ao computador com uma sessão de serviços de terminal. Além disso, a sessão de serviços de terminal é registada com a mesma conta de utilizador que esteja configurada para o serviço AT.

Causa

Este problema ocorre porque as seguintes condições são verdadeiras:
  • O serviço AT tenta executar tarefas não interactivas num contexto específico.
  • O contexto específico é que a sessão de conta de utilizador.
  • A sessão de conta de utilizador está ligada ao computador que está a utilizar os serviços de terminal.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.

Windows Server 2003, 64 bits

   Date        Time   Version       Size     File name      Platform
   -----------------------------------------------------------------
   06-Jul-2004 21:18  5.2.3790.186  539,648  Schedsvc.dll   IA-64
   06-Jul-2004 21:13  5.2.3790.186  180,224  Wschedsvc.dll  x86

Windows Server 2003

   Date         Time   Version       Size     File name
   -------------------------------------------------------
   07-Jul-2004  00:13  5.2.3790.186  180,224  Schedsvc.dll

Como contornar

Para contornar este problema, não iniciar sessão sessão de serviços de terminal com a mesma conta de utilizador que esteja configurada para o serviço Programador de tarefas.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter informações adicionais sobre a terminologia padrão utilizada para descrever actualizações de software da Microsoft, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB843280 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 843280  (http://support.microsoft.com/kb/843280/en-us/ )