ID do artigo: 843280 - Última revisão: terça-feira, 24 de julho de 2007 - Revisão: 1.10

Não-interativo at.exe tarefas não são executados no Windows Server 2003

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Após usar a ferramenta AT (AT.exe) para agendar uma tarefa, a tarefa pode não ser executada conforme o esperado. Se você exibir a tarefa com a ferramenta tarefas agendadas, você verá o seguinte status de erro na coluna status da pasta Tarefas agendadas:
0 x 80
Observação Para iniciar a ferramenta tarefas agendadas, clique em Iniciar , aponte para Todos os programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Tarefas agendadas

Além disso, o arquivo de log SchedLgU.txt pode conter uma entrada que é semelhante a seguinte entrada:
"At2.job" (test.cmd)
Terminar de date and time
Resultado: Tarefa foi concluída com um código de saída de (80).
Observação Para exibir o arquivo de log SchedLgU.txt, execute essas etapas:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Tarefas agendadas .
  2. No menu Tarefas agendadas , clique em Avançado e, em seguida, clique em Exibir Log .
Esse sintoma pode ocorrer quando todas as seguintes condições forem verdadeiras:
  • A tarefa é configurada para não interagir com a área de trabalho. Quando você usa a ferramenta AT para agendar uma tarefa não-interativa, a tarefa não-interativa não usa o parâmetro interativo.
  • A conta de serviço AT está configurada para fazer logon com uma conta de usuário em vez de com a conta do sistema.

    Observação Para exibir a conta do serviço AT, execute estas etapas:
    1. Clique em Iniciar , aponte para Todos os programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Tarefas agendadas .
    2. No menu Tarefas agendadas , clique em Avançado e clique em Conta do serviço AT .
  • Você se conectar ao computador com uma sessão de serviços de terminal. Além disso, a sessão de serviços de terminal está conectada como a mesma conta de usuário que está configurada para o serviço AT.

Causa

Esse problema ocorre porque as seguintes condições são verdadeiras:
  • O serviço AT tenta executar tarefas não-interativos em um contexto específico.
  • O contexto específico é que a sessão de conta de usuário.
  • A sessão de conta de usuário está conectada ao computador que está usando os serviços de terminal.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.

Windows Server 2003, 64-bit

   Date        Time   Version       Size     File name      Platform
   -----------------------------------------------------------------
   06-Jul-2004 21:18  5.2.3790.186  539,648  Schedsvc.dll   IA-64
   06-Jul-2004 21:13  5.2.3790.186  180,224  Wschedsvc.dll  x86

Windows Server 2003

   Date         Time   Version       Size     File name
   -------------------------------------------------------
   07-Jul-2004  00:13  5.2.3790.186  180,224  Schedsvc.dll

Como Contornar

Para contornar esse problema, não faça logon uma sessão de serviços de terminal com a mesma conta de usuário que esteja configurada para o serviço Agendador de tarefas.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter informações adicionais sobre a terminologia padrão que é usada para descrever as atualizações de software da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB843280 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 843280  (http://support.microsoft.com/kb/843280/en-us/ )