Article ID: 843447 - Last Review: July 24, 2007 - Revision: 1.10

A 32-bit program that uses the Virtual Disk service API may not work correctly on a computer that is running Windows Server 2003, Enterprise Edition for Itanium-based Systems

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SYMPTOMS

When you run a 32-bit program that uses the Virtual Disk service (VDS) API on your computer that is running Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems, the program may not work correctly. For example, when you try to run the 32-bit version of the Diskpart.exe tool, Diskpart.exe stops responding. You receive the following error message:
The disk management services could not complete the operation.

CAUSE

This problem occurs because the 32-bit VDS dynamic link library (DLL) component is not installed or registered on the 64-bit versions of Windows Server 2003.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version        Size    File name      Platform
   -------------------------------------------------------------------
   24-Nov-2004  01:30   5.2.3790.212   31,744  Vds_ps.dll     IA-64
   24-Nov-2004  01:25   5.2.3790.212   22,016  Wvds_ps.dll    x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB843447