Περιγραφή άγνωστων συμβουλών για το Excel

Μεταφράσεις άρθρων Μεταφράσεις άρθρων
Αναγν. άρθρου: 843504 - Δείτε τα προϊόντα στα οποία αναφέρεται το συγκεκριμένο άρθρο.
Ανάπτυξη όλων | Σύμπτυξη όλων

Σε αυτήν τη σελίδα

Περίληψη

Αυτό το άρθρο περιγράφει ορισμένες από τις πιο ισχυρές και χρήσιμες δυνατότητες και λειτουργίες του Microsoft Excel οι οποίες παραμένουν άγνωστες στους χρήστες. Για παράδειγμα, μπορεί να δημιουργείτε μια νέα μακροεντολή για να πραγματοποιήσετε έναν υπολογισμό, ενώ υπάρχει ένας έτοιμος τύπος ή συνάρτηση που έχει τη δυνατότητα να εκτελέσει αυτήν την εργασία. Ή μπορεί να δημιουργήσετε μια νέα μακροεντολή για την εκτέλεση μιας εργασίας, ενώ μπορείτε να χρησιμοποιήσετε μια υπάρχουσα δυνατότητα που εκτελεί αυτήν την εργασία.

ΕΙΣΑΓΩΓΗ

Αυτό το άρθρο παραθέτει ορισμένες συμβουλές για τη χρήση του Microsoft Excel.

Περισσότερες πληροφορίες

Σύνδεση κειμένου σε πολλές στήλες

Μπορείτε να συνδέσετε ή να παραθέσετε μια αλληλουχία κειμένου που βρίσκεται σε πολλές στήλες χρησιμοποιώντας τον τελεστή & ή τη συνάρτηση CONCATENATE -- για παράδειγμα, εάν πληκτρολογήσετε τα ακόλουθα δεδομένα στα κελιά A1:C2:

Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
A1: ΌνομαB1: ΠατρώνυμοC1: Επίθετο
A2: ΠέτροςΒ2: ΝικολάουC2: Φυτράκης

Για να βάλετε το πλήρες όνομα στο κελί D2, πληκτρολογήστε έναν από τους ακόλουθους τύπους:
$D$2: =CONCATENATE(A2," ",B2," ",C2)
$D$2: =A1&" "&B2&" "&C2
Σημείωση Το διάστημα (" ") μεταξύ των κελιών χρησιμοποιείται για την εισαγωγή διαστήματος μεταξύ του κειμένου που θα εμφανίζεται.

Ορισμός της περιοχής εκτύπωσης

Από την έκδοση του Microsoft Excel 97 για Windows είναι διαθέσιμο το κουμπί γραμμής εργαλείων Ορισμός περιοχής εκτύπωσης (Set Print Area) στο μενού Αρχείο (File). Κάνοντας κλικ στο κουμπί γραμμής εργαλείων Ορισμός περιοχής εκτύπωσης (Set Print Area), μπορείτε να ορίσετε την τρέχουσα επιλογή ως περιοχή εκτύπωσης. Αφού προσθέσετε το κουμπί γραμμής εργαλείων Ορισμός περιοχής εκτύπωσης (Set Print Area) σε μια υπάρχουσα γραμμή εργαλείων, μπορείτε να κάνετε κλικ στο κουμπί Ορισμός περιοχής εκτύπωσης (Set Print Area) για να ορίσετε εύκολα μια περιοχή εκτύπωσης η οποία θα αντιστοιχεί στην τρέχουσα επιλεγμένη περιοχή.

Για να προσθέσετε το κουμπί γραμμής εργαλείων Ορισμός περιοχής εκτύπωσης (Set Print Area) στο Excel, ακολουθήστε τα εξής βήματα:
  1. Στο μενού Προβολή (View), τοποθετήστε το δείκτη του ποντικιού στην εντολή Γραμμές εργαλείων (Toolbars) και κατόπιν κάντε κλικ στην εντολή Προσαρμογή (Customize).
  2. Κάντε κλικ στην καρτέλα Εντολές (Commands).
  3. Στο πλαίσιο Κατηγορίες (Categories), κάντε κλικ στην επιλογή Αρχείο (File) και, στη συνέχεια, μετακινηθείτε προς τα κάτω στη λίστα εντολών μέχρι να εμφανιστεί το κουμπί γραμμής εργαλείων Ορισμός περιοχής εκτύπωσης (Set Print Area).
  4. Κάντε κλικ στην εντολή Ορισμός περιοχής εκτύπωσης (Set Print Area) και, στη συνέχεια, σύρετέ τη σε μια υπάρχουσα γραμμή εργαλείων.

Εξαίρεση διπλότυπων στοιχείων σε μια λίστα

Εάν δημιουργήσατε μια λίστα στοιχείων η οποία περιέχει διπλότυπα στοιχεία και θέλετε να λάβετε μια λίστα με μοναδικά στοιχεία, χρησιμοποιήστε την εντολή Σύνθετο φίλτρο (Advanced Filter) στο Excel.

Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Πληκτρολογήστε τα ακόλουθα δεδομένα στα κελιά A1:A10 σε ένα νέο βιβλίο εργασίας:

    Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
    A1: Φρούτα
    A2: Μήλο
    Α3: Κεράσι
    A4: Αχλάδι
    A5: Κεράσι
    A6: Δαμάσκηνο
    A7: Μήλο
    A8: Μήλο
    A9: Αχλάδι
    A10: Μήλο
  2. Στο μενού Δεδομένα (Data), τοποθετήστε το δείκτη του ποντικιού στην εντολή Φίλτρο (Filter) και κατόπιν κάντε κλικ στην εντολή Σύνθετο φίλτρο (Advanced Filter).
  3. Στην περιοχή Ενέργεια (Action), κάντε κλικ στην επιλογή Αντιγραφή σε (Copy to).
  4. Στο πλαίσιο Περιοχή λίστας (List Range), πληκτρολογήστε $A$1:$A$10.
  5. Κάντε κλικ στο πλαίσιο ελέγχου Μοναδικές εγγραφές μόνο (Unique records only), πληκτρολογήστε $B$1 στο πλαίσιο Αντιγραφή σε (Copy to) και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    Στη στήλη B εμφανίζεται η ακόλουθη λίστα μοναδικών στοιχείων:

    Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
    B1: Φρούτα
    Β2: Μήλο
    Β3: Κεράσι
    B4: Αχλάδι
    B5: Δαμάσκηνο
Σημειώστε ότι αυτή η μέθοδος λειτουργεί και σε πολλές στήλες. Μπορείτε να κάνετε απόκρυψη γραμμών όταν χρησιμοποιείτε την εντολή Σύνθετο φίλτρο (Advanced Filter).

Πολλαπλασιασμός τιμών κειμένου με τον αριθμό 1 για μετατροπή κειμένου σε αριθμούς

Μερικές φορές, κατά την εισαγωγή αρχείων από άλλες προελεύσεις, οι αριθμητικές τιμές ενδέχεται να εμφανίζονται ως αριθμοί αλλά να συμπεριφέρονται ως τιμές κειμένου. Για να επιλύσετε αυτό το πρόβλημα, μετατρέψτε αυτές τις τιμές σε αριθμούς. Μία μέθοδος για να το κάνετε αυτό είναι να πολλαπλασιάσετε αυτές τις τιμές κειμένου με τον αριθμό 1.

Για να μετατρέψετε τις τιμές κειμένου, ακολουθήστε τα εξής βήματα:
  1. Κάντε κλικ σε ένα κενό κελί του φύλλου εργασίας, βεβαιωθείτε ότι το κελί δεν έχει μορφοποιηθεί ως κείμενο και, στη συνέχεια, πληκτρολογήστε τον αριθμό 1 στο κελί.
  2. Με επιλεγμένο το κενό κελί, κάντε κλικ στην εντολή Αντιγραφή (Copy) του μενού Επεξεργασία (Edit).
  3. Επιλέξτε την περιοχή που περιέχει τις τιμές που θέλετε να μετατρέψετε σε αριθμούς.
  4. Στο μενού Επεξεργασία (Edit), κάντε κλικ στην εντολή Ειδική επικόλληση (Paste Special).
  5. Στην ενότητα Πράξη (Operation), κάντε κλικ στην επιλογή Πολλαπλασιασμός (Multiply) και κατόπιν κάντε κλικ στο κουμπί OK.
Αυτή η μέθοδος μετατρέπει το κείμενο σε αριθμούς. Μπορείτε να διαπιστώσετε εάν έγινε επιτυχής μετατροπή των τιμών κειμένου, προβάλλοντας τη στοίχιση του αριθμού. Εάν χρησιμοποιείτε τη μορφή "Γενική" (General) και οι τιμές έχουν στοίχιση δεξιά, οι τιμές αυτές είναι αριθμοί. Οι τιμές κειμένου έχουν στοίχιση αριστερά.

Χρήση του "Οδηγού εισαγωγής κειμένου" (Text Import Wizard) για μετατροπή κειμένου σε αριθμούς

Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Επιλέξτε την περιοχή που περιέχει τις τιμές που θέλετε να μετατρέψετε σε αριθμούς.
  2. Στο μενού Δεδομένα (Data), κάντε κλικ στην εντολή Κείμενο σε στήλες (Text to Columns).
  3. Κάντε κλικ στο κουμπί Επόμενο (Next) στα δύο διαδοχικά παράθυρα για να μεταβείτε στο βήμα 3 του οδηγού.
  4. Στο πλαίσιο ομάδας Μορφοποίηση στήλης δεδομένων (Column Data Format), κάντε κλικ στο πλαίσιο ελέγχου Γενική (General) και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος (Finish).
Αυτή η μέθοδος μετατρέπει το κείμενο σε αριθμούς. Μπορείτε να διαπιστώσετε εάν έγινε επιτυχής μετατροπή των τιμών κειμένου, προβάλλοντας τη στοίχιση του αριθμού. Εάν χρησιμοποιείτε τη μορφή "Γενική" (General) και οι τιμές έχουν στοίχιση δεξιά, οι τιμές αυτές είναι αριθμοί. Οι τιμές κειμένου έχουν στοίχιση αριστερά.

Ταξινόμηση δεκαδικών αριθμών σε μια διάρθρωση

Ας υποθέσουμε ότι δημιουργείτε τους ακόλουθους αριθμούς διάρθρωσης στα κελιά A1:A6:

Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
A1: 1.1.0
A2: 1.10.0
Α3: 1.2.0
A4: 1.20.0
A5: 1.21.1
A6: 1.3.0

Αφού ταξινομήσετε τους αριθμούς διάρθρωσης, εμφανίζονται στην ίδια σειρά. Οι αριθμοί διάρθρωσης εμφανίζονται στη σειρά που τους πληκτρολογήσατε. Ωστόσο, εάν θέλετε να ταξινομήσετε τους αριθμούς που βρίσκονται ανάμεσα στις τελείες, χρησιμοποιήστε τον "Οδηγό εισαγωγής κειμένου" (Text Import Wizard). Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Επιλέξτε τα κελιά A1:A6.
  2. Στο μενού Δεδομένα (Data), κάντε κλικ στην εντολή Κείμενο σε στήλες (Text to Columns).
  3. Στο βήμα 1 του "Οδηγού εισαγωγής κειμένου" (Text Import Wizard), κάντε κλικ στην επιλογή Οριοθετημένο (Delimited) και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο (Next).
  4. Στο πλαίσιο ομάδας Οριοθέτες (Delimiters), κάντε κλικ για να καταργήσετε την επιλογή όλων των πλαισίων ελέγχου εκτός από το πλαίσιο ελέγχου Άλλο (Other). Στο πλαίσιο ελέγχου Άλλο (Other), πληκτρολογήστε μια τελεία και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο (Next).
  5. Στο βήμα 2, πληκτρολογήστε $B$1 στο πλαίσιο Προορισμός (Destination), έτσι ώστε να μην αντικατασταθεί η αρχική διάρθρωση και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος (Finish).

    Οι αριθμοί εμφανίζονται στις στήλες B, C και D.
  6. Επιλέξτε τα κελιά A1:D6.
  7. Στο μενού Δεδομένα (Data), κάντε κλικ στην εντολή Ταξινόμηση (Sort).
  8. Στη λίστα Ταξινόμηση κατά (Sort by), κάντε κλικ στη στήλη B.
  9. Στο πλαίσιο Έπειτα κατά (Then by), κάντε κλικ στη στήλη C.
  10. Στη λίστα Έπειτα κατά (Then by), κάντε κλικ στη στήλη D και στη συνέχεια κάντε κλικ στο κουμπί OK.
Η ταξινομημένη λίστα εμφανίζεται στη στήλη A.

Χρήση φόρμας δεδομένων για προσθήκη εγγραφών σε μια λίστα

Όταν προσθέτετε εγγραφές σε μια λίστα, χρησιμοποιήστε μια προκαθορισμένη φόρμα δεδομένων. Για να ξεκινήσετε, κάντε κλικ σε ένα κελί της λίστας και, στη συνέχεια, κάντε κλικ στην εντολή Φόρμα (Form) του μενού Δεδομένα (Data).
Σύμπτυξη αυτής της εικόναςΑνάπτυξη αυτής της εικόνας
Public/EN-US/Office/Excel/843504A.gif

Εισαγωγή της τρέχουσας ημερομηνίας ή ώρας

Εάν θέλετε να εισαγάγετε γρήγορα την τρέχουσα ημερομηνία σε ένα κελί, πιέστε τα πλήκτρα CTRL+; και, στη συνέχεια, πιέστε το πλήκτρο ENTER. Για γρήγορη εισαγωγή της τρέχουσας ώρας σε ένα κελί, πιέστε CTRL+: και κατόπιν πατήστε το πλήκτρο ENTER.

Προβολή των ορισμάτων ενός τύπου

Κατά την εισαγωγή ενός τύπου σε ένα κελί, πιέστε τα πλήκτρα CTRL+SHIFT+A για να εμφανίσετε τα ορίσματα σε έναν τύπο. Εάν πληκτρολογήσετε =RATE και, στη συνέχεια, πιέσετε τα πλήκτρα CTRL+SHIFT+A, μπορείτε να δείτε όλα τα ορίσματα για αυτήν τη συνάρτηση -- για παράδειγμα, =RATE(nper,pmt,pv,fv,type,guess). Εάν θέλετε περισσότερες λεπτομέρειες, πληκτρολογήστε =RATE και, στη συνέχεια, πιέστε τα πλήκτρα CTRL+A για να εμφανίσετε τον "Οδηγό συναρτήσεων" (Function Wizard).

Εισαγωγή του ίδιου κειμένου ή τύπου σε μια περιοχή κελιών

Εάν θέλετε να καταχωρήσετε γρήγορα το ίδιο κείμενο ή τον ίδιο τύπο σε μια περιοχή κελιών, ακολουθήστε τα εξής βήματα:
  1. Επιλέξτε την περιοχή κελιών που θέλετε να συμπληρώσετε.
  2. Πληκτρολογήστε το κείμενο ή τον τύπο χωρίς να πιέσετε το πλήκτρο ENTER. Αντί για αυτό, πιέστε το συνδυασμό πλήκτρων CTRL+ENTER.
Τα δεδομένα εμφανίζονται στην περιοχή που επιλέξατε.

Σύνδεση ενός πλαισίου κειμένου με δεδομένα σε ένα κελί

Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Στη γραμμή εργαλείων Σχεδίαση (Drawing), κάντε κλικ στο στοιχείο Πλαίσιο κειμένου (Text Box), κάντε κλικ στο φύλλο εργασίας και, στη συνέχεια, σύρετε το δείκτη του ποντικιού για να δημιουργήσετε το πλαίσιο κειμένου.
  2. Για να κάνετε αλλαγές στη γραμμή τύπων, κάντε κλικ σε αυτήν ή πιέστε το πλήκτρο F2.
  3. Πληκτρολογήστε τον τύπο σύνδεσης -- για παράδειγμα, πληκτρολογήστε =A1 και, στη συνέχεια, πιέστε το πλήκτρο ENTER.
Το κείμενο που καταχωρείτε στο συνδεδεμένο κελί εμφανίζεται στο πλαίσιο κειμένου -- για παράδειγμα, A1. Μπορείτε να μετακινήσετε το πλαίσιο κειμένου σε οποιοδήποτε φύλλο εργασίας του βιβλίου εργασίας.

Σύνδεση μιας εικόνας με μια περιοχή κελιών

Μπορείτε να αντιγράψετε μια περιοχή κελιών και να επικολλήσετε την εικόνα που προκύπτει σε ένα φύλλο εργασίας. Με αυτήν την ενέργεια, μπορείτε εύκολα να δείτε τα περιεχόμενα των κελιών σε οποιοδήποτε σημείο του φύλλου εργασίας. Μπορείτε να χρησιμοποιήσετε αυτήν τη μέθοδο για να κάνετε εκτύπωση μη γειτονικών κελιών σε μια σελίδα. Η εικόνα συνδέεται και ενημερώνεται με τις αλλαγές τόσο στο περιεχόμενο όσο και στη μορφοποίηση. Για να δημιουργήσετε μια συνδεδεμένη εικόνα, ακολουθήστε τα εξής βήματα:
  1. Επιλέξτε την περιοχή κελιών.
  2. Από το μενού Επεξεργασία (Edit), κάντε κλικ στην εντολή Αντιγραφή (Copy).
  3. Επιλέξτε το κελί όπου θέλετε να εμφανίζεται η εικόνα.
  4. Στο μενού Επεξεργασία (Edit), κάντε κλικ στην εντολή Επικόλληση σύνδεσης εικόνας (Paste Picture Link) ενώ κρατάτε πατημένο το πλήκτρο SHIFT.
Το αποτέλεσμα είναι ένα στιγμιότυπο το οποίο ενημερώνεται κάθε φορά που γίνεται αλλαγή ή μορφοποίηση των κελιών προέλευσης.

Αντιμετώπιση προβλημάτων σε ένα μεγάλο τύπο

Εάν δημιουργήσετε ένα μεγάλο τύπο φύλλου εργασίας, ο οποίος δεν αποδίδει το αναμενόμενο αποτέλεσμα, σύρετε το δείκτη για να επιλέξετε ένα μέρος του τύπου στη γραμμή τύπων και, στη συνέχεια, πιέστε το πλήκτρο F9. Εάν το κάνετε αυτό, θα υπολογιστεί μόνο το επιλεγμένο κομμάτι του τύπου.

Σημαντικό Εάν πιέσετε το πλήκτρο ENTER, το κομμάτι του τύπου θα χαθεί. Επομένως, βεβαιωθείτε ότι πιέζετε το πλήκτρο ESC. Ωστόσο, αν πιέσετε κατά λάθος το πλήκτρο ENTER, πιέστε το συνδυασμό πλήκτρων CTRL+Z για να αναιρέσετε την αλλαγή.

Προβολή χάρτη γραφικών ενός καθορισμένου ονόματος

Σημείωση Αυτή η ενότητα ισχύει μόνο για την έκδοση Excel 97 για Windows.

Όταν ρυθμίζετε το πλαίσιο Ζουμ (Zoom) ενός φύλλου εργασίας σε μια τιμή ίση ή μικρότερη του 39 τοις εκατό, θα εμφανιστεί στην οθόνη ένα ορθογώνιο το οποίο περιέχει ένα καθορισμένο όνομα που αποτελείται από μια περιοχή δύο ή περισσότερων γειτονικών κελιών. Όταν κάνετε κλικ στο κουμπί Ζουμ (Zoom) της Βασικής (Standard) γραμμής εργαλείων και πληκτρολογήσετε μια τιμή ίση ή μεγαλύτερη του 40 τοις εκατό, τα ορθογώνια που υποδηλώνουν συγκεκριμένες περιοχές εξαφανίζονται αυτόματα. Σημειώστε ότι αυτή η δυνατότητα δεν είναι διαθέσιμη σε παλαιότερες εκδόσεις του Microsoft Excel.

Συμπλήρωση κενών κελιών μιας στήλης με περιεχόμενα από προηγούμενο κελί

Ας υποθέσουμε ότι πληκτρολογείτε τα ακόλουθα ονόματα στη στήλη A:
Σύμπτυξη αυτής της εικόναςΑνάπτυξη αυτής της εικόνας
Public/EN-US/Office/Excel/843504B.gif
Για να ταξινομήσετε σωστά τα ονόματα, συμπληρώστε τα ονόματα στα κενά κελιά. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
  1. Επιλέξτε τα κελιά A1:A10.
  2. Στο μενού Επεξεργασία (Edit), κάντε κλικ στην εντολή Μετάβαση (Go To).
  3. Κάντε κλικ στο κουμπί Ειδικά σε (Special), κάντε κλικ στο στοιχείο Κενά (Blanks)και κατόπιν κάντε κλικ στο κουμπί OK.
  4. Πληκτρολογήστε =a1 και, στη συνέχεια, πιέστε τα πλήκτρα CTRL+ENTER.

    Αυτό το βήμα εισαγάγει τα ονόματα στα κενά κελιά που έχετε επιλέξει.
  5. Επιλέξτε τα κελιά A1:A10.
  6. Από το μενού Επεξεργασία (Edit), κάντε κλικ στην εντολή Αντιγραφή (Copy).
  7. Στο μενού Επεξεργασία (Edit), κάντε κλικ στην εντολή Ειδική επικόλληση (Paste Special).
  8. Στην ομάδα Επικόλληση (Paste), κάντε κλικ στο πλαίσιο ελέγχου Τιμές (Values) και κατόπιν κάντε κλικ στο κουμπί OK.
Τα κελιά θα συμπληρωθούν με τα ονόματα.

Εναλλαγή σχετικής αναφοράς σε απόλυτη αναφορά

Μπορείτε να πιέσετε το πλήκτρο F4 για να κάνετε εναλλαγή μεταξύ της σχετικής και της απόλυτης διεύθυνσης ενός κελιού για έναν τύπο. Όταν πληκτρολογείτε έναν τύπο στη γραμμή τύπων, χρησιμοποιήστε μια αναφορά κελιού σε μορφή σχετικής διεύθυνσης -- για παράδειγμα, χρησιμοποιήστε το A1. Αφού πληκτρολογήσετε την αναφορά, πιέστε το πλήκτρο F4 και η αναφορά κελιού θα μετατραπεί αυτόματα σε απόλυτη αναφορά κελιού -- για παράδειγμα, $A$1. Μπορείτε επίσης να συνεχίσετε να πιέζετε το πλήκτρο F4 για να εμφανίσετε μικτές φόρμες με σχετικές και απόλυτες αναφορές.

Για περισσότερες πληροφορίες σχετικά με τις αναφορές σε κελιά, κάντε κλικ στην καρτέλα Αναζήτηση (Find) της Βοήθειας του Microsoft Excel (Microsoft Excel Help), πληκτρολογήστε απόλυτη και σχετική και, στη συνέχεια, κάντε διπλό κλικ στο θέμα Διαφορά μεταξύ σχετικών και απόλυτων αναφορών.

Χρήση της συνάρτησης OFFSET για τροποποίηση δεδομένων σε εισαγόμενα κελιά

Ας υποθέσουμε ότι χρησιμοποιείτε τα ακόλουθα δεδομένα στα κελιά A1:A7 και θέλετε να κάνετε αφαίρεση της πρώτης γραμμής από την τελευταία γραμμή της περιοχής:

Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
A1: 1
A2: 2
Α3: 3
A4: 4
A5: 5
A6:
A7: =A5-A1

Ας υποθέσουμε ότι θέλετε να χρησιμοποιήσετε έναν τύπο ο οποίος να βρίσκεται πάντοτε δύο γραμμές κάτω από το τελευταίο κελί, αφήνοντας ένα κενό κελί μεταξύ του τύπου και του τελευταίου κελιού που περιέχει δεδομένα. Ας υποθέσουμε ότι, εάν εισαγάγετε μια νέα γραμμή στο κενό κελί (γραμμή 6 στο ακόλουθο παράδειγμα), θέλετε ο τύπος να αφαιρεί τα δεδομένα του κελιού A1 από τα δεδομένα του κελιού A6 αντί από τα δεδομένα που βρίσκονται στο κελί A5.

Σημειώστε ότι σε αυτό το παράδειγμα, ο τύπος =A5-A1 δεν αφαιρεί από τα δεδομένα της γραμμής A6, όταν εισαγάγετε μια γραμμή με δεδομένα στο κελί A6.

Για να το κάνετε αυτό, χρησιμοποιήστε τη συνάρτηση OFFSET. Η συνάρτηση OFFSET επιστρέφει μια αναφορά σε μια περιοχή που αποτελείται από καθορισμένο αριθμό γραμμών και στηλών από ένα κελί ή μια περιοχή κελιών. Σε αυτό το παράδειγμα, χρησιμοποιήστε τον ακόλουθο τύπο:
=OFFSET(A6,-1,0)-A1
Ο τύπος OFFSET δεν είναι σταθεροποιημένος στη γραμμή που βρίσκεται επάνω από το κελί A6 και αλλάζει κατά την εισαγωγή νέων γραμμών.

Χρήση της εντολής "Σύνθετο φίλτρο" (Advanced Filter)

Εάν δημιουργήσετε μια λίστα δεδομένων στο Excel και θέλετε να επιλέξετε συγκεκριμένα στοιχεία και να τα αντιγράψετε σε άλλο φύλλο, χρησιμοποιήστε την εντολή Σύνθετο φίλτρο (Advanced Filter) του Excel. Για να χρησιμοποιήσετε αυτήν την εντολή, τοποθετήστε το δείκτη του ποντικιού στην εντολή Φίλτρο (Filter) του μενού Δεδομένα (Data), κάντε κλικ στην εντολή Σύνθετο φίλτρο (Advanced Filter) και, στη συνέχεια, ακολουθήστε τις οδηγίες που εμφανίζονται στην οθόνη. Εάν δεν είστε βέβαιοι ποιες πληροφορίες σας ζητά το Excel, ανατρέξτε στη Βοήθεια του Microsoft Excel (Microsoft Excel Help).

Χρήση αθροισμάτων υπό όρους για την άθροιση δεδομένων

Aς υποθέσουμε ότι δημιουργείτε μια λίστα δεδομένων στα κελιά A1:A10 και θέλετε να αθροίσετε όλες τις τιμές που είναι μεγαλύτερες από 50 και μικρότερες από 200. Για να το κάνετε αυτό, χρησιμοποιήστε τον ακόλουθο τύπο πίνακα:
=SUM(IF(A1:A10>=50,IF(A1:A10<=200,A1:A10,0),0))
Σημείωση Βεβαιωθείτε ότι έχετε καταχωρήσει τον τύπο ως πίνακα πιέζοντας τα πλήκτρα CTRL+SHIFT+ENTER. Μόλις το κάνετε αυτό, θα εμφανιστούν αγκύλες {} γύρω από τον τύπο. Μην προσπαθήσετε να εισαγάγετε τις αγκύλες με μη αυτόματο τρόπο.

Ο τύπος χρησιμοποιεί ένθετες συναρτήσεις IF για κάθε κελί της περιοχής και προσθέτει τα δεδομένα ενός κελιού μόνο όταν ικανοποιούνται και τα δύο κριτήρια.

Χρήση αθροισμάτων υπό όρους για την καταμέτρηση δεδομένων

Aς υποθέσουμε ότι δημιουργείτε μια λίστα δεδομένων στα κελιά A1:A10 και θέλετε να καταμετρήσετε όλες τις τιμές που είναι μεγαλύτερες από 50 και μικρότερες από 200. Για να το κάνετε αυτό, χρησιμοποιήστε τον ακόλουθο τύπο πίνακα:
=SUM(IF(A1:A10>=50,IF(A1:A10<=200,1,0),0))
Σημείωση Βεβαιωθείτε ότι έχετε καταχωρήσει τον τύπο ως πίνακα πιέζοντας τα πλήκτρα CTRL+SHIFT+ENTER. Μόλις το κάνετε αυτό, θα εμφανιστούν αγκύλες {} γύρω από τον τύπο. Μην προσπαθήσετε να εισαγάγετε τις αγκύλες με μη αυτόματο τρόπο.

Ο τύπος χρησιμοποιεί ένθετες συναρτήσεις IF για κάθε κελί της περιοχής και προσθέτει μία μονάδα στο σύνολο μόνο όταν ικανοποιούνται και τα δύο κριτήρια.

Χρήση των συναρτήσεων INDEX και MATCH για την αναζήτηση δεδομένων

Aς υποθέσουμε ότι δημιουργείτε τον ακόλουθο πίνακα με πληροφορίες στα κελιά A1:C5 και ότι αυτός ο πίνακας περιέχει πληροφορίες ηλικίας στα κελιά C1:C5:
Σύμπτυξη αυτής της εικόναςΑνάπτυξη αυτής της εικόνας
Public/EN-US/Office/Excel/843504C.gif
Aς υποθέσουμε ότι θέλετε να αναζητήσετε την ηλικία ενός ατόμου χρησιμοποιώντας το όνομά του. Για να το κάνετε αυτό, χρησιμοποιήστε ένα συνδυασμό των συναρτήσεων INDEX και MATCH, όπως στο ακόλουθο δείγμα τύπου:
=INDEX($A$1:$C$5, MATCH("Μαρία",$A$1:$A$5,),3)
Αυτό το δείγμα τύπου χρησιμοποιεί τα κελιά A1:C5 ως πίνακα και αναζητά την ηλικία της Μαρίας στην τρίτη στήλη. Ο τύπος επιστρέφει το αποτέλεσμα 22.

Μετακίνηση της λαβής συμπλήρωσης για τη δημιουργία μιας σειράς αριθμών

Αν σύρετε τη λαβή συμπλήρωσης ενός κελιού, μπορείτε να αντιγράψετε τα περιεχόμενα αυτού του κελιού σε άλλα κελιά της ίδιας γραμμής ή στήλης. Εάν το κελί περιέχει έναν αριθμό, μια ημερομηνία ή μια χρονική περίοδο η οποία μπορεί να προβληθεί από το Excel σε μια σειρά, οι τιμές προσαυξάνονται αντί να αντιγράφονται. Για παράδειγμα, εάν το κελί περιέχει το στοιχείο "Ιανουάριος", μπορείτε να συμπληρώσετε γρήγορα τα υπόλοιπα κελιά μιας γραμμής ή στήλης με τα στοιχεία "Φεβρουάριος", "Μάρτιος" και ούτω καθεξής. Μπορείτε επίσης να δημιουργήσετε μια προσαρμοσμένη σειρά συμπλήρωσης για καταχωρήσεις κειμένου που χρησιμοποιείτε συχνά, όπως οι περιοχές πωλήσεων της εταιρείας σας.

Aυτόματη συμπλήρωση δεδομένων

Μπορείτε να κάνετε διπλό κλικ στη λαβή συμπλήρωσης ενός επιλεγμένου κελιού για να συμπληρώσετε με τα περιεχόμενα του κελιού μια στήλη με αριθμό γραμμών ίσο με της διπλανής στήλης. Για παράδειγμα, αν πληκτρολογήσετε δεδομένα στα κελιά A1:A20, πληκτρολογήσετε έναν τύπο ή κείμενο στο κελί B1, πιέσετε το πλήκτρο ENTER και, στη συνέχεια, κάνετε διπλό κλικ στη λαβή συμπλήρωσης, το Excel συμπληρώνει τα δεδομένα στη στήλη από το κελί B1 έως το κελί B20.

Χρήση της συνάρτησης VLOOKUP με μη ταξινομημένα δεδομένα

Στο Excel 97 για Windows και σε νεώτερες εκδόσεις, η συνάρτηση VLOOKUP λειτουργεί όταν τη χρησιμοποιείτε με δεδομένα που δεν έχουν ταξινομηθεί. Ωστόσο, πρέπει να προσθέσετε ένα πρόσθετο όρισμα στον τύπο. Το όρισμα Range_Lookup θεωρείται TRUE αν δεν καθορίσετε μια τιμή. Σημειώστε ότι το όρισμα Range_Lookup είναι το τέταρτο όρισμα. Αυτή η συμπεριφορά κάνει τη συνάρτηση συμβατή με προηγούμενες εκδόσεις του Excel.

Για να λειτουργήσει σωστά η συνάρτηση VLOOKUP με δεδομένα που δεν έχουν ταξινομηθεί, αλλάξτε το όρισμα Range_Lookup σε FALSE. Ακολουθεί ένα δείγμα συνάρτησης το οποίο αναζητά την ηλικία του Παύλου στον πίνακα δεδομένων που δημιουργήσατε προηγουμένως στην ενότητα "Χρήση των συναρτήσεων INDEX και MATCH για την αναζήτηση δεδομένων":
=VLOOKUP("Παύλος",$A$2:$C$5,3,FALSE)

Επιστροφή κάθε τρίτου αριθμού

Aς υποθέσουμε ότι δημιουργείτε τον ακόλουθο πίνακα δεδομένων στα κελιά A1:A12 και θέλετε να πάρετε έναν αριθμό ανά τρεις αριθμούς της στήλης και να τον τοποθετήσετε σε μια γειτονική στήλη:
Σύμπτυξη αυτής της εικόναςΑνάπτυξη αυτής της εικόνας
Public/EN-US/Office/Excel/843504D.gif
Για να το κάνετε αυτό, χρησιμοποιήστε τη συνάρτηση ROW μαζί με τη συνάρτηση OFFSET -- για παράδειγμα, χρησιμοποιήστε το ακόλουθο δείγμα τύπου:
=OFFSET($A$1,ROW()*3-1,0)
Αυτός ο τύπος εξαρτάται από τη γραμμή του κελιού στο οποίο θα καταχωρηθεί. Στον τύπο, η συνάρτηση ROW επιστρέφει τον αριθμό γραμμής του κελιού όπου είναι καταχωρημένος ο τύπος. Αυτός ο αριθμός πολλαπλασιάζεται με το 3. Η συνάρτηση OFFSET μετακινεί το ενεργό κελί προς τα κάτω, από το κελί A1, κατά τον καθορισμένο αριθμό γραμμών και επιστρέφει κάθε τρίτο αριθμό.

Στρογγυλοποίηση στο πλησιέστερο λεπτό

Aς υποθέσουμε ότι καταχωρείτε τους ακόλουθους τύπους στα κελιά A1:A3 ενός φύλλου εργασίας:

Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
A1: =1,23/2
A2: =1,21/2
Α3: =SUM(A1:A2)

Aς υποθέσουμε ότι εργάζεστε με χρήματα και ότι τα αποτελέσματα των υπολογισμών μορφοποιούνται ως χρήματα. Οι τιμές που επιστρέφονται είναι οι ακόλουθες:

Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
A1: €0,62
A2: €0,61
Α3: €1,22

Όπως μπορείτε να δείτε, το άθροισμα στο κελί A3 δεν είναι σωστό. Το πρόβλημα είναι ότι, παρόλο που η μορφή των αριθμών (νομισματική) στρογγυλοποιεί τις τιμές που εμφανίζονται, οι υποκείμενες τιμές δεν στρογγυλοποιούνται στο πλησιέστερο λεπτό. Μπορούμε να επιλύσουμε αυτήν τη συμπεριφορά χρησιμοποιώντας τη συνάρτηση ROUND. Για παράδειγμα, αλλάξτε τους τύπους ως εξής:

Σύμπτυξη αυτού του πίνακαΑνάπτυξη αυτού του πίνακα
A1: =ROUND(1,23/2,2)
A2: =ROUND(1,21/2,2)
Α3: =ROUND(SUM(A1:A2),2)

Το δεύτερο όρισμα της συνάρτησης ROUND ενημερώνει το Excel για το ψηφίο που πρέπει να στρογγυλοποιηθεί. Σε αυτήν την περίπτωση, το 2 ενημερώνει το Excel ότι πρέπει να κάνει στρογγυλοποίηση στο δεύτερο δεκαδικό ψηφίο.

Εγκατάσταση και χρήση της Βοήθειας του Microsoft Excel (Microsoft Excel Help)

Η Βοήθεια του Microsoft Excel (Microsoft Excel Help) επιτρέπει την αναζήτηση πληροφοριών σχετικά με ένα συγκεκριμένο θέμα χρήσης, την αναζήτηση μέσω μιας λίστας θεμάτων ή την αναζήτηση συγκεκριμένων λέξεων και φράσεων αντί για θέματα. Μπορείτε επίσης να χρησιμοποιήσετε τη θεματική Βοήθεια (πιέστε το πλήκτρο F1) για να προβάλετε πληροφορίες που σχετίζονται με την εργασία.

Τα αρχεία της Βοήθειας (Help) πρέπει να είναι εγκατεστημένα για να έχετε δυνατότητα πρόσβασης σε αυτά. Εάν δεν είναι εγκατεστημένη η Βοήθεια (Help), εκτελέστε ξανά το πρόγραμμα Εγκατάστασης (Setup) και, στη συνέχεια, κάντε κλικ στο κουμπί Προσθαφαίρεση (Add/Remove) για να εγκαταστήσετε τα αρχεία.

Όχι άνοιγμα και αποθήκευση απευθείας από δισκέτα

Όταν ανοίγετε ένα βιβλίο εργασίας, το Excel δημιουργεί προσωρινά αρχεία στο φάκελο όπου αποθηκεύετε το αρχείο και στο φάκελο από τον οποίο ανοίξατε το βιβλίο εργασίας. Αυτά τα προσωρινά αρχεία διαγράφονται όταν κλείσετε το αρχείο. Επίσης, το Excel δημιουργεί ένα αντίγραφο του αρχείου στο μέσο κατά την αποθήκευση του αρχείου. Αυτή η συμπεριφορά ενδέχεται να είναι προβληματική αν ανοίξετε ένα βιβλίο εργασίας από μια δισκέτα ή αν η δισκέτα δεν έχει αρκετό ελεύθερο χώρο για το αρχείο.

Για αυτούς τους λόγους, είναι καλή ιδέα να αντιγράψετε το αρχείο στο σκληρό σας δίσκο πριν εργαστείτε με αυτό. Αφού ολοκληρώσετε τις τροποποιήσεις, αποθηκεύστε το αρχείο στο σκληρό σας δίσκο και, στη συνέχεια, αντιγράψτε το πίσω στη δισκέτα.

Χρήση ενός πλήκτρου για δημιουργία νέου γραφήματος ή φύλλου εργασίας

Για να δημιουργήσετε γρήγορα ένα γράφημα, επιλέξτε τα δεδομένα γραφήματος και, στη συνέχεια, πιέστε το πλήκτρο F11. Για να δημιουργήσετε ένα νέο φύλλο εργασίας, πιέστε τα πλήκτρα SHIFT+F11.

Ορισμός πολλών περιοχών εκτύπωσης στο ίδιο φύλλο εργασίας

Μπορείτε να ορίσετε πολλές περιοχές εκτύπωσης στο ίδιο φύλλο εργασίας χωρίς να χρησιμοποιήσετε μακροεντολή. Για να το κάνετε αυτό, χρησιμοποιήστε την εντολή "Προσαρμοσμένες προβολές" (Custom Views) και την εντολή "Εκτύπωση έκθεσης" (Print Report). Ουσιαστικά, καθορίζετε προβολές ενός φύλλου εργασίας και, στη συνέχεια, καθορίζετε μια έκθεση με τις προβολές τις επιλογής σας. Για περισσότερες πληροφορίες, ανατρέξτε στη Βοήθεια του Microsoft Excel (Microsoft Excel Help).

Για πρόσθετες πληροφορίες, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft (Knowledge Base):
142529 XL: Τρόπος δημιουργίας πολλαπλών προβολών και τρόπος δημιουργίας και εκτύπωσης μιας έκθεσης

Ιδιότητες

Αναγν. άρθρου: 843504 - Τελευταία αναθεώρηση: Τρίτη, 19 Δεκεμβρίου 2006 - Αναθεώρηση: 1.2
Οι πληροφορίες σε αυτό το άρθρο ισχύουν για:
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft Office Excel 2003
Λέξεις-κλειδιά: 
kbfunctions kbhowto kbinfo KB843504

Αποστολή σχολίων

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com