The Lsass.exe process uses between 50 percent and 100 percent of the processor resources when Windows Server 2000 domain users try to log on to the domain controller

Article translations Article translations
Article ID: 843557 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

When Microsoft Windows Server 2000 domain users try to log on to the domain controller, one of the following conditions may occur:
  • The logon process takes a long time.
  • The logon process does not succeed.
When you examine the Lsass.exe process on the Processes tab in Task Manager on your domain controller, you notice that the Lsass.exe process is using between 50 percent and 100 percent of the processor resources.

CAUSE

This problem may occur if the following conditions are both true:
  • Many users try to log on to your Windows 2000 domain controller at the same time.
  • The users who try to log on to your Windows 2000 domain controller are members of many groups.
The logon process builds and then sorts a list of the groups that a user is a member of. If the user belongs to many groups, the logon process may take a long time to build and then sort the groups list. If many users who belong to many groups log on at the same time, the Lsass.exe process may use more processor resources than expected. The logon process may not succeed because the domain controller is busy processing Lsass.exe.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows 2000 Service Pack 3 or a later version.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2004  02:17   5.0.2195.6876    388,368   Advapi32.dll
   24-Mar-2004  02:17   5.0.2195.6866     69,904   Browser.dll
   24-Mar-2004  02:17   5.0.2195.6824    134,928   Dnsapi.dll
   24-Mar-2004  02:17   5.0.2195.6876     92,432   Dnsrslvr.dll
   24-Mar-2004  02:17   5.0.2195.6883     47,888   Eventlog.dll
   24-Mar-2004  02:17   5.0.2195.6890    143,632   Kdcsvc.dll
   11-Mar-2004  02:37   5.0.2195.6903    210,192   Kerberos.dll
   21-Sep-2003  00:32   5.0.2195.6824     71,888   Ksecdd.sys
   11-Mar-2004  02:37   5.0.2195.6902    520,976   Lsasrv.dll
   25-Feb-2004  23:59   5.0.2195.6902     33,552   Lsass.exe
   19-Jun-2003  20:05   5.0.2195.6680    117,520   Msv1_0.dll
   24-Mar-2004  02:17   5.0.2195.6897    312,592   Netapi32.dll
   19-Jun-2003  20:05   5.0.2195.6695    371,984   Netlogon.dll
   13-Jul-2004  02:24   5.0.2195.6944    933,648   Ntdsa.dll
   24-Mar-2004  02:17   5.0.2195.6897    388,368   Samsrv.dll
   24-Mar-2004  02:17   5.0.2195.6893    111,376   Scecli.dll
   24-Mar-2004  02:17   5.0.2195.6903    253,200   Scesrv.dll
   04-Jun-2004  23:13   5.0.2195.6935  5,887,488   Sp3res.dll
   24-Mar-2004  02:17   5.0.2195.6824     50,960   W32time.dll
   21-Sep-2003  00:32   5.0.2195.6824     57,104   W32tm.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New naming schema for Microsoft Windows software update packages
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 843557 - Last Review: October 26, 2013 - Revision: 2.6
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB843557

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com