Article ID: 843618 - Last Review: July 24, 2007 - Revision: 1.10

The Storport.sys driver does not use ReportLUN data after a "CHECK 0B/00/06" error occurs

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SYMPTOMS

'When a storage array returns a "CHECK 0B/00/06 (Aborted Command - I/O Process Terminated)" error with a ReportLUN command, the Storport.sys driver does not use the data from the ReportLUN command.

CAUSE

This problem occurs because the Storport.sys driver does not examine the additional logical unit numbers (LUNs) that are between 00 and FE (between 0 and 254).

RESOLUTION

Hotfix information

After you install this hotfix, Storport.sys retries commands after a "CHECK 0B/00/06" error. Additionally, the STORport driver does not use data from the returned ReportLUN and scans with an inquiry (INQ) for all available LUNs.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
32-bit editions of Windows Server 2003

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Aug-2004  22:07  5.2.3790.202       72,704  Storport.sys
 
Windows Server 2003, 64-Bit Enterprise Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Aug-2004  22:04  5.2.3790.202      251,392  Storport.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbbug kbfix kbwinserv2003presp1fix kbqfe kbhotfixserver KB843618