System Message 6247 "Invalid Bankacct, BankSub Combination in Cash Manager" in AP

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Article ID: 844300 - View products that this article applies to.
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SYMPTOMS

System Message 6247 - "Invalid Bankacct, BankSub Combination in Cash Manager" occurs in Accounts Payable.

CAUSE

1. Occurs if the Cash Account and Subaccount combination in Voucher and Adjustment Entry (03.010.00) - Manual Check, Quick Voucher and Pre-Payment Entry (03.020.00), Manual Check Entry (03.030.00), or Payment Selection (03.500.00) have not been defined in Cash Manager Cash Account Maintenance (20.250.00). See Resolution 1.

2. Occurs when printing Checks (03.620.00) if the BATCH, APCHECK, and APCHECKDET tables contain an invalid Subaccount. See resolution 2.

3. Occurs when printing Checks (03.620.00) if the CpnyID value is incorrect in the GLSETUP table. See resolution 3.

RESOLUTION

Resolution 1 - Verify that the Cash Account and Subaccount are defined in Cash Manager Cash Account Maintenance (20.250.00).
Note If Cash Manager is set up, the Cash Accounts and Subaccounts used in Accounts Payable, Accounts Receivable, and Payroll must be defined in Cash Account Maintenance (20.250.00).

1. Access Cash Account Maintenance (20.250.00).
2. Verify that the Bank Account and Bank Subaccount combination has been defined.
3. If the Bank Account and Bank Subaccount combination has not been defined, enter the appropriate combination.
4. Save changes and close the screen.

Resolution 2 - Verify that the Subaccount values are correct in the APCHECK, APCHECKDET, and BATCH tables.

1. Make a BACKUP of the database which can be restored in case an undesired data loss occurs.

2. Using Query Analyzer, access the appropriate Application database and execute the following statements:

A. To verify the Subaccount values in the APCHECK table:
SELECT Sub, * from APCHECK where BatNbr = 'XXXXXX'
(where XXXXXX = the appropriate Batch Number)

B. To verify the Subaccount values in the APCHECKDET table:

SELECT User2, * from APCHECKDET where BatNbr = 'XXXXXX'
(where XXXXXX = the appropriate Batch Number)

C. To verify the Subaccount values in the BATCH table:

SELECT User2, * from BATCH where BatNbr = 'XXXXXX' and Module = 'AP'
(where XXXXXX = the appropriate Batch Number)

Resolution 3 - Verify that the correct Company ID is defined in the GLSETUP table.


WARNING: The GLSETUP table contains the Master Company information, and it should NOT be changed. The only time this table should be changed is if the Multi-Company module is not implemented and the CpnyID in GLSETUP does not match the CpnyID in the COMPANY table.

1. Make a BACKUP of the database which can be restored in case an undesired data loss occurs.

2. Using Query Analyzer, access the appropriate Application database and execute the following statement to verify that the CpnyID in the GLSETUP table is correct:

SELECT CpnyID, * from GLSETUP

3. If the CpnyID field is not populated with the correct value, execute the following statement to correct it:

UPDATE GLSETUP SET CpnyID = 'XXXX'
(where 'XXXX' = the correct Company ID)

This article was TechKnowledge Document ID: 114330

Properties

Article ID: 844300 - Last Review: October 24, 2012 - Revision: 3.0
Applies to
  • Microsoft Dynamics SL 2011
  • Microsoft Dynamics SL 2011 Service Pack 1
  • Microsoft Dynamics SL 7.0
  • Microsoft Dynamics SL 7.0 Service Pack 2
  • Microsoft Dynamics SL 7.0 Service Pack 3
  • Microsoft Dynamics SL 7.0 Service Pack 4
Keywords: 
kbmbsmigrate KB844300

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