"The Password you entered was not valid" in Solomon Desktop

Article ID: 849086 - View products that this article applies to.
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SYMPTOMS

When you log on to Solomon Desktop with an Integrated Logon User ID, you receive the following message on the User Login Results screen:

The Password you entered was not valid.

CAUSE

This behavior may occur if the IIS Anonymous User is not set up as a SQL Server Login.

RESOLUTION

To correct this issue, add the IIS Anonymous User as a Microsoft SQL Server Login in Enterprise Manager.

1. At the IIS server, click Start, click Control Panel, and then double-click Administrative Tools. Double-click Internet Services Manager (Windows 2000), Internet Information Services (Windows XP), or Internet Information Services (IIS) Manager (Windows Server 2003).

2. Expand through Default Web Site.

3. Right-click Solweb (the name of the Solomon Desktop Web site) and then click Properties.

4. Click the Directory Security tab.

5. Click Edit for Anonymous access and authentication control.

6. Note the user name specified under the Account used for anonymous access label in the Authentication Methods dialog box.

Note The IIS Anonymous User must be a valid domain account.

7. Open SQL Enterprise Manager.

8. Double-click SQL Server Group, and then double-click your server name.

9. Under your server name, double-click Security.

10. Right-click Logins, and then click New Login.

11. In the Name field, specify the network user ID noted in step 6.

12. Click the Windows Authentication option.

13. In the Domain box, type or select the domain for the network user.

14. Make sure that the Grant access option is selected for Security access.

15. Accept the default settings for the Server Roles and Database Access tabs.

16. Click OK.

This article was TechKnowledge Document ID: 137336

Properties

Article ID: 849086 - Last Review: July 10, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Great Plains Solomon IV 4.50
  • Microsoft Great Plains Solomon IV 5.0
Keywords: 
KBRetire kbmbssolomondesktop kbmbsenvironment kbmbsmigrate KB849086
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.