Erro "Não é possível acessar esse formulário porque o dicionário que o contém não está carregado" quando você abre uma janela no Microsoft Dynamics GP
Este artigo fornece métodos para resolve o erro "Não é possível acessar esse formulário porque o dicionário que o contém não está carregado" no Microsoft Dynamics GP.
Aplica-se a: Microsoft Dynamics GP
Número de KB original: 851052
Sintomas
Ao abrir uma janela no Microsoft Dynamics GP, você recebe a seguinte mensagem de erro:
Não é possível acessar esse formulário porque o dicionário que o contém não está carregado.
Causa 1
Se um módulo instalado anteriormente for removido, o Microsoft Dynamics GP não atribuirá um formulário existente alternativo. Consulte Resolução 1.
Causa 2
Se um dicionário de formulários foi removido ou se tornou corrompido, o Microsoft Dynamics GP não poderá abrir o formulário atribuído. Consulte Resolução 2.
Solução 1
Para resolver esse problema, use um dos métodos a seguir.
Método 1 da Resolução 1
Reinstale o módulo que foi removido. Essa ação recria o dicionário de produtos que o Microsoft Dynamics GP deve acessar.
Método 2 da Resolução 1
Selecione um formulário para o Microsoft Dynamics GP a ser usado. Para fazer isso, use a opção apropriada.
- Abra a janela Formulários e Relatórios Alternativos/Modificados . Para fazer isso, no menu gp do Microsoft Dynamics, aponte paraSistema deInstalação> de Ferramentas> e selecione Formulários e Relatórios Alternativos/Modificados.
- Na lista de ID , selecione a ID apropriada.
- Na lista Produto , selecione Todos os Produtos.
- Na lista Tipo , selecione Windows.
- Na área Lista de Formulários e Relatórios Alternativos/Modificados , expanda o nó apropriado com base na janela que você deseja acessar.
- Expanda a janela apropriada e selecione Microsoft Dynamics GP ou a opção apropriada.
- Selecione Salvar.
- Feche a janela Formulários e Relatórios Alternativos/Modificados .
Observação
Por padrão, quando você abre a janela Segurança Avançada , o usuário atual e a empresa atual são selecionados. Todas as alterações feitas são para o usuário atual e para a empresa atual. No entanto, você pode selecionar mais empresas na área Nome da Empresa . Você pode selecionar mais usuários na área Usuário da janela Segurança Avançada .
Solução 2
Para resolve esse problema, siga um dos seguintes métodos.
Método 1 da Resolução 2
Crie novamente o arquivo Form.dic se o dicionário Forms estiver corrompido.
Para obter mais informações sobre como recriar o arquivo Forms.dic, consulte Como recriar o arquivo Forms.dic no Microsoft Dynamics GP.
Método 2 da Resolução 2
Selecione um formulário para o Microsoft Dynamics GP a ser usado. Para fazer isso, use a opção apropriada.
- Abra a janela Formulários e Relatórios Alternativos/Modificados . Para fazer isso, no menu gp do Microsoft Dynamics, aponte paraSistema deInstalação> de Ferramentas> e selecione Formulários e Relatórios Alternativos/Modificados.
- Na lista de ID , selecione a ID apropriada.
- Na lista Produto , selecione Todos os Produtos.
- Na lista Tipo , selecione Windows.
- Na área Lista de Formulários e Relatórios Alternativos/Modificados , expanda o nó apropriado com base na janela que você deseja acessar.
- Expanda a janela apropriada e selecione Microsoft Dynamics GP ou a opção apropriada.
- Selecione Salvar.
- Feche a janela Formulários e Relatórios Alternativos/Modificados .
Observação
Por padrão, quando você abre a janela Segurança Avançada , o usuário atual e a empresa atual são selecionados. Todas as alterações feitas são para o usuário atual e para a empresa atual. No entanto, você pode selecionar mais empresas na área Nome da Empresa . Você pode selecionar mais usuários na área Usuário da janela Segurança Avançada .
Comentários
https://aka.ms/ContentUserFeedback.
Brevemente: Ao longo de 2024, vamos descontinuar progressivamente o GitHub Issues como mecanismo de feedback para conteúdos e substituí-lo por um novo sistema de feedback. Para obter mais informações, veja:Submeter e ver comentários