Microsoft Dynamics GP'de bir pencere açtığınızda "Bu formu içeren sözlük yüklenmediğinden bu forma erişilemiyor" hatası

Bu makalede, Microsoft Dynamics GP'de "Bu formu içeren sözlük yüklenmediğinden bu forma erişilemiyor" hatasını çözmek için yöntemler sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics GP
Özgün KB numarası: 851052

Belirtiler

Microsoft Dynamics GP'de bir pencere açtığınızda aşağıdaki hata iletisini alırsınız:

Bu formu içeren sözlük yüklenmediğinden bu forma erişilemiyor.

Neden 1

Daha önce yüklenmiş bir modül kaldırılırsa, Microsoft Dynamics GP alternatif bir mevcut form atamaz. Bkz . Çözüm 1.

Neden 2

Bir form sözlüğü kaldırıldıysa veya bozulursa, Microsoft Dynamics GP atanan formu açamaz. Bkz . Çözüm 2.

Çözüm 1

Bu sorunu gidermek için aşağıdaki yöntemlerden birini kullanın:

Çözüm 1'in Yöntem 1'i

Kaldırılan modülü yeniden yükleyin. Bu eylem, Microsoft Dynamics GP'nin erişmesi gereken ürün sözlüğünü yeniden oluşturur.

Çözüm 1'in Yöntem 2'sinde

Microsoft Dynamics GP'nin kullanması için bir form seçin. Bunu yapmak için uygun seçeneği kullanın.

  1. Alternatif/Değiştirilmiş Formlar ve Raporlar penceresini açın. Bunu yapmak için , Microsoft Dynamics GP menüsünde Araçlar>Kurulum>Sistemi'nin üzerine gelin ve ardından Alternatif/Değiştirilmiş Formlar ve Raporlar'ı seçin.
  2. Kimlik listesinde uygun kimliği seçin.
  3. Ürün listesinde Tüm Ürünler'i seçin.
  4. Tür listesinde Windows'ı seçin.
  5. Alternatif/Değiştirilmiş Formlar ve Raporlar Listesi alanında, erişmek istediğiniz pencereye göre uygun düğümü genişletin.
  6. Uygun pencereyi genişletin ve ardından Microsoft Dynamics GP'yi veya uygun seçeneği belirleyin.
  7. Kaydet'i seçin.
  8. Alternatif/Değiştirilmiş Formlar ve Raporlar penceresini kapatın.

Not

Varsayılan olarak, Gelişmiş Güvenlik penceresini açtığınızda, geçerli kullanıcı ve geçerli şirket seçilir. Yaptığınız tüm değişiklikler geçerli kullanıcıya ve geçerli şirkete yöneliktir. Ancak , Şirket Adı alanında daha fazla şirket seçebilirsiniz. Gelişmiş Güvenlik penceresinin Kullanıcı alanında daha fazla kullanıcı seçebilirsiniz.

Çözünürlük 2

Bu sorunu çözmek için aşağıdaki yöntemlerden birini izleyin.

Çözüm 2'nin Yöntem 1'i

Form sözlüğü bozuksa Form.dic dosyasını yeniden oluşturun.

Forms.dic dosyasını yeniden oluşturma hakkında daha fazla bilgi için bkz. Microsoft Dynamics GP'de Forms.dic dosyasını yeniden oluşturma.

Çözüm 2'nin Yöntem 2

Microsoft Dynamics GP'nin kullanması için bir form seçin. Bunu yapmak için uygun seçeneği kullanın.

  1. Alternatif/Değiştirilmiş Formlar ve Raporlar penceresini açın. Bunu yapmak için , Microsoft Dynamics GP menüsünde Araçlar>Kurulum>Sistemi'nin üzerine gelin ve ardından Alternatif/Değiştirilmiş Formlar ve Raporlar'ı seçin.
  2. Kimlik listesinde uygun kimliği seçin.
  3. Ürün listesinde Tüm Ürünler'i seçin.
  4. Tür listesinde Windows'ı seçin.
  5. Alternatif/Değiştirilmiş Formlar ve Raporlar Listesi alanında, erişmek istediğiniz pencereye göre uygun düğümü genişletin.
  6. Uygun pencereyi genişletin ve ardından Microsoft Dynamics GP'yi veya uygun seçeneği belirleyin.
  7. Kaydet'i seçin.
  8. Alternatif/Değiştirilmiş Formlar ve Raporlar penceresini kapatın.

Not

Varsayılan olarak, Gelişmiş Güvenlik penceresini açtığınızda, geçerli kullanıcı ve geçerli şirket seçilir. Yaptığınız tüm değişiklikler geçerli kullanıcıya ve geçerli şirkete yöneliktir. Ancak , Şirket Adı alanında daha fazla şirket seçebilirsiniz. Gelişmiş Güvenlik penceresinin Kullanıcı alanında daha fazla kullanıcı seçebilirsiniz.