Fehlermeldungen beim Auswählen eines Batches im Fenster "Gehaltsabrechnungsprüfungen erstellen" in Microsoft Dynamics GP
Dieser Artikel bietet eine Lösung für Fehler, die auftreten, wenn Sie einen Batch im Fenster Gehaltsabrechnungsprüfungen erstellen in Microsoft Dynamics GP auswählen.
Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 851664
Symptome
Wenn Sie einen Batch im Fenster "Gehaltsabrechnungsprüfungen erstellen" in Microsoft Dynamics GP auswählen, erhalten Sie möglicherweise eine der folgenden Fehlermeldungen:
Fehlermeldung 1
Fehler: "Öffnen des Vorgangs auf UPR_Temp_Post2 falsche Datensatzlänge hat"
Fehlermeldung 2
Fehler: "Remove Range Operation on Table ddDeposits has caused known error 2" (Remove Range Operation on Table ddDeposits has caused known error 2)
Fehlermeldung 3
Fehler: "Batches mit null Transaktionen können nicht markiert werden"
Fehlermeldung 4
Fehler: "Ein anderer Benutzer führt eine Überprüfung durch"
Fehlermeldung 5
Fehler: "fehler beim Zugreifen auf SQL-Daten UPR_Work_Post"
Fehlermeldung 6
Fehler: "Der Mitarbeiterdatensatz kann nicht inaktiviert oder gelöscht werden. Die Lohnausführung wird für diesen Mitarbeiter ausgeführt."
Fehlermeldung 7
Fehler: "Überprüfungen können nicht berechnet werden. Fehler wurden gefunden."
Fehlermeldung 8
Fehler: "Eine Überprüfung kann nicht aufgehoben werden. Es wird eine Computerüberprüfung ausgeführt."
Fehlermeldung 9
Fehler: "Sie können einen für die Buchung markierten Batch nicht bearbeiten"
Fehlermeldung 10
Fehler: "Batch ist für die Veröffentlichung markiert und kann nicht bearbeitet werden."
Darüber hinaus kann in einer der folgenden Dateien ein Fehler beim Öffnen des Vorgangs, ein Fehler beim Abrufen/Ändern oder ein Speichervorgang auftreten, um anzugeben, dass der Batch "Gehaltsabrechnung" hängen bleibt:
- UPR_WORK_MSTR
- UPR_WORK_MSTR_Detail
- UPR_WORK_HDR
- UPR_WORK_Pay_Type
- UPR_WORK_Deduction
- UPR_WORK_Benefit
- UPR_WORK_State_Tax
- UPR_WORK_Local Steuer
- UPR_WORK_Check
- UPR_WORK_Post
- UPR_Flat_Tax_Records
- UPR_Account_Cache
Ursache
Dieses Problem kann auftreten, wenn die Arbeitstabellen für die Gehaltsabrechnung nicht gelöscht wurden. Die Arbeitstabellen für die Gehaltsabrechnung müssen gelöscht werden, um den Batch freizugeben.
Lösung
Hinweis
Bevor Sie die Anweisungen in diesem Artikel befolgen, stellen Sie sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie wiederherstellen können, wenn ein Problem auftritt.
Gehen Sie wie folgt vor, um das Problem zu beheben:
Schritt 1: Löschen von Datensätzen in Arbeitstabellen für die Gehaltsabrechnung
Öffnen Sie Microsoft SQL Server mit SQL Server Management Studio (SSMS).
Um SQL Server Management Studio zu starten, wählen Sie Start aus, zeigen Sie auf Alle Programme>Microsoft SQL Server 2008, und wählen Sie dann SQL Server Management Studio aus.
Führen Sie delete-Anweisungen für die Unternehmensdatenbank aus.
Hinweis
Die ersten beiden Zeilen im Skript löschen den Inhalt der Aktivitätsdateien in der Dynamics-Datenbank. Die anderen Zeilen löschen den Inhalt der Arbeitsdateien und der Aktivitätsdateien in der Unternehmensdatenbank.
Delete DYNAMICS..UPR10300 Delete DYNAMICS..UPR10304 Delete UPR10200 Delete UPR10201 Delete UPR10202 Delete UPR10203 Delete UPR10204 Delete UPR10205 Delete UPR10206 Delete UPR10207 Delete UPR10208 Delete UPR10209 Delete UPR10213 Delete UPR19900 Delete UPR19901
Wenn Sie Direct Deposit verwenden, führen Sie diese Löschauszug für die Tabelle "Direct Deposit Work" aus:
Delete DD10100 --(Direct Deposit Employee Deposit Work)
Schritt 2: Löschen temporärer Dateien
Um temporäre Dateien zu löschen, öffnen Sie Windows Explorer, und wählen Sie dann das Temporäre Verzeichnis aus. Das temporäre Verzeichnis weist den folgenden Pfad auf:
C:\Windows\Temporary
Löschen Sie im Verzeichnis die Dateien, die mit TNT beginnen. Löschen Sie dann die Dateien mit einer .tmp Dateinamenerweiterung.
Schritt 3: Links überprüfen
Mit "Links aktivieren" wird die Verknüpfung der Daten zwischen den Tabellen überprüft, um die Datenintegrität sicherzustellen. Gehen Sie dazu wie folgt vor:
- Öffnen Sie das Fenster "Links überprüfen". Wählen Sie in Microsoft Dynamics GP die Option Microsoft Dynamics GP, wartung und dann Links überprüfen aus.
- Wählen Sie in der Liste Reihendie Option Gehaltsabrechnung aus.
- Wählen Sie in der Liste Logische Tabellendie Option Gehaltsabrechnungstransaktionen aus, wählen Sie Einfügen und dann OK aus.
- Aktivieren Sie im Dialogfeld Berichtsziel das entsprechende Kontrollkästchen, und wählen Sie dann OK aus.
Hinweis
Sie können die Fehlermeldungen, die im Fehlerprotokoll auftreten, problemlos ignorieren. Der Prozess Links überprüfen bezieht die Batch-ID erneut an die vorhandenen Transaktionen an.
Wenn es sich bei Ihrem Batch um wiederkehrende Batches handelte und vom Prozess "Links überprüfen" neu erstellt wurde, wurde die Batchhäufigkeit standardmäßig auf einmalige Verwendung festgelegt. Wählen Sie Transaktionen, dann Gehaltsabrechnung und dann Batches und dann die neu erstellte Batch-ID aus, und überprüfen Sie die Batch-Einstellungen. Wenn es sich um einen wiederkehrenden Batch handelt, ändern Sie die Häufigkeit in eine Häufigkeit , die nicht nur die einmalige Verwendung ist.
Schritt 4: Erstellen der Überprüfungsdatei
Erstellen Sie die Überprüfungsdatei erneut. Alle Batches befinden sich noch in der Prüfdatei.
Häufig gestellte Fragen:
F1: Ich möchte nicht den gesamten Gehaltsabrechnungsbatch löschen und von vorn beginnen, sollte ich weiterhin die oben genannten Schritte ausführen?
A1: Ja, die Transaktionen im Gehaltsabrechnungsbatch werden in der tabelle UPR10302 Gehaltsabrechnungstransaktionen gespeichert, und Sie löschen diese Tabelle nicht in den obigen Skripts, sodass die Transaktionen nicht entfernt werden. Die Skripts entfernen nur den Batchheaderdatensatz (UPR10301), und wenn Sie Checklinks ausführen, erstellt das System diesen Batchheaderdatensatz erneut (da er in den Transaktionen noch angezeigt wird, sodass er neu erstellt wird).)
F2: Ich habe den neuen Batch gepostet und er ist verschwunden. Es sollte ein wiederkehrender Batch gewesen sein.
A2: Wenn Sie Überprüfungslinks ausgeführt haben, um den Batch neu zu erstellen, wurde er standardmäßig mit einer einzigen Verwendungshäufigkeit erstellt. Sie sollten die Batchhäufigkeit vor der Veröffentlichung bearbeitet haben, wenn es sich um einen wiederkehrenden Batch hätte handelt. Wenn Sie den Batch gepostet haben, ist es jetzt zu spät. Sie müssen den Batch bzw. die Transaktionen manuell wieder eingeben (beginnend mit dem nächsten erforderlichen Buchungsdatum), und die Häufigkeit für den neuen Batch ändern, der in Zukunft verwendet werden soll.
Feedback
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