Mensajes de error al seleccionar un lote en la ventana Compilación de comprobaciones de nómina en Microsoft Dynamics GP

En este artículo se proporciona una solución a los errores que se producen al seleccionar un lote en la ventana Compilación de comprobaciones de nómina en Microsoft Dynamics GP.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 851664

Síntomas

Al seleccionar un lote en la ventana Compilación de comprobaciones de nómina en Microsoft Dynamics GP, puede recibir uno de los siguientes mensajes de error:

Mensaje de error 1

Error: "Abrir operación en UPR_Temp_Post2 tiene una longitud de registro incorrecta"

Mensaje de error 2

Error: "Remove Range Operation on Table ddDeposits has caused known error 2" (Quitar operación de intervalo en la tabla ddDeposits ha causado el error conocido 2)

Mensaje de error 3

Error: "Los lotes con cero transacciones no se pueden marcar"

Mensaje de error 4

Error: "Otro usuario está realizando una ejecución de comprobación"

Mensaje de error 5

Error: "UPR_Work_Post no se pudo acceder a los datos SQL"

Mensaje de error 6

Error: "El registro de empleado no se puede desactivar o eliminar La ejecución de pago está en curso para este empleado"

Mensaje de error 7

Error: "No se pueden calcular las comprobaciones. Se encontraron errores".

Mensaje de error 8

Error: "No se puede anular una comprobación. Una ejecución de comprobación del equipo está en proceso".

Mensaje de error 9

Error: "No se puede editar un lote marcado para su publicación"

Mensaje de error 10

Error: "Batch está marcado para su publicación y no se puede editar".

Además, puede producirse un error abrir operación, un error Get/Change o un error guardar operación en uno de los siguientes archivos para indicar que el lote De nómina está bloqueado:

  • UPR_WORK_MSTR
  • UPR_WORK_MSTR_Detail
  • UPR_WORK_HDR
  • UPR_WORK_Pay_Type
  • UPR_WORK_Deduction
  • UPR_WORK_Benefit
  • UPR_WORK_State_Tax
  • impuestos de UPR_WORK_Local
  • UPR_WORK_Check
  • UPR_WORK_Post
  • UPR_Flat_Tax_Records
  • UPR_Account_Cache

Causa

Este problema puede producirse si no se han borrado las tablas de trabajo de nómina. Las tablas de trabajo de nómina deben borrarse para liberar el lote.

Solución

Nota:

Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que puede restaurar si se produce un problema.

Para resolver este problema, siga estos pasos:

Paso 1: Eliminar registros en tablas de trabajo de nómina

  1. Abra Microsoft SQL Server con SQL Server Management Studio (SSMS).

    Para iniciar SQL Server Management Studio, seleccione Inicio, seleccione Todos los programas>Microsoft SQL Server 2008 y, a continuación, seleccione SQL Server Management Studio.

  2. Ejecute instrucciones delete en la base de datos de la empresa.

    Nota:

    Las dos primeras líneas del script eliminan el contenido de los archivos de actividad de la base de datos de Dynamics. Las otras líneas eliminan el contenido de los archivos de trabajo y los archivos de actividad en la base de datos company.

    Delete DYNAMICS..UPR10300
    Delete DYNAMICS..UPR10304
    Delete UPR10200
    Delete UPR10201
    Delete UPR10202
    Delete UPR10203
    Delete UPR10204
    Delete UPR10205
    Delete UPR10206
    Delete UPR10207
    Delete UPR10208
    Delete UPR10209
    Delete UPR10213
    Delete UPR19900
    Delete UPR19901
    
  3. Si usa El depósito directo, ejecute este extracto de eliminación para la tabla de trabajo de depósito directo:

    Delete DD10100 --(Direct Deposit Employee Deposit Work)
    

Paso 2: Eliminar archivos temporales

Para eliminar archivos temporales, abra el Explorador de Windows y, a continuación, seleccione el directorio Temporal . El directorio Temporal tiene la siguiente ruta de acceso:

C:\Windows\Temporary

En el directorio, elimine los archivos que comienzan por TNT. A continuación, elimine los archivos que tienen una extensión de nombre de archivo .tmp.

Active Vínculos para comprobar la vinculación de los datos entre las tablas para garantizar la integridad de los datos. Para ello, siga estos pasos:

  1. Abra la ventana Vínculos. En Microsoft Dynamics GP, seleccione Microsoft Dynamics GP, seleccione Mantenimiento y, a continuación, seleccione Comprobar vínculos.
  2. En la lista Serie , seleccione Nómina.
  3. En la lista Tablas lógicas , seleccione Transacciones de nómina, Insertar y, después, Aceptar.
  4. En el cuadro de diálogo Destino del informe, active la casilla correspondiente y, a continuación, seleccione Aceptar.

Nota:

Puede omitir de forma segura los mensajes de error que se producen en el registro de errores. El proceso Comprobar vínculos vuelve a conectar el identificador de lote a las transacciones existentes.

Si el lote debe haber sido un lote periódico y se ha vuelto a generar mediante el proceso Comprobar vínculos, la frecuencia del lote se estableció en un solo uso de forma predeterminada. Seleccione Transacciones, nómina y, a continuación, seleccione Lotes, el id. de lote que se ha vuelto a crear y revise la configuración de Batch. Si debe ser un lote periódico, cambie la frecuencia a una frecuencia distinta de Uso único.

Paso 4: Compilación del archivo check

Vuelva a compilar el archivo de comprobación. Todos los lotes siguen en el archivo de comprobación.

Preguntas comunes:

P1: No quiero eliminar todo el lote de nóminas y empezar de nuevo, ¿debo seguir los pasos anteriores?

A1: Sí, las transacciones del lote de nóminas se almacenan en la tabla UPR10302 Transacciones de nómina y no se elimina esa tabla en los scripts anteriores, por lo que no se quitan las transacciones. Los scripts solo quitan el registro de encabezadopor lotes (UPR10301) y, al ejecutar checklinks, el sistema volverá a crear ese registro de encabezado por lotes (porque lo ve en las transacciones todavía, por lo que lo volverá a crear).

P2: Publicé el nuevo lote y desapareció. Debería haber sido un lote periódico.

A2: Cuando ejecutó vínculos de comprobación para recompilar el lote, lo creó con una frecuencia de uso única de forma predeterminada. Debería haber editado la frecuencia del lote antes de publicarla, si debería haber sido un lote periódico. Si ha publicado el lote, ya es demasiado tarde. Tendrá que volver a escribir manualmente el lote o las transacciones (a partir de la fecha de publicación siguiente necesaria) y cambiar la frecuencia del nuevo lote que se usará en el futuro.