Messages d’erreur lorsque vous sélectionnez un lot dans la fenêtre Générer des vérifications de la paie dans Microsoft Dynamics GP

Cet article fournit une solution aux erreurs qui se produisent lorsque vous sélectionnez un lot dans la fenêtre Générer des vérifications de la paie dans Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP
Numéro de la base de connaissances d’origine : 851664

Symptômes

Lorsque vous sélectionnez un lot dans la fenêtre Générer des vérifications de la paie dans Microsoft Dynamics GP, vous pouvez recevoir l’un des messages d’erreur suivants :

Message d’erreur 1

Erreur : « L’opération d’ouverture sur UPR_Temp_Post2 a une longueur d’enregistrement incorrecte »

Message d’erreur 2

Erreur : « L’opération de suppression de plage sur la table ddDeposits a provoqué l’erreur connue 2 »

Message d’erreur 3

Erreur : « Les lots avec zéro transaction ne peuvent pas être marqués »

Message d’erreur 4

Erreur : « Un autre utilisateur effectue une exécution case activée »

Message d’erreur 5

Erreur : « UPR_Work_Post n’a pas pu accéder aux données SQL »

Message d’erreur 6

Erreur : « L’enregistrement de l’employé ne peut pas être désactivé ou supprimé L’exécution de paye est en cours pour cet employé »

Message d’erreur 7

Erreur : « Les vérifications ne peuvent pas être calculées. Des erreurs ont été détectées. »

Message d’erreur 8

Erreur : « Vous ne pouvez pas annuler un case activée. Un ordinateur case activée’exécution est en cours. »

Message d’erreur 9

Erreur : « Vous ne pouvez pas modifier un lot marqué pour la publication »

Message d’erreur 10

Erreur : « Batch est marqué pour publication et ne peut pas être modifié ».

En outre, une erreur d’ouverture d’opération, une erreur Get/Change ou une erreur d’opération d’enregistrement peut se produire sur l’un des fichiers suivants pour indiquer que le lot paie est bloqué :

  • UPR_WORK_MSTR
  • UPR_WORK_MSTR_Detail
  • UPR_WORK_HDR
  • UPR_WORK_Pay_Type
  • UPR_WORK_Deduction
  • UPR_WORK_Benefit
  • UPR_WORK_State_Tax
  • taxe UPR_WORK_Local
  • UPR_WORK_Check
  • UPR_WORK_Post
  • UPR_Flat_Tax_Records
  • UPR_Account_Cache

Cause

Ce problème peut se produire si les tables de travail de paie n’ont pas été effacées. Les tables de travail de paie doivent être effacées pour libérer le lot.

Résolution

Remarque

Avant de suivre les instructions de cet article, vérifiez que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer en cas de problème.

Pour résoudre ce problème, procédez comme suit :

Étape 1 : Supprimer des enregistrements dans les tables de travail paie

  1. Ouvrez Microsoft SQL Server à l’aide de SQL Server Management Studio (SSMS).

    Pour démarrer SQL Server Management Studio, sélectionnez Démarrer, pointez sur Tous les programmes>Microsoft SQL Server 2008, puis sélectionnez SQL Server Management Studio.

  2. Exécutez des instructions delete sur la base de données de l’entreprise.

    Remarque

    Les deux premières lignes du script suppriment le contenu des fichiers d’activité dans la base de données Dynamics. Les autres lignes suppriment le contenu des fichiers de travail et des fichiers d’activité dans la base de données de l’entreprise.

    Delete DYNAMICS..UPR10300
    Delete DYNAMICS..UPR10304
    Delete UPR10200
    Delete UPR10201
    Delete UPR10202
    Delete UPR10203
    Delete UPR10204
    Delete UPR10205
    Delete UPR10206
    Delete UPR10207
    Delete UPR10208
    Delete UPR10209
    Delete UPR10213
    Delete UPR19900
    Delete UPR19901
    
  3. Si vous utilisez le dépôt direct, exécutez cette instruction delete pour la table Direct Deposit Work :

    Delete DD10100 --(Direct Deposit Employee Deposit Work)
    

Étape 2 : Supprimer les fichiers temporaires

Pour supprimer des fichiers temporaires, ouvrez Windows Explorer, puis sélectionnez le répertoire Temporaire. Le répertoire Temporaire a le chemin d’accès suivant :

C:\Windows\Temporary

Dans le répertoire, supprimez les fichiers qui commencent par TNT. Ensuite, supprimez les fichiers qui ont une extension de nom de fichier .tmp.

Vérifier les liens case activée la liaison des données entre les tables pour garantir l’intégrité des données. Pour ce faire, procédez comme suit :

  1. Ouvrez la fenêtre Liens case activée. Dans Microsoft Dynamics GP, sélectionnez Microsoft Dynamics GP, Maintenance, puis Vérifier les liens.
  2. Dans la liste Séries , sélectionnez Paie.
  3. Dans la liste Tables logiques , sélectionnez Transactions de paie, Insérer, puis OK.
  4. Dans la boîte de dialogue Destination du rapport, sélectionnez la zone de case activée appropriée, puis sélectionnez OK.

Remarque

Vous pouvez ignorer en toute sécurité les messages d’erreur qui se produisent dans le journal des erreurs. Le processus Vérifier les liens rattache l’ID de lot aux transactions existantes.

Si votre lot devait être un lot récurrent et a été reconstruit par le processus Vérifier les liens, la fréquence du lot a été définie sur une utilisation unique par défaut. Sélectionnez Transactions, Paie, puis Lots, sélectionnez l’ID de lot qui a été recréé, puis passez en revue les paramètres Batch. S’il s’agit d’un lot périodique, remplacez la fréquence par une fréquence autre qu’une utilisation unique.

Étape 4 : Générer le fichier case activée

Générez à nouveau le fichier case activée. Tous les lots se trouvent toujours dans le fichier case activée.

Questions courantes :

Q1 : Je ne veux pas supprimer l’intégralité du lot de paie et recommencer, dois-je quand même suivre les étapes ci-dessus ?

R1 : Oui, les transactions du lot de paie sont stockées dans la table Transactions de paie UPR10302 , et vous ne supprimez pas cette table dans les scripts ci-dessus, de sorte que les transactions ne sont pas supprimées. Les scripts suppriment uniquement l’enregistrement d’en-tête de lot (UPR10301) et lorsque vous exécutez des liens de vérification, le système recrée cet enregistrement d’en-tête de lot (car il le voit toujours sur les transactions, donc il le recréera).)

Q2 : J’ai publié le nouveau lot et il a disparu. Il aurait dû s’agit d’un lot récurrent.

R2 : Lorsque vous avez exécuté case activée liens pour reconstruire le lot, il l’a généré avec une fréquence d’utilisation unique par défaut. Vous devez avoir modifié la fréquence du lot avant de la publier, s’il s’agit d’un lot périodique. Si vous avez publié le lot, il est trop tard. Vous devez rebaser manuellement le lot/les transactions (à compter de la prochaine date de publication nécessaire) et modifier la fréquence du nouveau lot à utiliser à l’avenir.