Article ID: 867780 - Last Review: August 29, 2007 - Revision: 2.2

A USB scanner device may not capture a picture correctly in Windows XP

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SYMPTOMS

When you try to capture a picture on a universal serial bus (USB) scanner device that is plugged into a Microsoft Windows XP-based computer, the picture may not be captured correctly.

CAUSE

This problem may occur if the Usbport.sys driver submits USB request blocks (URBs) to the scanner out of sequence.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   25-Jun-2004  21:52  5.1.2600.1515    5,632  Hccoin.dll       
   11-Apr-2004  03:22  5.1.2600.1515   30,464  Usbccgp.sys
   11-Apr-2004  03:21  5.1.2600.1515   25,216  Usbehci.sys
   11-Apr-2004  03:21  5.1.2600.1515   53,120  Usbhub.sys
   11-Apr-2004  03:21  5.1.2600.1515   16,000  Usbohci.sys
   25-Jun-2004  20:48  5.1.2600.1546  139,136  Usbport.sys
   11-Apr-2004  03:21  5.1.2600.1515   19,328  Usbuhci.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB867780