Windows XP でのバックアップからシステム状態データを復元した後、サードパーティのデバイス ドライバーが復元されません。

文書翻訳 文書翻訳

この資料の内容

Show all imageすべて表示Hide all imageすべて非表示

現象

Microsoft Windows XP でシステム状態データをバックアップから復元するバックアップ ツールを使用すると、サード パーティ製のドライバーを復元できません可能性があります。たとえば、Windows XP の新規インストールには、システム状態データのバックアップを復元すると、ネットワーク アダプターのドライバーが復元されない、し、次の追加現象が発生します。
  • デバイス マネージャーでコンピューターにインストールされているネットワーク アダプターを表示するに黒の感嘆符は、黄色の背景には、ネットワーク アダプターの横が表示されます。
  • 使用して、IP アドレスを更新しようとしたとき、 ipconfig 更新/ このコマンドは、次の出力が表示されます。
    インターフェイスの更新中にエラーが発生しました。 NameOfNetworkConnection: システム指定されたファイルが見つかりません
  • 復元操作後のバックアップ ツールの生成、レポートには、次のメッセージが含まれます。
    操作に失敗しました。バックアップのレポートの詳細についてを参照してください。

原因

システム状態データをバックアップから復元するとサード パーティ製のドライバーが復元されないために発生します。次のレジストリ サブキーの復元操作中は復元されません。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
このレジストリ サブキーには、デバイス ドライバーのパスを参照するサブキーが含まれます。

回避策

この問題を回避するには、デバイス マネージャーを使用して、削除し、デバイスを再インストールします。これを行うには、次の手順を実行します。

メモ コンピューターに管理者として、またはこれらの手順を実行するのには、administrators グループのメンバーとしてログオンしなければなりません。コンピューターがネットワークに接続されている場合は、ネットワーク ポリシーの設定、次の手順を終了できないことがあります。
  1. クリックしてください。 開始をクリックして 実行、タイプ sysdm.cpl で、 ファイルを開く ボックスとクリック [OK].
  2. クリックして、 ハードウェア タブ、し、 デバイス マネージャーをクリックして デバイス マネージャー.
  3. 削除、削除、および、クリックするデバイスを右クリックして、デバイスのデバイス カテゴリを展開します。 アンインストール.たとえば、ネットワーク アダプターを削除するには、展開します。 ネットワーク アダプター、ネットワーク アダプターを右クリックし、をクリックして アンインストール.
  4. デバイスの削除を確認するメッセージが表示されたらをクリックします。 [OK].
  5. で、 アクション メニューをクリックして ハードウェア変更をスキャンします。.
  6. 指示を表示する場合は、画面上に表示される指示に従います。デバイスによっては、クリックするとデバイスがコンピューターにインストールされて ハードウェア変更をスキャンします。 手順 5 で。これらのデバイスは、追加の指示の画面には表示されません。

    メモ 削除し、ネットワーク アダプターを再インストールする場合は、オフにして、IP アドレスが更新される前に、ネットワーク アダプターを有効にするがあります。ネットワーク アダプターを無効にするには、ネットワーク アダプターを右クリックしをクリックしてください 無効にします。、を確認するメッセージが表示されたら、[ [はい].ネットワーク アダプターを有効にするには、ネットワーク アダプターを右クリックし、クリックしてください 有効にします。.

詳細

デバイス マネージャーでデバイスを管理する方法の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
283658Windows XP でデバイスを管理する方法
バックアップを作成し、データを復元するのには、バックアップ ツールを使用する方法の詳細については、マイクロソフト サポート技術記事を表示するのには、次の資料番号をクリックしてください。
308422Windows xp コンピューター上のファイルおよびフォルダーのバックアップをバックアップするバックアップを使用する方法
309340 バックアップを使用して、コンピューターに Windows XP のファイルとフォルダーを復元する方法

この資料について

文書番号: 870891
最終更新日: 2011年7月30日
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:870891
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。
この資料に関するフィードバックを提供しますか?
 

Get more support from smallbusiness.support.microsoft.com

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.