Update: Die bestimmte Zeichen im Zeichensatz UNOC und bestimmte schwedischen Zeichen möglicherweise nicht übersetzt, wenn ein EDI-Dokument mit Microsoft BizTalk Server 2004 verarbeitet wird

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 870996 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie in Microsoft BizTalk Server 2004 mit Electronic Document Interchange (EDI) arbeiten und Sie konvertieren Zeichensatz für Dokumente, die bestimmte Zeichen in der UNOC enthalten, und bestimmte schwedischen Zeichen ein Problem auftreten. Sie können feststellen, dass das Ausgabedokument des Konvertierungsprozesses nicht die Daten widerspiegeln, die in das Eingabedokument des Konvertierungsvorgangs enthalten ist.

Ursache

Dieses Problem kann auftreten, wenn BizTalk Server 2004 ein EDI-Dokument verarbeitet, die bestimmte Zeichen im Zeichensatz UNOC und bestimmte schwedischen Zeichen enthält.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Microsoft BizTalk Server 2004, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
888751Wie Sie das neueste BizTalk Server 2004 Servicepack erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
Date         Time   Version        Size      File name
------------------------------------------------------------
30-Jul-2004  16:51  4.0.1126.5      24,064   Compeif.exe    
07-Oct-2003  00:21                 155,136   Edibtsmmc.msc
30-Jul-2004  16:50  4.0.1126.0      17,408   Edimmcresdll.dll 
30-Jul-2004  16:50  4.0.1126.11    188,416   Edimmcsnapin.dll 
30-Jul-2004  16:50  4.0.1126.195   851,968   Esp.dll 
30-Jul-2004  16:50  4.0.1126.13    172,032   Esproxy.dll 
30-Jul-2004  16:49  4.0.1126.22     65,536   Esp_btsoma.dll 
30-Jul-2004  16:49  4.0.1126.24    118,784   Esp_cli.dll 
30-Jul-2004  16:51  4.0.1126.2      21,504   Esp_err.dll 
30-Jul-2004  16:51  4.0.1126.26     23,040   Esp_files.dll 
30-Jul-2004  16:48  4.0.1126.49     86,016   Esp_gen.dll 
30-Jul-2004  16:51  4.0.1126.28     22,016   Esp_sqlsrv2000.dll 
30-Jul-2004  16:51  4.0.1126.25     22,528   Esp_srv.exe 
30-Jul-2004  16:49  4.0.1126.185   368,640   Esp_trans.dll 
30-Jul-2004  16:51  4.0.1126.16     32,768   Esp_voyager.dll 
30-Jul-2004  16:51  4.0.1126.1     167,936   Genins.exe 
18-Jun-2004  19:24                 488,650   Live.eif
30-Jul-2004  18:41  4.0.1126.0      61,440   Microsoft.biztalk.adapter.edi.common.dll 
30-Jul-2004  18:41  4.0.1126.0     110,592   Microsoft.biztalk.adapter.edi.manager.dll 
30-Jul-2004  18:42  4.0.1126.0      32,768   Microsoft.biztalk.adapter.edi.receiver.dll 
30-Jul-2004  18:41  4.0.1126.0      45,056   Microsoft.biztalk.adapter.edi.resourcer.dll 
30-Jul-2004  18:41  4.0.1126.0      20,480   Microsoft.biztalk.adapter.edi.sspi.dll 
30-Jul-2004  18:41  4.0.1126.0      36,864   Microsoft.biztalk.adapter.edi.transmitter.dll 
30-Jul-2004  18:41  4.0.1126.0      11,264   Microsoft.biztalk.extension.edi.errortext.dll 
30-Jul-2004  18:41  4.0.1126.0     643,072   Microsoft.biztalk.extension.edi.hatplugin.dll 
30-Jul-2004  18:42  4.0.1126.0      94,208   Microsoft.biztalk.extension.edi.schemaeditor.dll 
07-Oct-2003  13:12                  18,904   Receivehandler.xsd.tmpl
29-Jul-2004  16:42                 145,770   Receivelocation.xsd.tmpl
07-Oct-2003  12:47                   9,870   Sendhandler.xsd.tmpl
29-Jul-2004  16:40                 190,048   Sendporttransport.xsd.tmpl
30-Jul-2004  16:51  4.0.1126.5       7,680   Trigcon.exe 
05-Feb-2004  18:25                      82   Updateedi.bat
21-Jul-2004  00:19                 321,170   Updateedi.sql
30-Jul-2004  16:50  4.0.1126.4     167,936   Validins.exe 
30-Jul-2004  16:51  4.0.1126.34  1,228,800   Xsd2edi.exe 


Gehen Sie nach dem Extrahieren der Inhalt der Hotfix zusätzlichen folgendermaßen vor um diesen Hotfix zu installieren:
  1. Führen Sie das Setup.exe-Programm, um die wichtigsten Dateien zu installieren.
  2. Kopieren Sie die Genins.exe-Anwendung vom Paketspeicherort extrahierten in den folgenden Ordner:

    \Programme\Microsoft BizTalk Server-2004\EDI\Subsystem
  3. Kopieren Sie die Updateedi.bat-Datei und die Datei Updateedi.sql aus dem extrahierten Hotfix-Speicherort in den folgenden Ordner:

    \Programme\Microsoft BizTalk Server-2004\EDI\Adapter\Bin\Config
  4. Führen Sie die folgende Batchdatei:

    \Programme\Microsoft BizTalk Server 2004\EDI\Adapter\Bin\Config\UpdateEDI.bat
  5. Nachdem Sie die vorherigen Schritte durchgeführt haben, starten Sie die folgenden Dienste neu:
    • Base BizTalk EDI-Dienst
    • BizTalk-Dienst-BizTalk-Gruppe: BizTalkServerApplication

      Hinweis: Der Platzhalter BizTalkServerApplication ist der Name des standardmäßigen BizTalk Server Host. Dieser Name kann auf Ihrem System anders sein.
Nachdem Sie diesen Hotfix installieren und Serverdienste neu zu starten, haben Sie jetzt über Optionen, um die EDI-Umschlag Typen auszuwählen, die folgen:
  • UNOC
  • UNOD
  • UNOE
  • UNOF
  • UNOG

Status

Microsoft hat bestätigt, dass dies einen Fehler in den Microsoft-Produkten ist, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde in BizTalk Server 2004 Service Pack 1 behoben.

Eigenschaften

Artikel-ID: 870996 - Geändert am: Donnerstag, 1. Juni 2006 - Version: 2.4
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Standard Edition
Keywords: 
kbmt kbautohotfix kbbiztalk2004-2006swept kbbiztalk2004sp1fix kbbtsorchestration kbbug kbfix kbhotfixserver kbqfe KB870996 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 870996
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com