Internet Explorer no puede descomprimir el contenido HTTP cuando visita un sitio de Web

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Id. de artículo: 871205 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
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Síntomas

Cuando visita un sitio Web, Microsoft Internet Explorer no puede descomprimir contenido HTTP. Puede experimentar este problema cuando se cumplen todas las condiciones siguientes:
  • Codificación fragmentada está habilitado en el servidor Web.
  • Compresión HTTP está habilitada en el servidor Web.
  • Datos se envían desde el servidor Web mediante el protocolo HTTPS.
Puede experimentar síntomas distintos de este problema, dependiendo del contenido que Internet Explorer está intentando descomprimir. Por ejemplo, si el contenido que se envía por el servidor de sitio Web es un archivo JavaScript, puede recibir un error de secuencias de comandos.

Causa

Este problema se produce cuando se pierde una notificación entre WININET URLMON. Cuando se pierde una notificación, se pierde un fragmento codificado necesaria para la descompresión. Cuando un fragmento codificado es perdido, el descompresor gzip produce un error.

notas
  • WININET (Wininet.dll) es el componente que recibe los datos HTTP. URLMON (urlmon.dll) es el componente que implementa el descompresor gzip.
  • Compresión HTTP también se conoce como codificación gzip.

Solución

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Microsoft Internet Explorer 6 Service Pack 1 (SP1)
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   14-Jan-2005  17:21  6.0.2800.1489  581,632  Wininet.dll
Microsoft Internet Explorer 6 Service Pack 2 (SP2)
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   10-Jun-2005  01:38  6.0.2900.2695  658,944  Wininet.dll

Información de instalación

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Después de instalar este hotfix, siga estos pasos:
  1. Cierre Internet Explorer.
  2. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  3. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_RESET_SOCKET_FLAGS_KB871205
  4. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  5. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  6. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  7. En el cuadro datos del valor , escriba 00000001 y, a continuación, haga clic en Aceptar .
  8. Salga del Editor del Registro.

Solución

Para evitar este problema, deshabilite codificación fragmentada o deshabilite la compresión HTTP en el servidor Web. Para ver la configuración de compresión HTTP en Microsoft Internet Information Services (IIS) 6.0, siga estos pasos:
  1. Haga clic en Inicio , seleccione Herramientas administrativas y, a continuación, haga clic en Administrador de Internet Information Services (IIS) .
  2. Expanda el servidor Web, haga clic con el botón secundario en sitios Web y, a continuación, haga clic en Propiedades .
  3. Haga clic en la ficha servicio y, a continuación, ver las opciones que aparecen en la compresión HTTP .

Estado

Microsoft ha confirmado que es un problema de Microsoft Internet Explorer 6 Service Pack 1.

Más información

Este problema es más probable que se produzca en un equipo que está ejecutando el servidor HTTP Apache porque Apache HTTP Server puede utilizar la codificación fragmentada en cualquier tipo de archivo. Esto incluye archivos estáticos, como un archivo de JavaScript o un archivo .gif. Cuando se produce el problema que se describe en este artículo, el contenido que se almacena en la caché de Internet Explorer puede ser truncado o dañado.

Nota De forma predeterminada, Microsoft Internet Information Server no utiliza codificación fragmentada. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
278998Cómo habilitar la codificación con IIS de transferencia fragmentada
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 871205 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0 SP1
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbtshoot kbprb KB871205 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 871205

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