HTTP-innehåll expanderas inte i Internet Explorer när en webbplats besöks

Artikelöversättning Artikelöversättning
Artikel-id: 871205 - Visa produkter som artikeln gäller.
Viktigt! Den här artikeln innehåller information om hur du redigerar registret. Säkerhetskopiera registret innan du gör några ändringar i det. Se till att du vet hur du återställer registret om det uppstår ett problem. Om du vill ha mer information om hur du säkerhetskopierar, återställer och förändrar registret klickar du på följande artikelnummer för att läsa artikeln i Microsoft Knowledge Base:
256986 Beskrivning av registret i Microsoft Windows
Visa alla | Dölj alla

På den här sidan

Symptom

När en webbplats besöks kan det hända att HTTP-innehåll inte expanderas i Microsoft Internet Explorer. Problemet kan uppstå om samtliga följande förutsättningar föreligger:
  • Chunked-kodning har aktiverats på webbservern.
  • HTTP-komprimering har aktiverats på webbservern.
  • Data skickas från webbservern med hjälp av HTTPS-protokollet.
Problemet kan ge olika symptom beroende på vad för slags innehåll som ska expanderas. Om innehållet som skickas av webbplatsservern till exempel är en JavaScript-fil kan ett meddelande om skriptfel visas.

Orsak

Problemet uppstår när ett meddelande mellan WININET och URLMON går förlorat. När ett meddelande går förlorat försvinner ett kodat segment som krävs för expanderingen, och gzip-expanderaren fungerar inte.

Obs!
  • WININET (Wininet.dll) är komponenten som tar emot HTTP-data. URLMON (urlmon.dll) är komponenten som implementerar gzip-dekomprimeraren.
  • HTTP-komprimering kallas även gzip-kodning.

Lösning

Service Pack-information

Lös problemet genom att hämta den senaste Service Pack-versionen för Windows XP. Om du vill veta mer klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
322389 Skaffa den senaste Service Pack-versionen för Windows XP

Information om snabbkorrigeringen

En snabbkorrigering som stöds är tillgänglig från Microsoft. Den är emellertid endast avsedd att åtgärda det problem som beskrivs i artikeln. Använd den bara på datorer där detta problem uppstår. Snabbkorrigeringen kan komma att testas igen. Om ditt arbete inte störs alltför mycket av detta problem, rekommenderar vi att du väntar på nästa programuppdatering som innehåller den här snabbkorrigeringen.

Om snabbkorrigeringen är tillgänglig för hämtning anges detta högst upp i denna artikel. Annars kontaktar du Microsoft Support för att få snabbkorrigeringen.

Obs! Om det uppstår ytterligare problem eller krävs felsökning, måste du kanske skapa en särskild serviceförfrågan. Normala supportavgifter tas ut för ytterligare supportfrågor och problem som inte gäller den aktuella snabbkorrigeringen. En fullständig lista över telefonnummer till Microsoft Support finns på följande Microsoft-webbplats:
http://support.microsoft.com/contactus/?ws=support
Obs! Samtliga språk som snabbkorrigeringen är tillgänglig för visas i en lista. Om ditt språk inte finns med i listan beror det på att ingen snabbkorrigering är tillgänglig för språket.

Filinformation

Den engelska versionen av den här snabbkorrigeringen har filattributen som visas i följande tabell (eller senare). Datum och tider för dessa filer anges i UTC-tid (Coordinated Universal Time). Innan du läser filinformationen konverteras den till lokal tid. Du kan se skillnaden mellan UTC-tid och lokal tid på fliken Tidszon i verktyget Datum och tid på Kontrollpanelen.
Microsoft Internet Explorer 6 Service Pack 1 (SP1)
   Datum         Tid   Version           Storlek  Filnamn
   -------------------------------------------------------
   14-jan-2005  17:21  6.0.2800.1489  581 632  Wininet.dll
Microsoft Internet Explorer 6 Service Pack 2 (SP2)
   Datum         Tid   Version           Storlek  Filnamn
   -------------------------------------------------------
   10-jun-2005  01:38  6.0.2900.2695  658 944  Wininet.dll

Installationsinformation

Varning! Det kan uppstå allvarliga problem vid felaktiga ändringar av registret med hjälp av Registereditorn eller någon annan metod. Dessa problem kan medföra att du måste installera om operativsystemet. Microsoft kan inte garantera att problemen kan lösas. Ändra registret på egen risk.

Gör följande när du har installerat här snabbkorrigeringen:
  1. Avsluta Internet Explorer.
  2. Klicka på Start, Kör, skriv regedit och klicka på OK.
  3. Leta upp och klicka på följande registerundernyckel:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_RESET_SOCKET_FLAGS_KB871205
  4. Peka på Ny/NyttRedigera-menyn, och klicka sedan på DWORD-värde.
  5. Skriv Iexplore.exe och tryck på RETUR.
  6. Högerklicka på Iexplore.exe och klicka på Ändra.
  7. Skriv 00000001 i rutan Data, och klicka sedan på OK.
  8. Avsluta Registereditorn.

Workaround

Undvik det här problemet genom att inaktivera chunked-kodning eller inaktivera HTTP-komprimering på webbservern. Så här visar du inställningarna för HTTP-komprimering i Microsoft Internet Information Services (IIS) 6.0:
  1. Klicka på Start, peka på Administrationsverktyg och klicka på Internet Information Services-hanteraren.
  2. Expandera webbservern, högerklicka på mappen Webbplatser och klicka på Egenskaper.
  3. Klicka på fliken Tjänst, och visa sedan alternativen under HTTP-komprimering.

Status

Microsoft har bekräftat att det här är ett problem i Microsoft Internet Explorer 6 Service Pack 1.

Mer Information

Det är sannolikare att problemet uppstår på en dator med Apache HTTP Server, eftersom chunked-kodning kan användas på vilken slags fil som helst i Apache HTTP Server. Här ingår statiska filer som JavaScript-filer eller GIF-filer. När problemet som beskrivs i den här artikeln uppstår kan innehållet i Internet Explorer-cachen trunkeras eller skadas.

Obs! Chunked-kodning används inte som standard i Microsoft Internet Information Server. Om du vill veta mer klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
278998 Aktivera chunked-överföringskodning med IIS (Länken kan leda till en webbplats som är helt eller delvis på engelska)
De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.

Egenskaper

Artikel-id: 871205 - Senaste granskning: den 23 december 2008 - Revision: 3.1
Informationen i denna artikel gäller:
  • Microsoft Internet Explorer 6.0 SP1
Nyckelord: 
kbautohotfix kbhotfixserver kbqfe kbtshoot kbprb KB871205

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com