You receive a "Cannot delete this scheduled job" error message when you try to delete a scheduled task in Windows 2000

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Article ID: 871245 - View products that this article applies to.
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Symptoms

When you try to delete a scheduled task, you may receive the following error message, even though the scheduled task is deleted:
Cannot delete this scheduled job (0)

Cause

This problem only occurs if the following conditions are true:
  • The client code uses NetSchedule APIs to delete jobs. (NetSchedule is used by the At.exe service.)
  • The client code relies on NetSchedule for the success or failure notification. (Because the file is deleted, checking that the file is deleted by any other way will succeed.)

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is replaced by 873405.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   12-Jul-2004  18:21  4.71.2195.6960    122,128  Mstask.exe       

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 871245 - Last Review: November 2, 2013 - Revision: 4.0
Applies to
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbbug kbfix kbwin2000presp5fix kbHotfixServer kbqfe KB871245

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