Solução de problemas de um lote parcialmente lançado em Contas A pagar no Microsoft Dynamics SL

Este artigo fornece soluções para erros que ocorrem quando você tenta lançar um lote no Accounts Payable no Microsoft Dynamics SL.

Aplica-se a: Microsoft Dynamics SL 2011
Número de KB original: 871362

Sintomas

Quando você tenta lançar um lote em Contas a pagar no Microsoft Dynamics SL, o lote não é liberado. Ao investigar, você verá que o lote na caixa de diálogo Liberar Lotes AP (03.400.00) tem um status de Parcialmente Liberado. Você pode ver uma das seguintes mensagens de erro em um log de eventos:

System Message 8888 – Ocorreu um erro inesperado ao liberar o lote %s. Entre em contato com Solomon para obter assistência com este lote.

Mensagem do Sistema 6019 – O lote está sem saldo e não foi liberado.

Mensagem do Sistema 6909 – Outro processo já adicionou o item %s. O programa deve ser encerrado.

Motivo

Há várias causas possíveis para as mensagens de erro.

Observação

Se nenhuma das causas a seguir se aplicar, execute um script de depuração. Para obter mais informações sobre como executar um script de depuração, confira resolução 2.

  • Durante o processo de lançamento, a conexão entre o Microsoft Dynamics SL e a instância do SQL Server foi perdida. Confira a resolução 1.
  • Durante o processo de lançamento, você selecionou Cancelar na caixa de diálogo Liberar Lotes AP (03.400.00). Confira a resolução 1.
  • A mensagem de erro Mensagem do Sistema 6909 pode ocorrer quando você tenta liberar lotes de Reconciliação de Verificação da caixa de diálogo Reconciliação de Verificação (03.060.00) depois de tentar alterar o período para Postar.
  • No Microsoft Business Solutions – Solomon 6.0, o bug 7318 pode fazer com que a mensagem de erro da Mensagem do Sistema 6909 seja exibida.

Resolução

Observação

Se você estiver usando atualmente o Microsoft Dynamics SL 2011 ou versões posteriores, poderá excluir o lote da tela de entrada de dados e reinseri-lo novamente.

Solução 1

Tente liberar o lote novamente. Para fazer isso, siga estas etapas:

  1. Abra a caixa de diálogo Liberar Lotes AP (03.400.00).
  2. Selecione a caixa marcar selecionada que está ao lado do número do lote referenciado no log de eventos.
  3. Selecione Iniciar Processamento.

Solução 2

Se você estiver executando o Microsoft SQL Server 2000, execute o script AP_6019_DEBUG no Analisador de Consultas SQL e envie os resultados do script e o log de eventos para os Serviços de Suporte ao Cliente da Microsoft. Para fazer isso, siga estas etapas. Um vídeo também está disponível que percorre o processo de execução do script de depuração de AP:

  1. Baixe o arquivo AP_6019_DEBUG.sql .

    A Microsoft examinou esse arquivo em busca de vírus. A Microsoft usou o software de detecção de vírus mais atual que estava disponível na data em que o arquivo foi postado. O arquivo é armazenado em servidores aprimorados pela segurança que ajudam a evitar alterações não autorizadas no arquivo.

  2. Selecione Iniciar, aponte para Todos os Programas, aponte para o Microsoft SQL Server e selecione Analisador de Consultas.

  3. Na caixa de diálogo Conectar a SQL Server, digite o nome da instância de SQL Server nome na caixa de SQL Server e selecione SQL Server Autenticação.

  4. Digite sa na caixa Nome de logon , digite a senha na caixa Senha e selecione OK.

  5. Na barra de ferramentas Analisador de Consultas, selecione o banco de dados do aplicativo.

  6. No menu Ferramentas , selecione Opções e selecione a guia Resultados .

  7. Na caixa de destino Resultados padrão , selecione Resultados para Texto.

  8. Na caixa Formato de saída Resultados , selecione Tab Delimitado e, em seguida, selecione OK.

  9. Substitua XXXXXX pelo número do lote de seis dígitos.

  10. Para executar o script, pressione F5.

  11. Depois que o script terminar de ser executado, clique apenas na janela inferior.

  12. No menu Arquivo, selecione Salvar como.

  13. Na caixa Nome do arquivo , digite IncidentAP. Substitua Incidente pelo número de incidente real.

  14. Na caixa Salvar como tipo , selecione Arquivos de Relatório (*.rpt)e selecione Salvar.

  15. Feche este arquivo junto com o log de eventos e envie os arquivos para os Serviços de Suporte ao Cliente da Microsoft.

Se você estiver executando o Microsoft SQL Server 2005 ou o Microsoft SQL Server 2008, execute o script AP_6019_DEBUG em SQL Server Management Studio e envie os resultados do script e o log de eventos para os Serviços de Suporte ao Cliente da Microsoft. Para fazer isso, siga estas etapas:

  1. Baixe o arquivo de depuração AP_6019_DEBUG.sql.

    O arquivo a seguir está disponível para download do Microsoft Dynamics File Exchange Server: AP_6019_DEBUG.sql.

    A Microsoft examinou esse arquivo em busca de vírus. A Microsoft usou o software de detecção de vírus mais atual que estava disponível na data em que o arquivo foi postado. O arquivo é armazenado em servidores aprimorados pela segurança que ajudam a evitar alterações não autorizadas no arquivo.

  2. Inicie SQL Server Management Studio, entre no servidor e altere a formatação de saída. Para fazer isso, siga estas etapas:

    1. No menu Ferramentas, selecione Opções.
    2. Selecione Resultados de Consulta.
    3. Na caixa Destino Padrão para Resultados , selecione Resultados para texto.
    4. Expanda Resultados de Consulta e expanda a instância de SQL Server.
    5. Selecione Resultados para Texto.
    6. Na caixa Formato de saída , selecione Guia delimitada.
    7. Selecione a caixa Incluir cabeçalhos de coluna no conjunto de resultados marcar caixa.
    8. Selecione OK para fechar a caixa de diálogo Opções .
  3. No menu Arquivo , selecione Abrir, localize o arquivo AP_6019_DEBUG.sql e clique duas vezes no arquivo AP_6019_DEBUG.sql .

  4. Substitua o espaço reservado XXXXXX pelo número de lote de seis dígitos do lote suspenso.

  5. Pressione F5.

  6. Depois que o script for concluído, clique com o botão esquerdo no painel inferior da janela.

  7. No menu Arquivo, selecione Salvar como.

  8. Na caixa Nome do arquivo , digite IncidentAP.

    Observação

    Substitua o espaço reservado Incidente pelo número do lote suspenso.

  9. Na caixa Salvar como tipo , selecione Arquivos de Relatório (*.rpt).

  10. Selecione Salvar.

  11. Compacte o arquivo.

  12. Envie o arquivo compactado junto com o log de eventos para os Serviços de Suporte ao Cliente da Microsoft.

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