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Article ID: 872811 - Last Review: October 25, 2006 - Revision: 2.4

Active Directory User group names have a backward slash mark inserted and are truncated during Systems Management Server 2003 Active Directory User Discovery

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SYMPTOMS

When you use Active Directory User Discovery in Systems Management Server (SMS) 2003 to discover users in an organizational unit in Active Directory, some Active Directory user groups or names in the User Name discovery property array UserGroupName may have a backward slash mark (\) inserted. Additionally, the Active Directory user group name may be truncated after the backward slash mark.

CAUSE

This problem occurs when the Active Directory user name or group name contains a comma (,). When this problem occurs, SMS 2003 Active Directory User Discovery delimits the comma with a backward slash mark.

When this problem occurs, SMS 2003 adds the user or user group to the Data Discovery Record (DDR), and the user name is truncated after the backward slash mark. For example, if you have an Active Directory user group that is named "Test, User", the Active Directory User Discovery array property UserGroupName for that user appears as the following:
DomainName\Test\
When Active Directory User Discovery writes the DDR record, the name appears as the following, where DomainName is the name of your domain:
DomainName\Test \

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885643  (http://support.microsoft.com/kb/885643/ ) How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Dec-2003  12:20  2.50.2726.140     114,688  Adsource.dll     
   06-Aug-2000  09:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  10:05  2.0.1493.5011     855,312  Preinst.exe      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Hotfix installation instructions

To use the hotfix installer to install this hotfix, follow these steps.

Note This method is only for Intel-based computers.
  1. Create a folder in a location that your SMS site servers can use.
  2. Copy the SMS2003-RTM-KB872811-X86-ENU.exe update file to the new folder.
  3. From each primary SMS site server in your environment, use an account that has administrative credentials to log on to your site server.
  4. Quit the SMS Administrator console if it is running.
  5. Run the SMS2003-RTM-KB872811-X86-ENU.exe file, and then follow the instructions in the wizard.

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsmstopazfix kbfix kbbug KB872811

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