Article ID: 872953 - Last Review: December 3, 2007 - Revision: 1.9

FIX: HTTP headers are set incorrectly when the AddHeader function or the SetHeader function is called in IIS 6.0

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

You can call the AddHeader function or the SetHeader function for two similar headers. When you do this, the value of the second header replaces the value of the first header. For example, if you first call the AddHeader CustomHeader1:Value1 function, and then you call the AddHeader CustomHeader:Value2 function, the result is a single CustomHeader1:Value2 header. The value of the CustomHeader:Value1 header is incorrect. Also, the total number of headers is incorrect. You expect to see the following two headers:
  • CustomHeader1:Value1\r\n
  • CustomHeader:Value2\r\n

CAUSE

This problem occurs when the header name that you add is a subset of an existing header. For example, the header "CustomHeader" is a subset of the header "CustomHeader1." When this problem occurs, Microsoft Internet Information Services (IIS) version 6.0 updates the value of the existing header instead of adding a new header and its value.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size    File name
   -----------------------------------------------------
   23-Oct-2003  18:23  5.2.9354.0   26,112  _sfx_.dll

   Date         Time   Version       Size    File name
   -----------------------------------------------------
   27-Jul-2004  17:38  6.0.3790.196  342,016 W3core.dll 
  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
kbautohotfix kbfix kbbug kbwinserv2003presp1fix kbhotfixserver kbqfe KB872953