将操作系统升级到 Windows XP Home Edition 或 Windows XP Professional Edition 后 Outlook Express 不启动

文章翻译 文章翻译
文章编号: 873021 - 查看本文应用于的产品
重要说明:本文包含有关修改注册表的信息。修改注册表之前,一定要先对其进行备份,并且一定要知道在出现问题时如何还原注册表。有关如何备份、还原和编辑注册表的信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 Microsoft Windows 注册表说明
展开全部 | 关闭全部

本文内容

症状

如果您在将操作系统升级到 Microsoft Windows XP Home Edition 或 Microsoft Windows XP Professional Edition 后启动 Microsoft Outlook Express 6.0,Outlook Express 6.0 会自动退出,而且您不会收到错误消息。

原因

如果存在下列情况之一,就可能会出现此问题:
  • Outlook Express 标识损坏。
  • Microsoft Outlook Express 文件损坏。

解决方案

可使用下列方法之一解决此问题。

方法 1:删除损坏的 Outlook Express 标识,然后创建一个新的 Outlook Express 标识

要删除损坏的 Outlook Express 标识,请按照下列步骤操作。

警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证您可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。
  1. 单击“开始”,单击“运行”,在“打开”框中键入“regedit”,然后单击“确定”。
  2. 在“注册表编辑器”中,展开以下注册表子项:
    HKEY_CURRENT_USER\Identities\
  3. 找到要删除的用户 Outlook Express 标识,然后将其导出到一个临时文件夹中。为此,请按照下列步骤操作:
    1. 单击要删除的 Outlook Express 标识。
    2. 在“文件”菜单上,单击“导出”。
    3. 在“导出注册表文件”对话框中的“保存位置”列表中,选择临时文件夹的位置,然后在“文件名”框中键入文件名。
    4. 单击“保存”。
  4. 右键单击要删除的 Outlook Express 标识,然后单击“删除”。
  5. 当提示您确认删除时,请单击“是”。
  6. 退出注册表编辑器。
  7. 重新启动 Outlook Express。

创建一个新用户帐户,然后将所有电子邮件和通讯簿导入到创建的新用户帐户中。

注意:将电子邮件和通讯簿导入到新创建的用户帐户中之前,必须先创建它们的备份。

方法 2:手动重新安装 Outlook Express 文件

要手动重新安装 Outlook Express 文件,请按照下列步骤操作。

警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证您可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。
  1. 单击“开始”,单击“运行”,在“打开”框中键入“regedit”,然后单击“确定”。
  2. 找到并单击下面的注册表子项:
    HKEY_CURRENT_USER\Identities\
  3. 右键单击“标识”,然后单击“删除”。
  4. 当提示您确认删除时,请单击“是”。
  5. 对以下注册表子项重复步骤 2 至步骤 4:
    • HKEY_CURRENT_USER\Software\Microsoft\Outlook Express
    • HKEY_CURRENT_USER\Software\Microsoft\WAB
    • HKEY_LCAL_MACHINE\Software\Microsoft\Outlook Express
    • HKEY_LOCAL_MACHINE\Software\Microsoft\WAB
  6. 退出注册表编辑器。
  7. 打开 Windows 资源管理器,然后单击以下文件夹
    SystemDrive\Program Files\Outlook Express
    其中,SystemDrive 是安装所有关键操作系统文件的驱动器
  8. 删除“Outlook Express”文件夹中的所有文件和文件夹。
  9. 在“Windows 资源管理器”中,找到并单击以下文件夹:
    SystemDrive\Program Files\Common Files\System
  10. 在“System”文件夹中,找到并删除下列文件:
    • Wab32.dll
    • Wab32res.dll

      注意:从“Outlook Express”文件夹和“System”文件夹中删除了文件和文件夹后,Windows XP 文件保护 (WAP) 将使用位于 SystemRoot\System32 文件夹中的“Dllcache”文件夹将原始文件从缓存还原到“Outlook Express”文件夹和“System”文件夹中。
  11. 在注册表中注册复制的文件。为此,请按照下列步骤操作:
    1. 单击“开始”,单击“运行”,在“打开”框中键入 msimn /reg,然后单击“确定”。

      注意:此操作将重新生成位于
      HKEY_LOCAL_MACHINE\Software\Microsoft
      子项下方的
      Outlook Express
      子项。
    2. 单击“开始”,单击“运行”,然后在“打开”框中键入以下命令:

      regsvr32 “SystemDrive\Program Files\Common Files\System\wab32.dll”
    3. 单击“确定”。

      注意:此操作将重新生成位于
      HKEY_LOCAL_MACHINE\Software\Microsoft
      子项下方的
      WAB
      子项。
  12. 重新启动计算机,然后使用用于删除 Outlook Express 注册表子项的同一用户帐户登录到计算机上。

    注意:此操作将自动重新生成您从
    HKEY_CURRENT_USER
    子项中删除的所有 Outlook Express 注册表子项。

属性

文章编号: 873021 - 最后修改: 2006年12月8日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft Outlook Express 6.0
关键字:?
kbprb KB873021
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com