文書番号: 873148 - 対象製品


重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Windows XP Service Pack 2 (SP2) をインストールするときに、次のいずれかの問題が発生することがあります。
  • Service Pack をインストールできません。
  • 次のエラー メッセージが表示されます。
    Service Pack 2 セットアップ ...
    アクセスが拒否されました。
  • Svcpack.log ファイルに、次のエラー メッセージが書き込まれます。
    DoRegistryUpdates failed

原因

この問題は、1 つ以上のレジストリ キーのアクセス許可が、そのレジストリ キーを更新できないように制限されている場合に発生することがあります。レジストリ キーの更新に失敗すると、セットアップ プログラムでエラーが発生する場合があります。

回避策

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

: 以下の手順を実行するには、Administrators セキュリティ グループのメンバである必要があります。

この問題を回避するには、次の手順を実行します。

手順 1 : レジストリの更新にエラーがあることを確認する

  1. Svcpack.log ファイルを開きます。デフォルトで、このファイルは C:\Windows フォルダにあります。Svcpack.log ファイルを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、%windir%\svcpack.log と入力し、[OK] をクリックします。
  2. [編集] メニューの [検索] をクリックします。
  3. [検索する文字列] ボックスに DoRegistryUpdates failed と入力し、[次を検索] をクリックします。
  4. "DoRegistryUpdates failed" というエラー メッセージが見つかった場合は、レジストリ更新の妨げとなっている問題が存在します。たとえば、以下のようなエラー メッセージが該当します。
    xxxx.xxx: DoInstallation:DoRegistryUpdates failed
    xxxx.xxx: アクセスが拒否されました。
    xxxx.xxx: Message displayed to the user: アクセスが拒否されました。
    : xxxx.xxx は、各メッセージのタイムスタンプを表します。

手順 2 : 特定のレジストリ キーを検索する

レジストリのアクセス許可に問題があることを確認したら、対応するレジストリ キーを見つけ、アクセス許可を変更して、Windows XP SP2 が正常にインストールされるようにする必要があります。これを行うには、次の手順を実行します。
  1. 詳細ログを有効にして、Setupapi.log ファイル内のレジストリ情報を含めます。 詳細ログを有効にする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    906485 Windows XP ベースのコンピュータで詳細ログを有効にする方法
    : デフォルトでは、レジストリ キーは Setupapi.log ファイルには出力されません。

    詳細ログを有効にした後、Windows XP SP2 を再度インストールし、レジストリ キーをキャプチャします。
  2. Setupapi.log ファイルを開きます。デフォルトで、このファイルは C:\Windows フォルダにあります。Setupapi.log ファイルを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、%windir%\setupapi.log と入力し、[OK] をクリックします。
  3. Ctrl キーを押しながら End キーを押して、Setupapi.log ファイルの末尾までスクロールします。
  4. [編集] メニューの [検索] をクリックします。
  5. [検索する文字列] ボックスにエラー 5: アクセスが拒否されましたと入力し、[検索する方向] で [上へ] をクリックし、[次を検索] をクリックします。

    たとえば、以下のような行が該当します。
    #-007 レジストリ キー HKCR\vnd.ms.radio を削除しています
    #E033 エラー 5: アクセスが拒否されました。
    : "アクセスが拒否されました。" の前の行が、問題のレジストリ キーを示しています。このキーをメモします。この場合、HKCR は "HKEY_CLASSES_ROOT" というレジストリ ハイブを表し、"vnd.ms.radio" は、そのレジストリ ハイブの下にあるサブキーの 1 つを表します。

手順 3 : レジストリのアクセス許可を変更する

誤ったアクセス許可が指定されているレジストリ サブキーが見つかったら、そのサブキーのアクセス許可を変更します。

レジストリ サブキーのアクセス許可を変更するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、regedit と入力し、[OK] をクリックして、レジストリ エディタを起動します。
  2. 手順 2d. でメモしたレジストリ サブキーを見つけて右クリックし、[アクセス許可] をクリックします。
  3. [グループ名またはユーザー名] で、[Administrators] をクリックします。
  4. [Administrators のアクセス許可] で、以下のアクセス許可の [許可] チェック ボックスをオンにします。
    • フル コントロール
    • 読み取り
  5. [適用] をクリックした後、[OK] をクリックします。
  6. [ファイル] メニューの [レジストリ エディタの終了] をクリックして、レジストリ エディタを終了します。
これで、レジストリ サブキーのアクセス許可の問題は解決され、Windows XP SP2 は正常にインストールされます。Windows XP SP2 をインストールするときに引き続き問題が発生する場合は、必要に応じてこの手順を繰り返します。

プロパティ

文書番号: 873148 - 最終更新日: 2005年11月17日 - リビジョン: 5.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
キーワード:?
kberrmsg kbtshoot kbnofix kbperformance kbappcompatibility kbupgrade kbsetup kbprb kbmaintenance KB873148
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com