Pri pokuse o nainštalovanie balíka Windows XP Service Pack 2 alebo Windows Server 2003 Service Pack 1 sa zobrazí chybové hlásenie informujúce o odmietnutí prístupu

Preklady článku Preklady článku
ID článku: 873148 - Zobraziť produkty, ktorých sa tento článok týka.


Dôležité upozornenie: Tento článok obsahuje informácie o úprave databázy Registry. Pred úpravou je potrebné databázu Registry zálohovať. Mali by ste tiež poznať postup pri obnovení databázy Registry v prípade, že sa vyskytne problém. Ďalšie informácie o zálohovaní, obnovení a úprave databázy Registry získate po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
256986 Popis databázy Registry systému Microsoft Windows
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Pri pokuse o nainštalovanie balíka Microsoft Windows XP Service Pack 2 (SP2) alebo Microsoft Windows Server 2003 Service Pack 1 (SP1) sa môže vyskytnúť ľubovoľný z nasledujúcich problémov:
  • Nie je možné nainštalovať balík Service Pack.
  • Zobrazí sa nasledujúce chybové hlásenie:
    Inštalácia balíka Service Pack zlyhala. Prístup je odmietnutý.
  • Súbor Svcpack.log obsahuje nasledujúce chybové hlásenie:
    Proces DoRegistryUpdates zlyhal.

PRICINA

Tieto problémy sa môžu vyskytnúť, ak sú obmedzené povolenia pre niektoré kľúče databázy Registry spôsobom, ktorý bráni v ich aktualizovaní. Zlyhanie aktualizácie kľúča databázy Registry môže spôsobovať zlyhanie inštalačného programu.

RIEŠENIE

Upozornenie: Ak databázu Registry upravíte nesprávne pomocou Editora databázy Registry alebo iným spôsobom, môžete spôsobiť vážne problémy. Tieto problémy môžu vyžadovať preinštalovanie operačného systému. Spoločnosť Microsoft nemôže zaručiť odstránenie takýchto problémov. Úpravy databázy Registry vykonávate na vlastné riziko.

Poznámka. Na vykonanie týchto krokov musíte byť členom skupiny zabezpečenia Administrators.

Ak chcete tento problém obísť, vykonajte tieto kroky.

Krok 1: Overenie, či zlyháva aktualizácia databázy Registry

  1. Otvorte súbor Svcpack.log. Tento súbor sa na základe predvoleného nastavenia nachádza v priečinku C:\Windows. Ak chcete otvoriť súbor Svcpack.log, kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz %windir%\svcpack.log a potom kliknite na tlačidlo OK.
  2. V ponuke Úpravy kliknite na položku Hľadať.
  3. Do poľa Hľadať zadajte DoRegistryUpdates zlyhal a potom kliknite na tlačidlo Hľadať ďalej.
  4. Ak sa nájde chybové hlásenie Proces DoRegistryUpdates zlyhal, vyskytuje sa problém, ktorý bráni v aktualizovaní databázy Registry. Chybové hlásenie sa bude podobať nasledujúcemu príkladu:
    xxxx.xxx: Proces DoInstallation:DoRegistryUpdates zlyhal.
    xxxx.xxx: Prístup bol odmietnutý.
    xxxx.xxx: Hlásenie zobrazené používateľovi: Prístup bol odmietnutý.
    Poznámka. xxxx.xxx predstavuje časovú pečiatku jednotlivých položiek.

Krok 2: Vyhľadanie konkrétneho kľúča databázy Registry

Ak zistíte, že sa vyskytlo zlyhanie povolení databázy Registry, je potrebné vyhľadať správny kľúč databázy Registry a zmeniť povolenia a umožniť úspešné nainštalovanie balíka Windows XP SP2 alebo Windows Server 2003 SP1. Postupujte nasledovne:
  1. Zahrňte informácie databázy Registry do súboru Setupapi.log povolením zapisovania do denníka s potvrdením. Ďalšie informácie o povolení zapisovania do denníka s potvrdením získate po kliknutí na nasledujúce číslo článku databázy Microsoft Knowledge Base:
    906485 Povolenie zapisovania do denníka s potvrdením v počítači so systémom Windows XP (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
    Poznámka. Na základe predvoleného nastavenia sa kľúče databázy Registry nezapisujú do súboru Setupapi.log.

    Po povolení zapisovania do denníka s potvrdením znovu nainštalujte balík Windows XP SP2 alebo Windows Server 2003 SP1, aby sa podarilo zachytiť kľúč databázy Registry.
  2. Otvorte súbor Setupapi.log. Tento súbor sa na základe predvoleného nastavenia nachádza v priečinku C:\Windows. Ak chcete otvoriť súbor Setupapi.log, kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz %windir%\setupapi.log a potom kliknite na tlačidlo OK.
  3. Stlačte kombináciu klávesov CTRL+END a prejdite na koniec súboru Setupapi.log.
  4. V ponuke Úpravy kliknite na položku Hľadať.
  5. Do poľa Hľadať zadajte hodnotu Chyba 5: Prístup bol odmietnutý v časti Smer, kliknite na položku Nahor a potom kliknite na položku Hľadať ďalej.

    Nájdená položka v súbore Setupapi.log by sa mala podobať na nasledujúci príklad:
    #-007 Deleting registry key HKCR\vnd.ms.radio
    #E033 Error 5: Access is denied.
    Poznámka. Riadok pred položkou "Access is denied" označuje problémový kľúč databázy Registry. V tomto prípade reťazec HKCR predstavuje podregister databázy Registry, ktorý je označený ako HKEY_CLASSES_ROOT. "vnd.ms.radio" je jeden podkľúč, ktorý sa nachádza v tomto podregistri databázy Registry.

Krok 3: Vynulovanie povolení databázy Registry

Keď ste našli podkľúč databázy Registry, ktorý má nesprávne povolenia, vykonajte ich aktualizáciu.

Ak chcete aktualizovať povolenia podkľúča databázy Registry, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz regedit a potom kliknite na tlačidlo OK. Spustí sa Editor databázy Registry.
  2. Vyhľadajte a pravým tlačidlom kliknite na podkľúč databázy registry, ktorý ste si poznačili v kroku 2d, a kliknite na položku Povolenia.
  3. V časti Názvy skupín alebo mená používateľov kliknite na položku Administrators.
  4. V časti Povolenia pre správcov sa uistite, že je pri nasledujúcich položkách začiarknuté políčko Zapnúť:
    • Úplné ovládanie
    • Čítanie
  5. Kliknite na tlačidlo Použiť a potom kliknite na tlačidlo OK.
  6. V ponuke Súbor kliknutím na položku Skončiť ukončite Editor databázy Registry.
Problém s podkľúčom databázy Registry by sa mal odstrániť a balík Windows XP SP2 alebo Windows Server 2003 SP1 by sa mal úspešne nainštalovať. Ak sa vyskytnú ďalšie problémy pri pokuse o nainštalovanie balíka Windows XP SP2 alebo Windows Server 2003 SP1, zopakujte podľa potreby tieto kroky.

Vlastnosti

ID článku: 873148 - Posledná kontrola: 13. apríla 2007 - Revízia: 5.2
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Service Pack 2, pri použití s produktom:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional Edition
  • Microsoft Windows Server 2003 Service Pack 1, pri použití s produktom:
    • Microsoft Windows Server 2003 Standard Edition
    • Microsoft Windows Server 2003 Datacenter Edition
    • Microsoft Windows Server 2003 Enterprise Edition
    • Microsoft Windows Server 2003 Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Kľúčové slová: 
kberrmsg kbtshoot kbnofix kbperformance kbappcompatibility kbupgrade kbsetup kbprb kbmaintenance KB873148

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com